Hallo,

ich habe vor kurzem einen 22PFL3507H (TV, 22") gekauft und ihn in mein häusliches LAN integriert. Der Zufriff auf die per DLNA freigegebenen Verzeichnisse/Inhalte meines NAS funktioniert soweit gut, jedoch sind viele Filme und Videos nicht abspielbar (Meldung: Audio/Video-Codec wird nicht unterstützt) obwohl sie in einem Format vorliegen, das laut Handbuch (S. 61/62) vom TV unterstützt wird. Auch eine erneute Transkodierung führt meistens zu keinem Erfolg.

Beispiel:

Folgendes Video wird abgespielt (MediaInfo):

Format : MPEG-4
Format-Profil : Base Media / Version 2
Codec-ID : mp42
Dateigröße : 663 MiB
Dauer : 43min
Modus der Gesamtbitrate : variabel
Gesamte Bitrate : 2 120 Kbps
Kodierungs-Datum : UTC 2012-08-25 16:16:48
Tagging-Datum : UTC 2012-08-25 16:16:51
Kodierendes Programm : mp4creator 1.4.4

Video
ID : 1
Format : AVC
Format/Info : Advanced Video Codec
Format-Profil : Baseline@L1.3
Format-Einstellungen für CABAC : Nein
Format-Einstellungen für ReFrames : 2 frames
Codec-ID : avc1
Codec-ID/Info : Advanced Video Coding
Dauer : 43min
Bitraten-Modus : variabel
Bitrate : 1 992 Kbps
Breite : 864 Pixel
Width_Original/String : 852 Pixel
Höhe : 480 Pixel
Bildseitenverhältnis : 16:9
Ursprüngliches Bildseitenverhältnis : 16:9
Modus der Bildwiederholungsrate : konstant
Bildwiederholungsrate : 25,000 FPS
ColorSpace : YUV
ChromaSubsampling : 4:2:0
BitDepth/String : 8 bits
Scantyp : progressiv
Bits/(Pixel*Frame) : 0.192
Stream-Größe : 623 MiB (94%)
Sprache : Englisch
Kodierungs-Datum : UTC 2012-08-25 16:16:48
Tagging-Datum : UTC 2012-08-25 16:16:51

Audio
ID : 2
Format : AAC
Format/Info : Advanced Audio Codec
Format-Profil : LC
Codec-ID : 40
Dauer : 43min
Source_Duration/String : 43min
Bitraten-Modus : variabel
Bitrate : 126 Kbps
maximale Bitrate : 158 Kbps
Kanäle : 2 Kanäle
Kanal-Positionen : Front: L R
Samplingrate : 44,1 KHz
Stream-Größe : 39,3 MiB (6%)
Source_StreamSize/String : 39,3 MiB (6%)
Sprache : Englisch
Kodierungs-Datum : UTC 2012-08-25 16:16:51
Tagging-Datum : UTC 2012-08-25 16:16:51[/SIZE][/FONT]



Folgendes Video wird nicht abgespielt (Video- und Audiokodec nicht unterstützt):
Allgemein


Format : MPEG-4
Format-Profil : Base Media / Version 2
Codec-ID : mp42
Dateigröße : 518 MiB
Dauer : 43min
Modus der Gesamtbitrate : variabel
Gesamte Bitrate : 1 657 Kbps
Kodierungs-Datum : UTC 2012-08-25 15:53:34
Tagging-Datum : UTC 2012-08-25 15:58:25
Kodierendes Programm : HandBrake 0.9.8 2012071700

Video
ID : 1
Format : AVC
Format/Info : Advanced Video Codec
Format-Profil : Main@L3.0
Format-Einstellungen für CABAC : Ja
Format-Einstellungen für ReFrames : 4 frames
Codec-ID : avc1
Codec-ID/Info : Advanced Video Coding
Dauer : 43min
Bitraten-Modus : variabel
Bitrate : 1 500 Kbps
Breite : 852 Pixel
Höhe : 480 Pixel
Bildseitenverhältnis : 16:9
Modus der Bildwiederholungsrate : konstant
Bildwiederholungsrate : 25,000 FPS
ColorSpace : YUV
ChromaSubsampling : 4:2:0
BitDepth/String : 8 bits
Scantyp : progressiv
Bits/(Pixel*Frame) : 0.147
Stream-Größe : 467 MiB (90%)
verwendete Encoder-Bibliothek : x264 core 120
Kodierungseinstellungen : cabac=1 / ref=1 / deblock=1:0:0 / analyse=0x1:0x111 / me=hex / subme=2 / psy=1 / psy_rd=1.00:0.00 / mixed_ref=0 / me_range=16 / chroma_me=1 / trellis=0 / 8x8dct=0 / cqm=0 / deadzone=21,11 / fast_pskip=1 / chroma_qp_offset=0 / threads=12 / sliced_threads=0 / nr=0 / decimate=1 / interlaced=0 / bluray_compat=0 / constrained_intra=0 / bframes=3 / b_pyramid=2 / b_adapt=1 / b_bias=0 / direct=1 / weightb=1 / open_gop=0 / weightp=1 / keyint=250 / keyint_min=25 / scenecut=40 / intra_refresh=0 / rc_lookahead=10 / rc=abr / mbtree=1 / bitrate=1500 / ratetol=1.0 / qcomp=0.60 / qpmin=3 / qpmax=69 / qpstep=4 / ip_ratio=1.40 / aq=1:1.00
Kodierungs-Datum : UTC 2012-08-25 15:53:34
Tagging-Datum : UTC 2012-08-25 15:58:25
colour_primaries : BT.601 NTSC
transfer_characteristics : BT.709
matrix_coefficients : BT.601

Audio
ID : 2
Format : AAC
Format/Info : Advanced Audio Codec
Format-Profil : LC
Codec-ID : 40
Dauer : 43min
Bitraten-Modus : variabel
Bitrate : 160 Kbps
maximale Bitrate : 213 Kbps
Kanäle : 2 Kanäle
Kanal-Positionen : Front: L R
Samplingrate : 48,0 KHz
Video Verzögerung : 80ms
Stream-Größe : 50,0 MiB (10%)
Kodierungs-Datum : UTC 2012-08-25 15:53:34
Tagging-Datum : UTC 2012-08-25 15:58:22



Beide Videos nutzen als Video-Codec: H264 - MPEG-4 AVC, Audio: AAC. Das erste wurde mit der Software MP4Ccreator transkodiert, das zweite mit Handbrake.
Auch bei anderen Containern (wie MKV/AVI) scheint die Wiedergabe mal zu klappen, mal nicht.
Dazu muss man sagen, dass beide Videos unter Windows wie auch unter Linux einwandfrei wiedergegeben werden (VLC-Player und Quicktime Player). Ebenso problemlos läuft die Ausgabe auf einem Mediaplayer von Asus.

Wo klemmt's bei Philips?

Schöne Grüße