View Full Version : HTS3367 Firmware upgrade did not work

01-06-2013, 10:05 AM
Hello to the forum !

Yesterday i tried to upgrade my HTS3367/12, because we often had troubles with new DVDs ( original ones - "no disk" ). So i thought it would be a good idea to check the firmware - 00.27.??

After copying the 00.35.00 to an USB stick i follwed the installprocedure. The display showed WRITE und counted down several times. I think it was the third time, when it got stuck on WRITE01, so i waited for about an hour - then i turned the system on/off. Since then nothing else, than a running fan and one short flashing of the powerled after connecting to the power, happens.

Could somebody help me "reloading" the system, or is it gone forever ?

Thanks in advance


01-06-2013, 02:43 PM
Can you still turn on the device and enter the menu? Check if you can see if the firmware is upgraded. If not:

- Format the USB device you use for upgrading the firmware;
- Make sure you only copy the firmware files to the usb stick;
- Try to update again using the philips install procedure.

If this doesn't work you might try a different USB stick and follow the above instructions. Maybe this works?

01-06-2013, 02:59 PM
As i mentioned above, the device does not start any longer. After powering up, the fan on the backside starts and for a very short time the power-led is lighting up once - nothing else.

I already tried using a USB-stick at startup-time,like booting from USB device, but this although doesn't work.

Any other ideas ? Is there some kind of press-button-combination to start from USB ?

01-08-2013, 03:42 PM
Hi Joe,

Maybe best to first try and start it up again ( if possible :( ). Take out the USB first and try some things. Did you unplug already for some minutes and plugged it back in? If so and not working try to unplug, press the power button and keep it pressed for some time while putting back the mains.....

Let me know and good luck

01-09-2013, 08:36 AM
Its up and running again !

Unfortunately normal procedures didn't help - as a last chance and to avoid electronic garbage i tried the technical way ( at one's own risk ).

With the help of the www we could find a good instruction: How to recover a dead player using a serial cable.
After soldering the electronic-parts for connecting the hts3367 to a pc via rs232, i could upload the 00.35.00 HTS336x.bin image.
Then following the normal USB upgrade-procedure - this time with a new fat32 formatted stick and only HTS-SW on it ;-) - everything is fine.

Even my problem with reading the new DVDs is gone !


Philips - Katerina
08-24-2015, 11:30 AM
Hello participants of the thread and forum members in general!

Hopefully your issue was dealt with and you are no longer facing it. Since the thread has been silent for some time now, I will proceed by closing it. If you still have the same question about the same issue or any similar issues arise feel free to start a new thread or contact one of us moderators to open this thread again.

Kind regards
Philips Katerina