PDA

View Full Version : BDP 7600 no video signal



krisv5
01-10-2013, 01:27 PM
I have a strange problem. I connected my BDP7600 to my onkyo HTR-548 receiver via HDMI. The Receiver is connected to Philips 21:9 TV through HDMI. There's also a settop box, PS3 and Xbox connected to the receiver, all with hdmi. When I choose the Blu Ray player on the receiver the TV shows the no videosignal sign on the TV. This appeared after I installed the newest firmware on the TV 14.104. I checked cables, connected to different inputs on the receiver, switched ARC and all other options on and off, but the BDP7600 still gives no signal. All other devices work fine.
If I connect the 7600 directly to the TV via HDMI Side input it works fine.
I've read something about handshaking protocoll in HDMI standards. Can this be the problem between receiver and Blu Ray player? The player used to work fine through the receiver before I've made the upgrade on the TV (21:9 50inch PFL 7956H version)

Pacman
01-15-2013, 02:44 PM
Could you try to test this same on a different TV? It looks like a Tv issue so try if and when possible..

krisv5
01-15-2013, 02:52 PM
I can not try it with a TV, but i've connected the BDP to a montior and it works fine. Even if directly connected to the TV it works (through HDMI side input) The problem occured when I recently updated the firmware of the TV to the latest version. I can not find the earlier firmware version, so I can't try downgrading. It stopped working after the firmware update of the TV.

Oscar
01-18-2013, 08:55 AM
Might be good to post this into the TV part or maybe the mod can move it to there as this is a TV issue