View Full Version : BDP7500, The Amazing Spider-Man and Firmware

01-17-2013, 10:13 AM
Two years ago I purchased the BDP7500BL/05 mainly because the 7.1 analogue outputs suited my older Denon receiver and the good reviews it had had. To be honest it has spun every blu-ray disc I have inserted in it until I was given 'The Amazing Spider-Man' (2012) this Christmas, no go!

Firstly it couldn't get past crappy advert for the Amazing app that goes with the blu-ray which I have now watched close to several thousand times. A quick Google revealed that PS3 users were experiencing the same thing and disconnecting the PS3 from the Internet solved the issue. I did the same with the 7500 and voilą instead of the picture freezing and locking up after the advert had finished the disc moved smoothly into the main menu.

So I select 'play' and we're off, the Columbia logo comes up and the titles start, so far, so good. The film begins, there is a shot of a stair case....FREEZE! The player locked up, so I try again and again and the player locks in exactly the same place! So after rebooting and watching that damn advert for the app for the millionth time I decided to skip to another chapter from the main menu, it plays...for 3 seconds then FREEZE! :(

So I exchanged the disc for another...exactly the same results and therefore I returned the disc and got my money back. But after a thought I logged a support call with Philips and they got back to me (phoned me on a Sunday) and took the details of the disc and player. They said they would get back to me but it is probably some new features on the disc causing the problems...what new feature screws the disc up when it is simply just 'playing' after disabling the Internet the menus worked fine! Bring back HD-DVD, that just worked! If I was trying to do something fancy I would understand but all I did was press 'play' :confused:

Philips asked if I had had the latest firmware on the player (which at the time was v1.10) now here lies the confusion. At the time I wasnt 100% sure of my model number as it was set in a cabinet and I couldnt get to the label on the rear but I was sure it was a BL/05 (for which the latest firmware is v1.10) but then again it might be a BL/12, for which the latest firmware is v1.12. So before I returned the disc I tried to upgrade my player with v1.12 assuming that if my player is an 05 it will probably turn its nose up at the upgrade? And if it is a BL/12 it will work! So guess what? It successfully upgraded to v1.12, so I tried old Spidey one more time! NO GO! Exactly the same results. :(

So nothing more from Philips for a few days and I decided to yank my player out of the cabinet and low and behold, my player clearly states it's a BL/05....So what firmware should I be running? This morning I went onto a chat session on the Philips site and the guy said v1.12 is the latest for my player? So now I'm very confused and wondering whether to roll back v1.10 which is clearly stated for my BDP7500BL/05.

So I was just wondering, is there any other BDP7500 users out there that have had trouble with the Amazing Spider-Man (2012) and if there are (or not even) what firmware do you run on your BDP7500's? v1.10 or v1.12???

Any feedback would be greatly appreciated, as I honestly don't see why one should have to bin their blu-ray players every 2 years due to disc problems! And we all know that blu-ray players with 7.1 analogue outputs are getting as rare as rocking horse sh*t these days!


01-18-2013, 08:52 AM
It looks you already gave the EAN ocde then to them. This is what they normally need for checking the discs

01-18-2013, 10:52 AM
Yes the guy from Philips took the bar code of the Spider-Man disc, so fingers crossed they may be able to do something.

Thing is though I still have the confusion over which firmware I should be running? I rolled back the firmware to v1.10 as I have now confirmed that my player is a 7500BL/05 but when I check the version info it states that the firmware is v1.10 all right but it says "BDP7500/12" in the top left hand corner????

Any thoughts???

01-27-2013, 09:40 AM
I think you accidentally "flashed" (not sure if that's what it's called) your blu-ray player when you installed another model's firmware on yours. This can lead to instability or even unrecoverable damage.
Hence, you best wait for a reply from the technical support staff before further experimenting with uninstalling/reinstalling firmware.

01-28-2013, 06:53 AM

You could be right and that would explain that BDP7500/12 now shows in the version info? The Philips teccie that called me explained that the /12 was the European model and the /05 was for the UK market. It allows me to apply v1.10 and v1.12 irrespectively so I am wondering (hoping) that it has not damaged the firmware as essentially they are the same player. If you look at the release notes for both firmware versions they are indentical apart from one extra entry for v1.12.
I will log a seperate support call for the firmware issue and see if Philips can give me an answer on this. As a test last night I popped in a copy of 'Wolverine-Origins' which some time back did not play correctly until I had upgraded the firmware to v1.10. Even though I am now running v1.12 it played absolutely fne and bearing in mind that I have now also disconnected the player from the Internet, it loaded up in seconds. So I feel that (hopefully) the damage is not to severe (if any).