View Full Version : MCI300/5 stuck in start up

01-27-2013, 04:56 AM

I have an MCI300/5 that is stuck in start-up

It's been packed away in storage for 2 years, got in unboxed and was working perfectly. I ran a firmware update and now it is stuck in starting up. I have powered off for long period but no change

Any ideas

02-02-2013, 08:34 PM

its likely to be the capacitors on the power supply board - would require a repair


alfa 147
11-06-2013, 12:35 PM
same problem over here, it stuck up on "starting system please wait" after running in wadm a firmware upgrade. What was the combination for hard reset, pressing open close button while inserting the power cable?

Philips - Rafal
11-07-2013, 11:14 AM
Dear alfa 147,

Please bear with us while we are checking this issue too.

Philips Moderation Team

Philips - Rafal
11-08-2013, 07:52 AM
Dear alfa 147,

This looks like a hardware issue as mentioned by jphenrick. It will require repair.
Please contact your local repair centre.

Kind regards,
Philips Moderation Team

alfa 147
11-11-2013, 09:06 AM
Problem solved, thanks @Philips - Rafal