PDA

View Full Version : DS8550/37 Bluetooth connectivity



lordoftheclick
02-03-2013, 11:14 PM
I have had DS8550/37 for little over 2 years now. I did not do my research prior to buying a dock, so I had a Future Shop sales person recommend me this dock after I said I was looking for a Bluetooth and/or wireless connectivity as a main feature I was looking for. We have two iPhone 4 in the house, as well as first gen iPad, and we are hugely disappointed.:(

I have never been able to pair this dock via Bluetooth to any of my devices, not on iOS 5 or iOS 6. I have Sync in my car and it's always paired with my devices, so I know my devices connect flawlessly via bluetooth, just not with the dock. :confused:

Upon attempting to pair, bluetooth button on my dock will blink fast for a while, and then slow down, but the connection is never made with my phones or iPad. I do have bluetooth enabled on my phone and I keep it just a few inches away from the dock.

So it's not the distance from the dock, not my phone settings, and I'm never prompted for any "0000" passwords to pair devices. And you can imagine I have tried rebooting and cold resetting my phones, reinstaling Dockstudio many times, tried to pair while docked and when not docked and I think I have exhausted my options here.

Any help greatly appreciated to get this Christmas present doing what it was supposed to do.

Kiro
02-04-2013, 02:52 PM
Hi,

have you tried to pair the devices out from DockStudio App, directly in the Bluetooth settings of your iPhones?
Is your DS8550 shown in the devices list?

lordoftheclick
02-04-2013, 08:44 PM
Hi,

have you tried to pair the devices out from DockStudio App, directly in the Bluetooth settings of your iPhones?
Is your DS8550 shown in the devices list?


Yes, I have. That would usually be the first thing I try, without the DockStudio app. And I have tried with dock on battery power as well as while plugged in.

And, no, DS8550 is NEVER shown in the devices list

Is there a firmware update for my dock? Or am I the only one to have a dock with such problem?

Kiro
02-05-2013, 09:00 AM
Hi,

I'm afraid that your Docking station needs servicer intervention... this behaviour is quite suspicious :confused:

lordoftheclick
02-06-2013, 09:03 PM
Thank You, Kiro, for your help!
I hope someone else could shine more light on this problem, and, in the meantime, I'll go through the papers to see how good was the warranty I got with this product...

Was there really nobody with this kind of a problem before?
Is this then a chance for Philips customer service to shine? What would be my next step in order to have this problem resolved?

Kiro
02-07-2013, 10:32 AM
Hi,

I suggest to contact your local Philips Customer Care. They will provide you all the information about authorized service centre in your zone.

Good luck! ;)

lordoftheclick
02-08-2013, 06:05 PM
No, they are going to charge me money for repair, and I'll rather buy something else that is new and working, than sink money into repairing faulty stuff. when you buy lemon, you never know how big of a lemon it is until you start repairing it. Like you said, Kiro, I need luck, and I tend not to count on it, so next time, I will do my research first

JOST0319
03-08-2013, 06:18 PM
No, they are going to charge me money for repair, and I'll rather buy something else that is new and working, than sink money into repairing faulty stuff. when you buy lemon, you never know how big of a lemon it is until you start repairing it. Like you said, Kiro, I need luck, and I tend not to count on it, so next time, I will do my research first

I have a very similar problem with my DS8550/37. I was able to pair my iPhone 3Gs, iPhone 4s and iPadG3 via bluetooth and it worked GREAT for about a year and a half. Then, a couple of weeks ago, I turned on the unit and the bluetooth failed to pair with any devices. In fact, the blue light blinked but the device was never recognized. I made no changes to the environment. The speaker dock was not moved off the shelf, my devices OS was not upgraded. Nothing. Just stopped working. I called Phillips and all they could say was update the Fidelio app. That made zero difference. So although the sound is awesome, their is clearly some bug in the bluetooth feature. I know this doesn't help your problem, but at least you know you are not alone with this issue...

Faust
03-11-2013, 11:31 AM
Hi Jost0319,

have you also updated your software version on your idevices?