View Full Version : Can't update firmware

02-20-2013, 10:54 AM
Hello there.

I am since recently the proud owner of a Philips GoGear Ariaz mp3 player and decided to check out what extra functionality I could get out of it.
I've tried the Device Manager: to no avail, it would not recognize the device.
I've tried 'Checking for Updates' through Philips Songbird, which always prompt me with an error and no further details. It has perfect access to the internet, so I still don't see the problem.

All I want is to update the firmware of my device, I don't really care how, but as Philips wants us customers to use their software to do this I'm stuck as it won't work. After an hour or so of googling, still nothing, so maybe anyone here can help me, maybe people experienced this problem themselves?

Any help in general would be greatly appreciated.


On a sidenote, another issue I couldn't find a solution for: the built-in speakers aren't working. So I figured it may need a good ol' reset, and else the speakers just may be broken. Anyone got experience on this?

Philips - Katerina
08-27-2015, 12:44 PM
Hello participants of the thread and forum members in general!

Hopefully your issue was dealt with and you are no longer facing it. Since the thread has been silent for some time now, I will proceed by closing it. If you still have the same question about the same issue or any similar issues arise feel free to start a new thread or contact one of us moderators to open this thread again.

Kind regards
Philips Katerina