View Full Version : 26PF5321D/37 firmware upgrade

03-07-2013, 06:50 PM
My name is Eidan and I am a long time Phillips customer, I am the proud owner of a 26PF5321D/37 TV and never had a problem with it until today when I finally hooked it to my PS3 using an HDMI cable. I set it up but I always get green yellow and snowy flickering so when I checked out the firmware log it said that there upgrade fixes that issue. I got one of my USB drives and used my mac to erase and convert it to a FAT32 dos format. I copied the file i downloaded from the support drivers page into the root and when I plug it to my TV it starts up and has the screen that has the upgrade and file info just like it should but when it came to actually installing the upgrade it said that it "cannot read file" I tried over and over again so I thought maybe its the file itself since everything loads just fine. Please let me know what I should try next I am desperate!

With best regards,

03-08-2013, 06:57 AM

Only FAT/DOS-formatted portable memory is supported.

See: http://download.p4c.philips.com/files/2/26pf5321d_37/26pf5321d_37_fur_eng.pdf

Try FAT16 (not FAT32).


03-11-2013, 08:16 PM
tried it with no luck though, it keeps telling me that "cannot read file" message. Could it actually be the file itself that is damaged?