PDA

View Full Version : BDP5200 and 3D not playing correctly



Drodgers
03-08-2013, 01:33 PM
Hi

Some 3D discs do not play correctly on this player. Namely: Prometheus,, Drive Angry, Green Hornet, Rio, Gulliver's Travels, Narnia Voyage of the Dawn Treader... They play as if the left and right fields are out of sync.

I have posted this previously on another thread to which many other people have the same problem. I received an email from Phillips back in October asking for the EAN codes of the discs which I supplied....but then nothing. And then on checking the thread this morning it has been "closed" without anything been advised as to whether the problem can be fixed with a firmware update or in fact any information at all. After care really is lacking.

Anybody know of an unofficial fix to this or anything?

Regards

Darin.

Teddy
03-08-2013, 02:40 PM
Hi,

I would advise you to post the EAN codes on your discs in this tread or this one: http://www.supportforum.philips.com/en/archive/index.php/t-3108.html

My experience is that Philips look at the issue and get back to you asap.

/Ted

Drodgers
03-08-2013, 02:50 PM
Hi,

I would advise you to post the EAN codes on your discs in this tread or this one: http://www.supportforum.philips.com/en/archive/index.php/t-3108.html

My experience is that Philips look at the issue and get back to you asap.

/Ted

Thanks. I sent Philips the EAN codes and the information they required back in October and still nothing. Still I have taken your advice and posted in the thread you advised and well, fingers crossed.

Darin.