PDA

View Full Version : MCD909 fan noise



wjbg
03-17-2013, 07:04 PM
Hi,

Approximately six or seven months ago my Philips MCD909 started making very loud noise on startup. It seems to be the fan that makes the noise. After a few minutes the noise would fade away. However, the last two months the noise has become unbearable and does not fade away anymore. Does someone has the same problem and know how can I resolve this issue?

Kind regards,
WJBG

Faust
03-20-2013, 12:20 PM
hey, this sounds like a hardware issue. would probably recommend to take it to service centre to have it checked.

jcjacobs
12-14-2013, 04:15 PM
Hi,

Approximately six or seven months ago my Philips MCD909 started making very loud noise on startup. It seems to be the fan that makes the noise. After a few minutes the noise would fade away. However, the last two months the noise has become unbearable and does not fade away anymore. Does someone has the same problem and know how can I resolve this issue?

Kind regards,
WJBG

I have the same problem. However the sound does dissapear after 2 minutes.

Bought the stereo approx. 4 years ago, so probably too late for warranty, and I think repairing it will be costly.


Opened the stereo too see if the fan is easy replaceable , but it is not.

If you have any other tips, please let me know!

Philips - Katerina
08-24-2015, 08:51 AM
Hello participants of the thread and forum members in general!

Hopefully your issue was dealt with and you are no longer facing it. Since the thread has been silent for some time now, I will proceed by closing it. If you still have the same question about the same issue or any similar issues arise feel free to start a new thread or contact one of us moderators to open this thread again.

Kind regards
Philips Katerina