PDA

View Full Version : Philips MCi300/05 Wireless Micro HiFi System problem



SteveinFrance
03-27-2013, 08:38 AM
Although I can still listen to Internet radio, my player will now not recognise my Flash Drive Key. I've tried a second key with the same result. There is a message displayed saying 'no usb device connected'. The key illuminates when inserted into the player, but doesn't flash as it used to.
Please can you help or advise me of any solution?
Many thanks

Faust
03-29-2013, 09:02 AM
Hi SteveinFrance, there may be something wrong with the USB slot in your device. I would take it to your local service centre to have it checked for you.

SteveinFrance
03-29-2013, 10:26 AM
Unfortunately I think the problem is more than the USB slot as the internet radio has now stopped working. We've just moved into a new house, so the plaster etc is still drying out. Could this be causing a problem and, if so, what can I do?

Faust
04-01-2013, 10:30 AM
what does it mean the internet radio stopped working. it won't connect to internet or you can't log into your account?

SteveinFrance
04-02-2013, 09:31 AM
what does it mean the internet radio stopped working. it won't connect to internet or you can't log into your account?

Sorry to be unclear. The player displays a message saying it can't connect to the internet. I've tried re-entering the Wi-fi code in case it had lost it, but to no avail.

Faust
04-04-2013, 08:23 AM
Have you tried to reset the factory settings of your MCi and the router as well. Reset and reconnect both, maybe that will help. I also found a FAQ that may help if the reset fails...have a look here - http://www.p4c.philips.com/cgi-bin/cpindex.pl?ctn=MCI300/05&dct=FAQ&faqview=1&list=aa12_list_partial.html&mid=Link_FAQs&refnr=0072381&scy=GB&slg=ENG&view=aa12_view_partial.html