PDA

View Full Version : BDP9700 not mounting USB3.0 hard-drive?



Rin
03-31-2013, 02:47 PM
The BDP9700 does not mount my USB3.0 NTFS 2.5" 640GB portable hard-drive, even though it is USB2.0 backward compatible. The drive mounts everywhere else.

The BDP9700 seems to detect something but the drive was not accessible. Restarted the player with the drive already connected; same thing. Tried with different cables, including the special USB3.0 cable; nothing changed. Took away the player's power, re-plugged; nope.

Tried the hard-drive on all other devices I could find, with different cables; functioned perfectly at USB2.0-speeds with an old Win-XP laptop and my cheap 2009 media-player, or at full USB3.0 speed with my new Win8 computer. Just for measure I tried an older portable 2.5" 120GB USB2.0 NTFS hard-disk; worked fine on the BDP9700 and everywhere else of coarse.


28-4-2013 update:
Bought a 4-port USB 3.0 hub with huge power supply to power the USB3.0 drive. Now at firmware v3.80. Nothing works.

THIS IS NOT A POWER ISSUE ! :( See below

Toengel
03-31-2013, 02:53 PM
Hi,

try firmware 3.76.

Toengel@Alex

Rin
03-31-2013, 05:08 PM
Hi Toengel, thanks, but...

As you can read I returned the player for a refund, so I cannot try your suggestion. I did look up the release notes of the 3.76 firmware, but it does not say anything about enhancing support for USB3.0-capable / USB2.0-compatible drives. I am not willing to re-buy the player just to try if this (to me) deal-breaking problem has been solved.

Did anyone try USB3.0-capable drives with the BDP9700? Before and after the 3.76 firmware upgrade?

===================================
System Software Version 3.76 release notes:
- Improvement on playback of 3D blu-ray disc “Avengers” (Asia Pacific version only)
- Enhance Blu-ray disc playability
- Enhance SACD playability
- Enhance the performance of HDMI connection
- Enhance playback performance
- Various bug fix

System Software Version 3.71.01
Fixes the following issues:
- Transparent black bar seen on the bottom of the screen during 3D playback.
- Device hang-up when loading 3D discs while it is connected to HDMI TV and HDMI AV receiver.

Direct link to the firmware:
http://www.p4c.philips.com/cgi-bin/dcbint/cpindex.pl?ctn=BDP9700/12&slg=en&scy=DE

Gerhard
04-08-2013, 12:15 PM
Just to finish this topic:

The issue is related to the power consumption a USB 3.0 device might show up.
Relevant answers were posted here (http://www.supportforum.philips.com/en/showthread.php?11741-BDP9700-Latest-Firmware-upgrade-(3-76)-has-been-released&p=54964&viewfull=1#post54964) and here (http://www.supportforum.philips.com/en/showthread.php?11741-BDP9700-Latest-Firmware-upgrade-(3-76)-has-been-released&p=54965&viewfull=1#post54965).

Rin
04-28-2013, 11:01 AM
Sorry Gerhard, topic not finished yet:

Re-bought the BDP9700 because you guys convinced me this was a power issue. It is not.

I also bought a 4-port USB 3.0 hub with a HUGE power supply, which is USB 2.0 backward compatible. It easily powers 3 small 2.5 inch USB 2.0 bus-powered hard disks plus a USB stick, all at the same time. Everything -except the USB 3.0 drive- mounts fine in the BDP9700. The hub is doing a great job powering everything.

SO: Still no go with the USB 3.0 hard disk :mad: Not even by itself on the USB hub. :mad: This is a USB 3.0 -issue, I am positive, the BDP9700 has a problem here. Anyone else tried with a (powered) USB 3.0 hard disk?

Thinking of logging an issue with Philips tech support on this one. I am throwing away money to get this fixed!!

Gerhard
04-28-2013, 11:50 AM
So, in that case - I'm sorry. It was just a try to explain your issue. I've currently no USB 3.0 HDD here for
a quick test. BTW - which manufacturer/type is it?

- Gerhard

kvic
05-15-2013, 02:40 PM
Hi

Compatibility among USB chips is a nightmare. What's your USB drive? Check two things:
1. Connect your USB 3.0 drive to Windows or Mac. Find out what's the vendor id for your drive's USB chip.
2. Check what's the NTFS version on your USB 3.0 drive. You can try to format your drive to FAT32 or exFAT. And see if 9700 can recognize your drive now.

Rin
05-15-2013, 10:11 PM
Hi kvic, Your questions gave me the idea to look for the chip set's firmware; upgraded that. Bummer, didn't help. But all ideas welcome!!

Enclosure Brand: MS-tech --> www.ms-tech.de
Enclosure Type: LU275S Black
USB3.0-Sata Chip set: ASM1051, now at firmware 130220.81.F6.02 = latest
Drive mounted: Samsung HM641JI
Drive Formatting: NTFS

As for the formatting: The BDP9700 support NTFS but not exFAT, right? Therefore I did not try exFAT. FAT16 and FAT32 are not an option for their limits on file size. I have many files that are bigger than 4GB.

As for power consumption: The drive works perfectly without additional power on ALL other USB2.0 port in my house. That includes several old and new computers, a media player, two tv's, and a wireless router. It spins-up fine on the BDP9700, it just doesn't mount. Using a USB3.0-hub in between with a HUGE power supply did not help either.

BDP9700 at firmware 3.80 and mcu0x19 = latest

Philips - QK
05-16-2013, 09:50 AM
Dear both,

We will look into the subject in greater details. Meanwhile, if you have more testing results to share, that will be a lot appreciated!

With thanks & regards,
Philips moderation team

kvic
05-16-2013, 02:26 PM
Hi

9600 didn't support exFAT. You're right. 9700 seems still not support exFAT. The reason I'm suggesting different filesystems is to rule out hardware issue. ASM1051 is by a company under ASUS. Seems a very good chip. I won't bet it's hardware issue...

Where did you format your NTFS? I'm guessing there is issue in the Master Boot Record (MBR). Or maybe your NTFS is on GPT (if you format it casually on a Mac). Please check. 9600 cannot cope with GPT. I'm guessing 9700 cannot do either.

Philips - QK
05-20-2013, 04:59 AM
Dear Rin,

kvic is right. Your device is in GPT instead of the traditional MBR format and hence not supported by BDP9700. This issue is not limited to USB3.0 HDD - USB2.0 HDD with GPT is also affected. Actually BDP9700 supports USB3.0 HDD.

However, your HDD is not actually a USB3.0 HDD.
It is a SATA HDD inside a HDD enclosure with USB3.0 interface

Kind regards,
Philips Moderation Team

Philips - QK
05-23-2013, 09:54 AM
Dear all,

Good news here - the GPT issue will be solved in the next software release.

Kind regards,
Philips Moderation Team

Toengel
05-23-2013, 10:24 AM
Hi,

AWESOME!

Toengel@Alex

kvic
05-23-2013, 01:13 PM
This is very encouraging news. Keep up with the momentum, Philips!

Rin
05-24-2013, 08:20 PM
SOLVED!! :D

After updating the USB3.0 case's chip-set to latest firmware it lost ALL USB2.0 backward compatibility, which made it totally useless to me. Had to down-date the firmware. Let this be a warning! ;) That was a little tricky, so it took me some time before I could look at kvic's suggestion the problem might be GPT:

My base computer has Windows 8 Pro, and I use several drives in a Win8 Storage Spaces (seriously cool feature, the reason I migrated to Win8Pro). I had used the bare drive as part of a large Pool of drives, which indeed makes it GPT. Reformatting is not enough to get (back) to MBR... :eek:

Life 's good, the drive also works fine on the BDP9700 now. NTFS on MBR, and no power-issues at all :o
Thank you all for your time, for all your responses and suggestions.

Greetz to all, sweets for all !
1941