View Full Version : NetTV option does not appear after repair

05-01-2013, 01:56 PM
Hi All,

Recently, my 46PFL9705H (bought 2 year back) main processing board been replace (due to thunder strike/power surge) with spare by an authorize Philips services agent (Malaysia).

As the service agent had diagnose the failure by replacing the main processing board and the unit seem back to normal operation, and the services agent said the unit require set back to Philips workshop for "programming" or "update" -- that require about 3~4 business day to get the job done.

After about an week, the said services agent return the repair unit and help install the TV channel, I do discover the "NetTV" selection was not appear under the Setup Menu.

Could this due to the main processing board been replaced was not uploaded with the NetTV software module (and the "Help" selection under the Start Menu show only an Big Blue Question mark when I click on it) or necessary component was missing ?

Kindly please advice what could I self-help (like upgrade necessary firmware) to get the NetTV and Help selection appear on Start Menu. As I had tried to upgrade the firmware to Q5551-000_140_046_000.

Hope to hear any advice from members..


p/s: The replaced main processor come with firmware version :Q5551-000_140_027_000 -- while my previous loaded was Q5551-000_140_048_000 -- which appear to have issue when using NetTV -- as the NetTV became TOTALLY unusable , since I am not able to use the remote control to make ANY selection when get into NetTV application...

05-01-2013, 03:18 PM

- go to the support website of your TV
- go into the manual section
- download manual update
- format usb stick with FAT
- create folder called "upgrades" on that stick
- extract the manual-update-zip file on your desktop
- copy the manual *. upg file into the subfolder of your USB stick
- plugin stick
- go to setup/local updates of your tv
- chose update on the stick
- ignore waring messange (older or as same as old)
- help should be back to normal

- then install firmware 140.48
- download firmware upgrade
- format usb stick with FAT
- copy the extracted autorun.upg to the root of that stick
- plugin stick
- install update


Philips - Mark
05-02-2013, 09:07 AM

When stuck in navigation in Smart TV or suffering from the "Philips server not found" message on a 2010 TV, be aware of this post (http://goo.gl/W70ey)

If Smart TV fails after a repair, than check if the repair engineer remembered to program the “set type” in the board.
To check this, put the TV on a normal TV channel.
Press 123654 on the remote control
Now you see the Customer Service Menu; CSM1
Set type is mentioned on the first line.

“Set type” should show the commercial type number of your TV; xxPFLxxxxx/xx
If Set type is false (like: “See Typeplate”) than the TV can’t connect to the portal.
Call back the repair engineer to finish the repair job by programming the set type.

05-04-2013, 04:45 PM
Hi Toengel / Mark,

Appreciate your information and now the "Help" menu got restore with the above guide.

However, the "NetTV" selection still not shown up when upgrade to latest available firmware...

And when the TV get into Customer Service Menu (by meant of pressing "123654" on any TV channel); under the CSM 1 menu, item 1.1 Set type -- shown "46PFL9705H/12 on the display and it match exactly to the TV model...

Could it be an "software module" did not upload by the service agent or service center.

Kindly please advice what I could do to self-help before engage the service agent/service center..

Thanks and best regards,

Ian Ho

05-05-2013, 12:14 PM

can you connect to you home network? Do you see your TV in your router configuration?


05-09-2013, 11:05 AM
Hi Toengel,

Yes, the TV was appear on the network and I'm using static IP address with wired connection to my home network (from my PC, I was able to PING the IP address assigned to the TV).

However, there was no "NetTV" icon appear when I press the "Home" button on my remote and attached please find the photo taken when TV was in Home menu.

Since I was able to contact the TV from my PC (which my PC running Windows 7 OS) and was there any DIY step that I could reload the "NetTV" module back to my TV ?

Appreciate your suggestion and comment.


Ian Ho1893

05-09-2013, 11:44 AM

do you have a smartphone? Try the MyRemote app to start NetTV - before you need to activate "jointspace".


05-09-2013, 01:29 PM
Hi Toengle,

Yes, I had enabled the "jointspace" on my TV and managed to used by Android smartphone with previously installed "MyRemote" app to control the TV (re-enable the NetTV control on "MyRemote" app).

However, when I click on the "NetTV" selection on under the "MyRemote" home screen. I will not be able to do any selection/control that relevant to "NetTV".

And I was curious that whether "jointspace" feature help to resolve the "NetTV" that I faced, as on the TV "Home Screen" -- there are NO NeTV selection could be made..

Attached please find the photo that I took when I switch my TV to "Home Screen" -- no NetTV appear on it at all..


Appreciate you advice -- how could I restore the NetTV module for my 46PFL9705H..

Thnanks and best regards

05-09-2013, 02:32 PM

OK - go again into CSM (123654) and check the option codes (1.4). Please compare them with the sticker on the back of your TV.


05-09-2013, 02:46 PM
Hi Toengel,

There are two option code for 1.4 under CSM..

Here they are:

1.4a Options 1 : 04100 06400 12455 02177
1.4b Options 2 : 11010 01539 00000 00000

And the TV sticker shown:

Option Code :
04100 14111 12479 02239
43777 34311 04108 00000


Ian Ho

05-09-2013, 02:53 PM

that's the problem - they forgot to program the right option codes - they need to be identical (CSM need to show the same as on the sticker of the back).

So call service again and say, that the programmed option code do not apply to the ones on the back of your TV after they changed the mainboard.


05-09-2013, 03:18 PM
Hi Toengel,


By the way, could I do the program the code myself.. as it quite hassle to get the service agent get in on
weekend.. and the last TV was return on 20 April 2013 (FYI, I was on oversea business trip for two week and just realize the NetTV option not available when I had time to play around/re-setup the external device connection..

Kindly please advice.


Ian Ho

p/s:It also quite hassle for the service agent to pick up the 46" TV... as the agent only own an non-commercial vehnicle to do the field support..