PDA

View Full Version : Purple picture HDMI / DVI BDP 9700



Stormen
05-05-2013, 10:31 AM
Hi
Connected the BDP 9700 (lastest firmware) to my old Zanyo Z2 (1080i) with DVI and now I have purple picture. Sharp and flawless but all purple. composit works great.
I before used a BDP9600 (hdmi) without any problems. And also tried with an old samsung DVD player (hdmi) with perfect picture. ( and a bdp8000)

Inputs on the Z2 is:
input2 DVI and I can only choose RGB
input1: YpPbPr with 3 RCA connectors.


The purple picture problem is what I understand a HDCP handshaking problem. YpPbPr vs RGB
I do wonder why there was no problem with the 9600 or the 8000 series ?

Is there any other settings in the BDP9700 that makes it send the same signal as BDP9600 ?

Toengel
05-05-2013, 11:15 AM
Hi,

what is you current firmware version?

What is your version of the MCU (remove disc, press home, press 8520)?

Toengel@Alex

Stormen
05-05-2013, 02:02 PM
Hi Toengel ( your alwas fast ) :-)

Model BDP9700/12
Stroke /12
Player SW HQ 00009334
Loader SW: 6J0826 8550 0826
MCU SW 0x15-0
Weakup [0x00]
Region B 2
Module time 2013-04-17 18:40:15
Binary Time Localbuild Wed 17 APRIL 2013 20:18:25
Net Tw 3.08
Smartphone 4.5

Toengel
05-05-2013, 03:42 PM
Hi,

your MCU is 0x15 - actual is 0x19 (I think, this is your problem).

Download the update again from the support website and install again:
- format usb stick
- extract the downloaded ZIP to the usb stick
- should look like:

usb-stick:\UPG_ALL\BDP9700.bin

Toengel@Alex

Stormen
05-05-2013, 05:47 PM
Hi. Ive uppgraded through usb stick and now got the 0x19-0 installed.
But it's the same problem.
I connected the bdp 9600 again just to make sure it wasnt the cable or projektor. And the picture had all colors in place.

Toengel
05-05-2013, 06:31 PM
Hi,

please now make a factory reset and pull power cord for 2-3 minutes...

After that, please check again, if you have firmware 3.80 and MCU 0x19.

Toengel@Alex

Stormen
05-05-2013, 07:55 PM
Hi Toengel
I'm very glad for your respons and kindness to help me solve this issue.
I made a factory reset and pulled the powercord for 5 minutes, then stared up, selected country etc. and tried with the projector again. Nope,, didnt solve the issue with hdcp.
And have the 3.8 and the MCU 0x19
You seem very sure that this bug is already fixed ? ;-)
I can try to reset, reinstall the FW and reset again. but nahh dont think that will help.

this is how it look for you guys who havent seen this before.

http://i233.photobucket.com/albums/ee311/F_Storm/DSC_0197_zpsfe064470.jpg (http://s233.photobucket.com/user/F_Storm/media/DSC_0197_zpsfe064470.jpg.html)

http://i233.photobucket.com/albums/ee311/F_Storm/DSC_0198_zps76153188.jpg (http://s233.photobucket.com/user/F_Storm/media/DSC_0198_zps76153188.jpg.html)

SHUMKINGLOONG
05-06-2013, 03:55 AM
Hi Stormen,

I also have this problem around 2 mths ago, the condition was the same as yours, using DVI to connect TV, no solution to solve it from the support team of Philips in Hong Kong.

At last, Philips agreed to refund, but anyway I hope they can solve this problem else I'll consider to buy it again.

Philips - Marcus
05-06-2013, 08:38 AM
Dear All,

I have escalated this issue to product development. I will let you know when I have any information in regards to matter.

Kind Regards,

Marcus

Stormen
05-06-2013, 08:24 PM
some intresting reading about handshaking hdcp



On the other hand, you can also run into a situation on older-DVI equipped TVs that even if they are HDCP compliant, they may not have the proper firmware to recognize the identity of the HDMI source component you are trying to connect. If you run into this situation a call to tech support for your TV or source component is a good idea before proceeding further.

official articel at about.com
http://hometheater.about.com/od/hometheaterdoityourself/a/How-To-Troubleshoot-Hdmi-Connection-Problems.htm

Philips - QK
05-08-2013, 06:56 AM
Dear Stormen,

You interested in this: http://www.supportforum.philips.com/en/showthread.php?12222-Interested-to-be-our-new-product-home-tester-REGISTER-HERE!?

I still remember your speaker so so so well :P

1892

Stormen
05-08-2013, 11:13 AM
LOL
Yep they where really massive, no center available though :-)

But now I got it rebuild and its got WAF factor ( wife acceptans factor)

http://i233.photobucket.com/albums/ee311/F_Storm/Bokhylla%20Horn/IMGP4883.jpg

http://i233.photobucket.com/albums/ee311/F_Storm/Bokhylla%20Horn/IMGP4903.jpg


6 months later
http://i233.photobucket.com/albums/ee311/F_Storm/Bokhylla%20Horn/bild_zps918fe38c.jpg (http://s233.photobucket.com/user/F_Storm/media/Bokhylla%20Horn/bild_zps918fe38c.jpg.html)



Here is the thread in swedish, use google translate:
http://sweetspotforum.forum24.se/sweetspotforum-about1892.html
Sorry OT:
Back to Topic !
The purple problem accours on different older models ov DVI screens and projector. something got changed between the 9600 and the 9700

Philips - QK
05-09-2013, 03:54 AM
wow, projector, it s even greater now :P

Yep, back to your topic, I have passed the issue to our development team. Will let you know if we have more investigation results. Thanks!

Stormen
05-15-2013, 10:51 AM
Have read som more threads about the old Sanyo plv Z2 with DVI connectors.
The DVI (DHCP) input on this projector does not always "play nice" with other DVI and HDMI source devices. Some players work some don't.


Some people claim that if the signal is changed to 60 Hz it solves the problem.
Sanyo claims hdcp comp with PAL standard. ( when launched 2003 )
Anyhow, something is changed between the 9600 and the 9700,, could be the keychain for hdcp ?
What signal is the BDP 9700 sending ?

Stormen
06-19-2013, 02:01 PM
Firmware 3.85.1 didnt solve the issue, But now I have perfect picture for 5 sec at startup, then HDCP kicks in and i get purple screen.
Investigations is still going on at Philips.

Stormen
08-02-2013, 01:02 PM
SOLVED ! with firmware 3.92