PDA

View Full Version : BDP5180 - No srt support with DSLN



knob2001
06-13-2011, 07:08 PM
Hi.

There's no way to show subtitles on AVI files (.srt, same name as file on same folder) when connected by DLNA. I've tried with several AVI files, even with several DLNA different brand servers, and of course, those avi + srt works on PC or via USB.

But MKV works flawlessly. You can alternate subs and audio streams right from the remote.

This could be a perfect BDplayer if the AVI files could show srt files too.

Thank you.
knob2001.


BDP5180 1.54 firmware.

sngbcn
06-14-2011, 10:48 AM
Hi,
Which DMS did you use? You can give a try to Mezzmo it has support for many file formats + subtitles.

http://www.conceiva.com/products/mezzmo/formatsupport.asp#SubtitleRead

Regards,

knob2001
06-14-2011, 12:14 PM
Hi.

Thanks for the advice, but that one was the first i tried. Then i tried more than five, but without much luck.

Regards.
knob2001

a_Tom
06-14-2011, 12:49 PM
Hi

what Codec does your AVI File got?
(you can use "http://mediainfo.sourceforge.net/en" to check the Video Codec)
Which Server did you try? (Twonky, TVersity, PS3 Media Server?!?)

knob2001
06-14-2011, 02:42 PM
Hi.

Most of the AVI files i got are MPEG-4 Visual (Xvid). Those files are played correctly on USB, but not on DNLA.

The server... i tried Tversity (very fast), PS3 Media Server, Mezzmo, TVmobili... none of them shows the subs on screen.

I've tried the srt codification ANSI, UNICODE and UTF-8. Nothing on the screen.

But all of them work perfect via USB, that's what i can't understand... i will try to do some tweaks but i'm running out of ideas.

Regards.

a_Tom
06-14-2011, 04:02 PM
For TVersity i can say that it is neccessary to transcode files to be able to see the subtitles, if you do not transcode files tversity is not able to handle video and subtitles.
not quite sure how this goes for other Servers.

knob2001
06-14-2011, 08:03 PM
Hi.

But the problem is how to force the transcoding of the file if the philips tell the server he can accept the codec. I've tried to force it but none of the servers seems to do it. They just send the raw stream...

Thanks to everybody for the answers.

Regards.

a_Tom
06-15-2011, 05:58 AM
On Tversity you can just tell the Server to Transcode everytime:
Settings > Transcoder > "When to Transcode" > allways or in the Media Library, edit your Sources > Advanced > Transcode: allways

This should do it.