View Full Version : WiFi Media Connect : Does not Connect Wirelessly

07-13-2011, 08:02 AM
I have trouble using Wi-Fi Media Connect and would value input from Philips admins or customers who have gotten around to successfully using the product.

TV: 40PFL5705DV/F7 with latest firmware
OS: Windows 7, 64-bit,intel i5 pc,6gb ram
Wi-Fi Media Connect Ver: 1.6.425

Connecting ethernet cable between TV and PC works! Wi-Fi Media Connect is able to project my PC screen.
Connecting wirelessly with ASUS RT-N13U N router (TV finds and accesses network OK). Does Not Work.

Connection Test on TV results:
"Status Warning
Home Network Only
Gateway or DNS is invalid
Or Router does not exist on network" .

Gateway, Primary DNS, Secondary DNS =
IP address and Subnet Mask are populated. IP address is different from my laptop and router ip.

Wifi Media Connect is loaded but does not "launch" when connected wirelessly.The icon is gray and no option to start projection pops up.
I can login into my router to make changes. Upnp is enabled.

Thank you.

07-13-2011, 08:09 AM

you need to set-up your TV and Router to DHCP...

If your Gateway and DNS are all then your TV does not get the information from your Router...


Philips - Thomas
07-15-2011, 09:00 AM
Hi ppetkov,

Can you please post your Router IP/TV IP and TV IP Address?
Please also add some information's on from the Router itself (Brand/Model)


07-18-2011, 05:22 AM
This is an update to my previous post.
I went in and manually setup the IP Configuration in the TV after playing with the web administration of my router.
The Connection Test on the TV officially says "PASS".

I have tested some of the NET TV Applications and they do indeed stream music from the Internet fine.
However the Philips Wi Fi Media Connect still does not run. No message box pops up to state that the program is initiated on the PC
while the TV just continues to display the "waiting" circular blue globe and no video appears.
The Wi-Fi Media Connect icon remains gray on the task bar.

Your help is appreciated.

My router is an ASUS model RT-N13U (n router)
Router IP:

Thank you. Please update with ways I can resolve this.

Philips - Thomas
07-19-2011, 12:12 PM

the best you can do is to keep the manual settings on the TV, and to configure also the PC with Static IP.
After that, connect both (TV and PC) directly with a Cable, so there is no Router in between.
If this is done, close the Wifi Media Connect Software completly on the PC and restart the Software on the TV, while TV is searching, start the Software on the PC.

If there is again any kind of Issue in there please get in direct contact with your local Call Center: