PDA

View Full Version : Firmware upgrade for BDP5100 (V1.57)



Philips - Remko
08-08-2011, 08:58 AM
BDP5100 Latest Firmware upgrade (V1.57) has been released


(V1.57) includes the following changes: (ONLY released for /05, /12, /51, /98)
• Enhance the video file playability.

The former firmware version includes the following changes:
• This software upgrade* enables you to enjoy Philips NetTV online services.
*: For future software upgrades from ver.1.53, please download the future software versions from www.philips.com/support site only & upgrade your player via USB. (V1.57)
• Improve playback of certain BD, DVD discs. (V1.31)
• Improve playback of ‘AVATAR’ Blu-ray disc. (V1.30)
• Improve Wi-Fi wireless performance with Philips Wi-Fi USB adapter, WUB1110. (V1.30)
• Improve DLNA performance.(V1.30)

Shurakai
09-02-2011, 09:24 AM
Dear Philips support,

any news about a firmware upgrade for the BDP5180 ? Never heard something about it after 1.54, which is honestly a piece of very bad code.

Best regards, Shurakai.

rollufje
09-02-2011, 01:08 PM
Totally agree with the above

Zwartij
10-07-2011, 05:29 PM
any news about a firmware upgrade for the BDP5180 ? Never heard something about it after 1.54
I don't know how good or bad that code is. I only notice NetTV isn't working, saying that my router connection is not ok.
For all my pc's it is ok, so it should be for any Philips apparatus.
Stil happy about the streaming dlna abilities of this bdp. Streaming through my local network, via my router. :(

kwinnie
10-10-2011, 07:37 AM
:) ok ... summarizing wishes here... we have 3 pieces here...
but what are the fixes expected... sorry i dont follow that very thoroughly here

what i noticed is that
1) subtitle for mkv playback...
2) anything else?

Shurakai
10-10-2011, 12:23 PM
BDP5180/12

1) Fix the freezing of AVI/MKV playback when streamed via DLNA (the EASYLINK/Screensaver workaround does definetly not work in my case).
2) Fix of SRT-subtitle display. Formatting of SRT subtitles (bold/italic) not correctly recognized.
3) VOBSUBs (external or muxed into a mkv) do not work at all. Only 1 out of ten subtitles is displayed and most often totally out of position on the bottom of the screen.
4) NetTV not working.

Don't know any more issues or forgot them, sorry. Since I bought a AC Ryan multimedia player I don't care much about the multimedia functionalities of the BDP anymore. As long as it plays DVDs and Blu-Rays I'm satisfied.

Zwartij
10-11-2011, 03:41 PM
BDP5180/12
4) NetTV not working.

Don't know any more issues or forgot them, sorry. Since I bought a AC Ryan multimedia player I don't care much about the multimedia functionalities of the BDP anymore. As long as it plays DVDs and Blu-Rays I'm satisfied.I didn't buy an AC Ryan or like, because of the streaming capabilities of the BDP (5180/12). :)

kwinnie
10-12-2011, 09:41 AM
Hi Zwartji

I thought you have solved the NET TV issue. Anything new related to the NET TV that s not working recently?

Just quoted: from your other post (hope you don't mind, I just wud like to know if you still have a prob for that...)
----------------------------------------------------------------------------------------------------------------

I reset the BDP player to factory defaults.
SW v1.54 stayed in place.
After resetting my network values BDP player works fine. Net tv works again.
So the upgrade to SW v1.54 did something in the background, I Guess
(please don't dare to mention that the setting were incorrect before. It worked with v1.50 and it didn't work after upgrading. Settings were checked so many times, just to be sure.)

Registration is the only bothersome issue. The e-mail address entry doesn't accept <name>@zonnet.nl, which is an existing mail address. The part '@zonnet.nl' lights up in green. The address is not accepted as valid.
---------------------------------------------------------------------------------------------------------------

http://www.supportforum.philips.com/en/showthread.php?1190-upgrade-1.54-bdp5180-12

Zwartij
10-12-2011, 05:12 PM
It didn't last. The second time I tried many times and at last it worked. After that I tried many many times, without success.

How many times I tried? Hm, it succeeds my TV-channel swapping very easily :mad:

Philips - Remko
10-19-2011, 02:44 PM
Dear Zwartij,

I did some testing on our device and did not face the problems you have with NET TV. To better help you can you give me the following feedback:

-Does this both happen wired and wireless?
-Do you get an IP adress?
-Which encryption type are you using?
-Did you already test on a different router?

Thanks for your feedback.

Zwartij
10-19-2011, 05:07 PM
Dear Zwartij,

I did some testing on our device and did not face the problems you have with NET TV. To better help you can you give me the following feedback:

-Does this both happen wired and wireless? ONLY WIRED IS IN USE
-Do you get an IP adress? WITH DHCP: YES, I PREFER FIXED IP
-Which encryption type are you using?NO WIFI IN USE
-Did you already test on a different router? NO, ALL OTHER NETWORK DEVICES WORK PERFECT, EVEN BROWSING WITH THE BDP IN NETWORK FOLDERS WORKS FINE

Thanks for your feedback.Thank you for your help. Answers are put in capitals in the quote.

Zwartij
11-02-2011, 05:42 PM
Dear Zwartij,

I did some testing on our device and did not face the problems you have with NET TV. I responded today in this thread: http://www.supportforum.philips.com/en/showthread.php?1190-upgrade-1.54-bdp5180-12&p=15684#post15684. It gives you a clue how to reproduce my issue.

edwin
11-21-2011, 10:14 AM
I have had numerous problems playing authentic (Disney) DVD's and also home-burned DVD's
Yesterday we wanted to see the brand new dutch movie "gooise vrouwen"
The player hanged three times: black white noise screen; after 10 seconds: TV tels us no input signal; after another 2 seconds a next TV signal gets priority, all the time and the player continues counting the second playing.
ther is no interaction with the remote control/buttons on the machine. only hard shut down (disconnect 220V mains) helps.

So to get rid of this frustration I did Firmware upgrade and no succes. same movie again hanged twice after upgrade.

I must sy that the upgrade itself did not go flawless. It cost me a lot of time and frustration to get it working.
The installation manual says (something like) "do not rename the folders, otherwise the BDP5100 will not regognise the software"
so if you tell windows to unzip "upgradev1.57.zip"
you will get the suggested folder name "G:\upgradev157" to store the unzipped content. THIS IS NOT THE FOLDER NAME the bluerayplayer is looking for!
instead it is a subfolder of the newly created folder name!
Drag that folder one level up, to the root of the usb stick!!!

z2000
02-13-2012, 08:34 PM
I have more problem after upgarde FW. I can not have network now. what I can do?

edwin
02-14-2012, 06:07 AM
before christmass my player went to e-care that is the philips authorised repair shop. They have replaced the dvd reading part that seems to be able to operate independently from the blue-ray part.

It didn't help. due to busy december month I didn't react imidiately after the repair. still the player hangs on DVD movies. even on a screensaver-like fireplace.

So if it works with blue-ray and doesn't work with dvd , can it be the upscaling chip/software?
Normally the TV does upscaling, but when the signal needs to travel over the hdmi wire i think it is made 1080-1920 at the bdp5100.
maybe that part of the player is ill?

lfcapelo
02-18-2012, 05:48 AM
I must say I am very disapointed with my 5100, and this version of the firmware hasn't really made things better for me.

- slow booting (also very annoying that it doesn't open the drive until it is finished booting - terrible user experience!).

- It will randomly stop responding (playing dvds, blurays, sometimes just on the menus), forcing me to unplug it from the socket as it becomes impossible to switch it off or do any other action.

- the media player component, that used to be able to read all my video files and then stopped doing so when updated.

- my net tv component was updated when I was trying to use it some time ago, and it was a very confusing process. first I started it and it didn't launch correctly, then it said the feature had been disabled, then it asked for some confirmations but never quite started, then it did start but didn't respond and didn't have all apps... and eventually it worked again. NOT a smooth process at all.

This is making me really just use the player for blu-rays, and everything else will go through my xbox.
Philips guys, my impression of your brand is severely affected by this product. I can accept a few issues but I just don't trust this disc player. I'm kind of hoping that one day you'll release an update that'll make things smoother... but I know that with each day that goes by, this is less and less likely. And if that day does not come, you will probably lose me as a customer.