View Full Version : BDP5200 streaming from NAS - Folders show no content!

08-10-2011, 11:13 AM

This is my first post on these forums, I hope I have chosen the right area to post this :)

I have just purchased a BDP5200/12 blu ray player yesterday. It was very easy to set up, and i currently have it connected via wifi to my home network. So far the player has been great, playing everything I want it too, I have many dvd's, cd's and media such as mp3's and mp4 films on a 250 GB USB portable drive, and all of this plays fine with no problems. But, i am having problems with the DLNA/browse PC functionality.

On my home network, I have an LG N1T1 NAS, which has all of my music, pictures and films stored. These files are all in mp3, jpg and mp4/avi files respectively, and all of this is easily accesible from mine and my girlfriends laptop. After setting up the wifi on my blu ray player, I could see the NAS via the browse pc function, then once i go into one of the folders I have made visible via the DLNA function from the NAS, the blu ray player starts to have problems. About 95% of the sub folders i have in my DLNA NAS folders are not visible on the blu ray player (I get the message 'NO CONTENT' in the far right column of the browser on the blu ray player).

As an example, on the NAS I have made the folders I store my pictures in (named 'pictures' ;)) available a DLNA folder. I can view this folder on the blu ray browser. This folder has two folders within it, but the blu ray browser can only see one of them! And in the folder it can see, most of the sub folders and picture files (about 90-95%) are not visible (the message 'NO CONTENT' shows on the far right column in the blu ray browser)!

Can anyone advise why this may not work? I had bought the NAS because of it's DLNA integration for my planed future purchase of a blu ray/media streamer, but so far this doesn't work the way I want it too. I've read many things on the internet regarding the LG N1T1 NAS, where people can view content from it no problem...

08-10-2011, 11:23 AM
Hi Cel,

is your player updated to the last firmware version V1.16?


08-10-2011, 02:06 PM
Hi kiro,

I'll double check when I get home. I do remember that as soon as the player was connected to the internet yesterday, it requested to be updated, which I did, but i did not check the version.

I'll report back later :)

08-10-2011, 02:35 PM

sometimes not all updates are available via the integrated update mechanism. If you player says that your device is up to date check the version and look if it is really 1.16 - if not you need to update manually...


08-10-2011, 02:51 PM
Allow me to ask a question on another front: Are you sure the files inside those folders are compatible with the media formats supported by the BDP? Maybe you could give more details on which files are shown and which are not.

For instance: all MP3s should be shown (unless there are 1000's on one folder and the BDP cannot show them, this kind of limitation has been seen in other types of devices like TVS)


08-11-2011, 08:53 AM
yes, are those mkv files?

08-11-2011, 12:30 PM
I've bought the 5200/12 last week and I've noticed mine is not playing any .mp4 files.. this seems not to be supported even with the latest firmware 1.16.

Now I'm asking myself why the hell isn't .mp4 supported? It's weird because this BR players is supposed to be able to play all your media through the wonderful DLNA function which philips gave us. But what philips has forgotten is that 95% of all smartphones & cams record video only in .mp4 format. Now I can connect my cam and smartphone through DLNA but I can not play my videos because everything is recorded in .mp4.
The content does show up in the folder on my BDP5200 but it just won't play it, then it shows a message saying this format is not supported.

I find this really weird... why isn't .mp4 supported? Perhaps am I doing something wrong?

08-11-2011, 01:14 PM

Thanks for the reply everyone, I checked the firmware version of my machine, and it is the latest 1.16.

Anyway, I went back into the browse PC function last night, and now everything I have set as DLNA from the NAS is visable and playable! Weird as the first night I set the player up, I was trying so many times to get the blu ray player to show the content from the DLNA folders. A wait over night obviously solved the problems!

Thanks again everyone!

P.s. I've not tried mp4 files yet, only avi video files, and these play fine! Will check the mp4's later

08-11-2011, 01:27 PM
Hi Spitfire


have a look at this table, .mp4 files should be supported, at least for video...

A mediainfo analysis could give more details.




@ cel: nice you solved the issue, enjoy!! :)