PDA

View Full Version : No sound on tv connecting laptop via hdmi



andriuspt
08-23-2011, 12:54 PM
Hi everybody,
My problem is well known and if you look in a lot of forums and support sites you'll find this issue announced by others. I don't need answers like: "check your sound options in Windows and set HDMI sound option as default" or "right click and check "show disconected devices" or something like that in sounds properties of your LapTop"...
So I have the problem with getting audio to work via the HDMI cable connected my LapTop to my TV. LapTop HDMI --> TV HDMI. Video works excellently but I can't get audio to come out of the TV. It is interesting that I used to have the sound earlier some times and it was not so easy to achieve. It apiered after doing number of resets of the notebook or TV, or both for several times and changing playback devices under "Sound" and I can not say what was helpful. Now it is impossible no matter how hard I try. And I have tried a lot of things. Installing, reinstalling drivers, reseting to default my TV and computer settings, updating TV's latest firmware, restarting computer and TV with HDMI cable pluged in or not pluged in a lot of times, tried to reset computer and TV switching diferent Windows sound properties even uninstalled all audio under "Sound, video and game controllers" and uninstaled "NVIDIA Geforce 8400M GS" under "Display adapters" in the Device Manager and reinstaled back, tried to find answers on various forums and support sites. NOTHING... I have spent hudge amount of time on it. And as I can see I'am not alone with this problem. Thousands of people have the same or similar problem. But there is no concrete help. When looking at the driver version of NVIDIA graphic card it may seem it is out of date (10/3/2009), but when I downloaded the latest version (8/3/2011) I can not get even video on my TV. So I got back to the older version. I asked NVIDIA customer care for help. Above all that I mentioned they asked to check the BIOS options of the laptop for the changes that may be needed for the audio to be routed over HDMI on the laptop. I tried to check BIOS as they told. But there are nothing like audio options there in my laptop. So it is impossible to check anything for HDMI audio. After all these mostly computer works I started suspecting Philips TV. Can it be that somehow Philips TV's are guilty in these issues? Anybody have any more ideas, advices? I've lost all my hopes. :(

I am using:
HP Pavilion DV6645en Notebook/AMDTurion 64x2/TL-58/1.9Ghz/15.4"/2GB/160GB/GeForce8400M/ WinVista HomePremium/Service Pack2/32-bit OS

Philips LED TV 32PFL9705H 81 cm (32") Full HD 1080p digital TV with Ambilight Spectra 3 and Perfect Pixel HD Engine

J.R
10-01-2011, 03:34 PM
I Also have same problem. I have HP elitebook with nvidia quadro FX graphics card. My tv is 46pfl8505. All the settings are correct because the laptop worked fine in my previous LG tv (wich unfortunately broke and i got philips). HDCP seems to ok.

Nvidia control panel shows DVI connection even if i have used hdmi cable ( no dvi ->hdmi cable)? So the television is sending wrong information to my laptop?

Why not the tv won't regognize that i'm using hdmi cable instead of dvi?

Please help!

digitalpbk
11-30-2011, 05:00 AM
see laptop to tv connection using hdmi (http://digitalpbk.com/hdmi/connect-laptop-tv-using-hdmi-port) for more information to troubleshoot this issue.

red_eye1980
12-15-2011, 11:06 AM
Hi there! had the same issue as you, connenting via hdmi from a mini desktop acer asprire using the onboard nvidia 8200. Tried several windows settings but no joy. the problem solved itself out as soon as i downloaded the latest nvidia drivers. then just connected the hdmi and the sound was on with no messing about. try it. if that fails, then try messing with settings. By the way i use the tv as the only display of the computer and before the vga upgrade it wouldnt show the bios, only windows. now it shows both. hope this helps

Toengel
12-15-2011, 11:44 AM
Hi,

if one is using a Nvidia Graphics card and connect the PC via HDMI to a Philips TV, one must EXPLICITLY switch on the HDMI-Audio in the Graphics Card Settings.

If you take a look at the release notes of each Geforce driver and search for Philips you will find out, that for Philips TVs HDMI-Audio is disabled by default - even if it works flawlessly.

Toengel@Alex

magician123
12-18-2011, 02:10 PM
Dear all!
I would like to connect my IBM Thinkpad 410s with my TV. The docking station has a displayport. If I buy a displayport-HDMI adapter, which HDMI standard should I use for the cable (TV = 42PFL7606k/02). I read that there are different cables available ?
Cheers...

Toengel
12-18-2011, 03:20 PM
Hi,

you need a "Highspeed HDMI cable" - highspeed is the magic word. Version number does not matter...

Toengel@Alex

marlon ckj
12-26-2011, 08:02 PM
hi , i got a SOLUTION for the 'no sound issue'

i had the same problem with my ion 330 htpc and philips 42pfl tv.
All the latest pc drivers were installed and hdmi sound device activated. I checked the windows configuration and according to windows (version 7) all sound devices were working properly.

however No Sound on my philips tv.

I connected my ion 330 htpc with the same hdmi cable to a samsung tv. Suprise suprise the digital sound was detected by the samsung tv. It was working correctly.

I did some research and I in my case the nvdia chipset and HDMI on older philips tvīs are not plug-and-play. I found out, when a nvidia chipset detects an olders philips tv no sound signal is sent through the hdmi cable.
why this is, i do not no. however there is a solution


the solutions is given in a nvidia forum:
http://forums.nvidia.com/index.php?showtopic=107314

As suggested in the forum: after installing an old beta driver "191.03 BETA drivers" (this driver is not straigth forward to find) my "no sound issue" was solved.

you can find the beta driver
http://www.nvidia.com/object/winxp_191.03_beta.html
or
http://www.nvidia.com/object/win7_winvista_64bit_191.03_beta.html.

remark: newer nvidia drivers do not solve this issue.
1) first install all the latest nvidia drivers
2) then instal the 191.03 BETA drivers
3) set hdmi sound device in windows as DEFAULT.
(Extra remark) if you do not have any hdmi sound at all, check also your bios and enable hdmi sound. You can find this setting in the advanced setting.

hopefully it wil solve your hdmi sound problem.

cheers, marlon

kazmi
02-23-2012, 11:29 AM
Hi Marlon... Could you please paste the link for the win7 32 bit beta driver ? thanx bye