View Full Version : HTS3371D Humming but WILL NOT POWER ON

09-08-2011, 04:42 AM
My family purchased the HTS3371 5.1 Home Theater system this year, and after about a month of use it no longer powers on. When plugged in, it hums so it's doing something on the inside, but the standby light does not come on, the display does not show anything, and it is unresponsive to any buttons or controls.

The odd thing was that I had had it unplugged for a few weeks after it stopped working but the other night I figured I'd try again. So I plugged it in and after about 10 minutes of unresponsive humming the standby light came on. I hit the power button on the remote control and the light turned off. After about another 10 minutes of nothing the display turned on and I was able to use the system as normal. HOWEVER, the next day when I attempted to bring it out of standby the light turned off and it did nothing. No sound came out of the speakers, it still hummed internally when I listened close, but I have not been able to power it on for the last 2 days.

I really need to get this problem fixed ASAP as I am a basement studio producer and use this system to listen to my mixes in surround

Philips - Gary
09-08-2011, 09:20 AM
Hi DanG,

I'm sorry to hear you're having problems turning on your Home Theatre, it doesn't sound like the unit is working correctly at the moment. Unfortunately as you have already tried leaving the product unplugged there isn't much more we can suggest as resetting requires you to be able to access the menu.

As getting this problem sorted is a priority for you I have sent further information to you in a private message, please check your inbox.

I hope this helps :)

09-08-2011, 09:21 AM
Hi DanG,

I am wondering if the standby light is on when it's disconnected from TV and speakers...
If it's still not on, I think it might be defective...

11-27-2013, 02:38 AM
I am having basically the same issue. My home theater will not even power on any more. No lights no sounds or anything.

11-27-2013, 08:47 AM
Hello S4L,

is your device still within the warranty? I would suggest you to visit your Local Service Centre to have it checked and fixed for you.

Fingers crossed.

Philips - Katerina
08-27-2015, 02:42 PM
Hello participants of the thread and forum members in general!

Hopefully your issue was dealt with and you are no longer facing it. Since the thread has been silent for some time now, I will proceed by closing it. If you still have the same question about the same issue or any similar issues arise feel free to start a new thread or contact one of us moderators to open this thread again.

Kind regards
Philips Katerina