View Full Version : Remote Control Refused to Work during Media File Playback

09-11-2011, 07:33 AM

I read on this forum another user reported a smiliar issue. I could not find that particular thread. Just want to report that the same problem exists on 9600. Not suprising if all 2010 models share a similar software build.

To produce the problem (100% reproducible):

Play a MKV file from USB.
Once the file starts playback, within the first 14 seconds, press some keys such as SUBTITLE / AUDIO TRACK.
9600 will not respond in the first 14 seconds into the playback. Assume it's busy working on initial setup or something.
After the first 14 seconds, press SUBSTITLE again. Make sure screen display confirm 9600 responded.
Now let it play for 15 to 20 minutes without pressing any buttons. Then, press PAUSE / OPTION / SUBSTILE / AUDIO TRACK buttons for example. No responses at all.

Playback continues as normal though no response from 9600. When this happens, the only buttons that I figure still working are:

Standby (so at least 9600 allows you to power off)
Long press of PAUSE (so 9600 will open/close the disc tray)

People mentioned one workaround (i.e. prevent the remote from stop working)

Let the media file to play for 2 to 3 minutes when the playback first starts.
Then press PAUSE and then PLAY again. After that the remote will remain functional for the rest of your movie session.

The problem from my understanding has nothing to do with EasyLink (or HDMI-CEC) because I have my EasyLink turned off on 9600.


09-11-2011, 08:59 AM

this seems to be a bug in all BDPs (at least all 2010 and newer)

Another workaround is to deactivate the screen saver...

If you take a look at the latest firmware release notes of the BDP5200 and BDP6000 (2011 models) you will find one interessting entry:

"Screen Saver is activated after 15-20 mins playback of mkv file in HDD."

So, maybe this is the real reason...


09-11-2011, 09:35 AM
thanks Toengel.
Disable screensaver works like a chime so far:)

Philips - Remko
09-16-2011, 08:01 AM
Hi Kvic,

Please check your personal messages.


09-24-2011, 05:54 AM
Hi Remko / Philips

Thanks for your PM that I haven't responded. Honestly, I don't believe with the specifics you requested will lead us to a solution on the right direction.

I played it through USB HDD which is external powered. It's a MKV file. Content doesn't matter. Even it's MKV or not is irrelevant but I only tried with MKV. So cannot speak for other file formats.

Btw, I spent so much time to detail the steps to reproduce the problem in the first message of this thread. Has Philips ever tried with paying attention to the fine details in bold?

The problem is *not* screen freeze. It's the remote control not responding.
Toengel@Alex was right and mentioned the solution already in the 2nd message, and I tried and confirmed it works.

Could Philips port the fix to 9600's firmware please? It's as simple as that. Let's not waste time to go in the wrong direction.

Cheers and thank you always for the support.

09-27-2011, 03:34 AM
hi kvic,

i am trying on my bdp9600 using your steps stated on the very top of this thread...i m not sure if that's because my device is extremely healthy or what. Mine responds in the first 14 secs on the subtitle and the menu buttons. and then i keep watching the mkv file without pressing any buttons until 20:42. At 20:42, I press pause, it works and then i press play it works as well.

Cannot found this problem with my device....

External USB device: just 8Gb mp3 device
Connected to TV through HDMI cable

Preference settings: subtitle off | parental control off | screen saver on | auto subtitle shift on
Advance: BD-live security off
Easylink: Easylink on | One Touch play on | One touce standby on |
Network: not connected
Audio: Night mode off | Neo6 Cinema | HDMI Audio Auto| Digital Audio Bitstream | PCM Downsampling Off
Video: TV display 16:9 | HDMI Video Auto | HDMI Deep Colour Auto| Component Video 480i/576i |
Picture settings Optimal| Blu-ray 3D video auto

Let's see what's wrong there...quite strange to me that by disabling the screen saver, it solves problems...

10-02-2011, 03:10 AM
I also experienced the same issue when watching a movie from a Hard Disk connected through USB to BDP9600.

The file format was MKV. I also found BDP9600 can't support file format M2TS in harddisk.

After disabling the screen saver, I was able to work around of this issue.


10-17-2011, 10:58 AM
I confirm the issue is fixed with the new V1.60 firmware.


11-02-2011, 02:13 PM
1.60 fixed it? Cool but the player doesn't allow me to upgrade. :(