PDA

View Full Version : BDP3000 Latest Software Upgrade (v1142.1) has been released



Philips - Remko
10-20-2011, 09:09 AM
Latest V1142.1 software release for related Product Models:


• BDP3000/05
• BDP3000/12

v1142.1 includes the following changes:

· Enhance the performance.

The former firmware version includes the following changes:
· USB 2.0 High Speed Certified (v1015.3)
o This software version will enable USB media files playback (DivX, MP3, JPEG, WMV, WMA) via the USB connector on the rear of your player.

· Improved Playability (v1015.3)
o Fixed resume playback function on a new Blu-ray Disc title ”Avatar”
o Improved playability of the certain Blu-ray and BD-R discs

· USB 2.0 High Speed Certified (v1006.1)
o This software version will enable USB media files playback (DivX, MP3, JPEG, WMV, WMA) via the USB jack on the rear of the this player.

· Improve Playability (v1006.1)
o This software version will improve the playback of certain Blu-ray and DVD discs.

· Improved 24fps (frame per second) playback (v1006.1)
o This software version enable smoother playback 24fps film material in Blu-ray Disc.

· Improve network setup function (v948.4)

· Resolves playback issue on some Blu-ray disc titles (v948.4)
o " Terminator Salvation ”
o " Alone in the dark 2 ”

· Improve disc compatibility (v941.4)

· Improve TV compatibility, adding Cinema 21:9 (v941.4)

Kindly download the software at www.philips.com/support

smp
11-02-2011, 06:57 PM
The "zooming" issue with Director's Cuts of Alien and Aliens blu-rays is STILL NOT FIXED. This is absolutely pathetic.
And why no new firmware for BDP3000/55 /96 or /98?

Toengel
11-02-2011, 07:09 PM
Hi,

can you please post the barcode of the BD set (it is printed on the cover)...

Toengel@Alex

smp
11-02-2011, 09:32 PM
5 039036 044776

The only way to properly watch the Director's Cut versions of Alien and Aliens is to start the movie from the chapters menu. Otherwise, the movie begins playing zoomed-in with only the top left corner of the image visible.

kwinnie
11-08-2011, 06:00 AM
do you have another BD device to check e.g. your PC? it sounds like it's a prob of the disc to me...

smp
11-08-2011, 10:22 AM
It's not a bad disc issue. It was a VERY well known bug with Alien/Aliens BD and Mediatek MT8520-based players. Even OPPO BDP-80/83 had this bug, but they fixed it a LONG time ago. Why Philips still didn't fix it is beyond me.
p.s. All MT8520-based Philips players still have this bug, not only BDP3000. BDP2500, BDP7300, BDP7500 (older, non-S2/B2 version), BDP9500 are also affected.

kwinnie
11-09-2011, 02:54 AM
i see. thanks for more information, smp...
then that indeed needs investigation

for your information the below:
http://www.supportforum.philips.com/en/showthread.php?3108-Is-your-Blu-ray-disc-not-playing-back

bezalon
11-19-2011, 08:09 AM
Hi,
I would like to know, why the latest Firm-update for BDP3000/12 doesnt include NTFS support? If this is all about being able to play MKV and HD videos in general, then why does the still only accept FAT and FAT32 formated usb devices with the 4GB maximun file size limit?
This doesnt make any sense and frustrates any user, especially when you read in forums that other devices of ther same series do now support NTFS file format.
Could you tell me a little bit more or (even better) fix this once and for all?
THank you in advance

smp
11-19-2011, 04:05 PM
There isn't a single NTFS-capable player with above mentioned MT8520 chipset. It's probably a limitation of Mediatek SDK.

bezalon
11-24-2011, 06:45 AM
There isn't a single NTFS-capable player with above mentioned MT8520 chipset. It's probably a limitation of Mediatek SDK.

I don't think that the Chipset is the problem. As there are players with the MT8520 that support NTFS. My Conceptronic CFULLHDMA has much older chipset and it reads NTFS file formats without any problems.

take a look at this article that I just found:

http://www.anandtech.com/Show/Index/3767?cPage=12&all=False&sort=0&page=3&slug=media-streamer-platforms-roundup

smp
11-24-2011, 10:23 AM
I don't think that the Chipset is the problem.
Chipset is not the problem. Mediatek devkit tools (SDK) are the problem, as far as I know.

As there are players with the MT8520 that support NTFS.
Name at least one. (LG BD390 has a Broadcom BCM7601 chipset, despite what that article says).
Here's the list of MT8520 players. None of them support NTFS:
Philips: BDP2500, BDP3000, BDP7300, BDP7500 (old revision), BDP9500.
LG: BD300, BD370.
JVC: XV BP1 (clone of LG BD370).
OPPO: BDP-80, BDP-83.
Seiki BD660 (old revision)
Tectoy DBR750
Bluetech BRU-HDM50
Medion P71006

matsagos
11-28-2011, 12:33 PM
Hi all,

I completely agree with bezalon about non supporting NTFS format. It is really silly. I also tried exFAT format which is an extended format that it solves the problem of 4GB limitation, but it do not work too.

matsagos
11-29-2011, 10:11 PM
Hi again,

I would like to ask if BDP3000 plays MKV files via USB

Thanks in advance

aplu
12-05-2011, 05:38 AM
Hi!

Yesterday I tried to play DVD made by LG recorder. BDP3000 got stuck completely. So I disconnected the mains. And then started the first time to connect LAN for firmware update. LAN connection was successful and also new version was found. After 30min on waiting for update to finalize I gave up. Went for instructions and tried USB update also. Extracted folder with files to root as instructed.. tried two USB-sticks (USB1 and USB 2.0). Both gave the same message "not valid SW available" (maybe slightly different wording.. don't remember extactly). I also tried copying the two BIN-files to root of USB memory stick. Didn't work..

Should I try to find older updates first? Where? Or how to update "original" firmware??. HELP - anyone! ?? :)

kwinnie
12-06-2011, 09:32 AM
so do you mean you are trying out the upgrade when a disc is in the disc tray?
if that's so, i think it actually will make your device got corrupted...

many cases in this forum reported something like this :( they eventually have to go to service...

aplu
12-07-2011, 06:21 AM
No disk on the machine.. Device still usable.

And plays now LG made DVD-R disk also :)
Maybe the LAN cable finally got the update to happen..

kwinnie
12-08-2011, 01:53 AM
glad to hear that.
maybe you can check also> home menu> settings> advanced> version info.

to see if that the latest fw... as i check in philips webpage: it should be 1142.1

saidean
12-21-2011, 01:34 AM
Is there a firmware update for the /98 models? I've been unsuccessful in playing the Star Wars Complete box set (Region A) and the last firmware was dated 2010-04-28 :(

Any way the firmware at the start of the thread can be modified to be used on the /98 models?

pyrrhus11
12-22-2011, 12:16 PM
Can anyone tell me why my BDP3000/05 cannot recognise the update file on a usb, I'm pulling my hair out trying to get the upgrade installed and the machine keeps telling me there is no software available on the usb, it is there however!!

kwinnie
12-23-2011, 02:51 AM
hi pyrrhus11,

i am not sure if you do it the below way:
1) remove disc from your disc tray > very important
2) download the zip file from support website
3) extract the zip file, there should be a folder containing a .bin file
4) put the WHOLE FOLDER in USB root directory. Do not rename the file nor the folder.
5) plug in the usb to your BDP3000. Go settings> advanced> software update

pyrrhus11
12-23-2011, 10:47 AM
Hello kwinnie;

I have done exactly as you spell out above but the machine keeps saying that no software was found.

niih
12-25-2011, 02:17 PM
Hi pyrhus11,

I had the same issue as you. Download and extract the zip file with the firmware. Rename the folder "UPG_ALL" to "UPG" and try again... Worked for me.

pyrrhus11
12-25-2011, 03:04 PM
Hi niih;

Thank you so much, you have saved Christmas!!!

hawkeye1922
01-23-2012, 10:43 PM
Just thought I'd share my recent firmware upgrade saga:
Tried upgrading my BDP3000/05 both via network and USB. Network method resulted in "downloading firmware from internet" and a progress bar that froze - I left it 12 hours and nothing happened. Via USB, I got the message "Firmware upgrade failed - rebooting in 5 seconds".
I tried both methods several times to no avail, even with the support of the live chat people. Eventually I looked more closely at my USB flash drive - it had a hidden system folder called "volume_information" - probably because I made it bootable a while ago.
I couldn't delete this so I switched to another non-bootable flash drive, deleted everything from it and put the firmware on. Even then, it didn't work first time - I still had to rename the folder "UPG" from UPG_ALL. The moral is, don't give up! Use a completely clear flash drive, rename the folder and it should work! Finally I can watch all 6 Star Wars discs!

Fender
01-26-2012, 12:54 AM
I've just tried this upgrade via Internet connection on a BDP3000/75 and it seems to have froze downloading. Cancel does not work. I was hoping the new version would fix my DVD - "no disc" error and the error "no usb device detected" (Fat32 usb with a fresh format). There was no disc in the tray when I started. I wonder how long I should leave it in this state.

Cyxxon
04-18-2012, 12:08 PM
Will we get a new firmware anytime soon? The discs with playback problems keep getting more numerous... the latest problematic discs are the Game of Thrones Blu-Rays. I can only play them at all if I boot the player, insert any other random Blu-Ray, wait until the menu has loaded, then eject the disc and put in the GoT disc. If I insert the GoT disc as the first disc after booting the player simply locks up on a black screen, and I have to unplug it.

Harry Potter 7.2 has skipping frames - there are certain positions during the movie (always the same) where the picture seems to skip back a frame and then continues, a very noticeable stuttering. Audio is unaffected.

Alien still has the zooming issue as others mentioned.

And my pet peeve: the missing first second of audio for everything. It doesn't matter what I play, if it is a movie, or just the menu, the first second or so is always without sound, which then suddenly kicks in.

Fender
04-18-2012, 09:20 PM
BDP3000/75 - The network download firmware upgrade did not work for me but the usb upgrade did after following the instructions in this thread. I had a problem with a blu-ray movie crashing the system, but after cleaning the disc 4 times it worked 100%. The DVD side is still not working and I still get annoying sound on standby.

Mike_G
04-19-2012, 09:11 PM
I, too, have experienced exactly the same problem when it comes to updating the firm ware. Updating via ethernet results in freeze screen and via USB requires a strange renaming of the folder to work. (Thanks for this tip!) When the player was finally updated I thought I would be able to play the Game of Throne-blu ray I've been wanting to see. But no, just as for Cyxxon above, the disc won't load. The mysterious work-around (swapping discs after loading the menu) is not a very smooth solution...
When will Phillips do something about these unstable firmwares??

dudestate
04-28-2012, 01:28 PM
I have 2 of these players, one which is on the previous 1015.1 firmware and one which is on the firmware which didnt have the USB option on the homescreen, none of them will update to newest version by any of the ways mentioned in this and various other threads, any other ideas Philips people as I have one player that flickers now and again, and another that wont play various titles (Terminator Salvation etc.) :( please help

steviecoyle
05-08-2012, 10:16 PM
I'm having the same problem with the Alien Anthology. The Alien Director's Cut & Aliens Special Edition zooms in to the top of the screen. The theatrical versions work fine. However as someone above mention, if I go into scene selections and start the film that way it works???

Info :
Model : BDP3000
Firmware : 1142.1

Blu-Ray Bar-code : 5039036050319

runadrum
07-08-2012, 12:25 PM
My two year old BDP3000 stopped playing DVDs a couple of weeks ago and today decided my existing blu rays which it was happy with last week are now 'unknown discs'. Could not see that firmware would be the problem but decided to download an upgrade for the first time ever.

Agree with other posts on here that the online download did not work - it just got stuck. The upgrade via USB has worked (after changing the file name to just UPG as suggested in this thread - thank you) but the disc problem, as expected, still exists.

Reviews of a cleaning disc on amazon suggest it may be a solution, so one is now on order. If that does not work I will be left with an expensive photo slide show player via a usb stick !

Thank you again though to the contributors to this thread.

:)

kwinnie
07-11-2012, 06:29 AM
unknown disc error is usually a error code for hardware loader issue. suggest you to contact your local support by www.philips.com/support > go 'contact' tab. good luck.

runadrum
07-11-2012, 05:52 PM
unknown disc error is usually a error code for hardware loader issue. suggest you to contact your local support by www.philips.com/support > go 'contact' tab. good luck.

Thank you for this suggestion - I have sent an email.

The cleaning disc got me nowhere as the player wouldn't recognise it and just repeated the 'no disc' message.

Cyxxon
10-10-2012, 01:10 PM
And I take it there is still no update?

5hellie4nne
10-14-2012, 09:15 AM
Please do another update, I have a few discs with the BD live feature (which I don't use) but when I press play to skip this part it just goes blank and I have to switch off the mains to get it to work again. Game of Thrones 1st series in paticular. Plus I have been reading that Harry Potter discs won't and I was hoping to purchase these in Blu ray but now I am not so sure. Please update the BD3000!!

maided
11-07-2012, 09:13 AM
Hi,

Still the same issue with Director's Cuts of Alien and Aliens blu-rays (the "zooming effect) even on prometheus to alien the evolution box set (9 discs) (EAN : 3344428051006).

More than one year that this issue have been announced around the world.
The last firmware est very old (12-13-2011) for the BDP2500/12.

Will you do something one day for this BR Player ?

Pacman
11-07-2012, 11:45 AM
Personally don´t think any new updates will coem anymore for this device....it looks like long ago one came and for others there are new releases...

kokos
11-08-2012, 08:27 PM
I'm experiencing difficulties when (trying to) play the BluRay version of "Game of Thrones" seasaon 1.
Disc 1: no problem. Disc 2: yesterday difficulty to start, but with some patience....all went well. Today I wanted to watch the last part of episode 4(disc2 had remained in the BDP3000) ......nothing. Player kept displaying "Play", but even "hard restarts"(unplugging AC-cord and waiting 1 minute.....)did not make it play.:mad:
I Tried a lot, but: nothing helped. Other BD's play perfectly though... Anyone similar experiences??(yes I have the latest firmware 1142.1)
.

izogi
12-02-2012, 10:09 AM
I'm experiencing difficulties when (trying to) play the BluRay version of "Game of Thrones" seasaon 1. [...] Anyone similar experiences??(yes I have the latest firmware 1142.1)
.

I've had the Game of Thrones S1 boxed set for many months now. It's started correctly about 50% of the time, on any given disc including disc 1. The other 50% of the time it's become stuck on a black screen (player display says 'PLAY') and everything's completely unresponsive. The only way I've been able to escape from this state is to pull out the player's power cable and reset the entire machine.

Today I had a bright idea, and successfully updated the player's firmware from 1006.1 to 1142.1, thinking it couldn't hurt to try. Now, however, disc 1 doesn't seem to start at all. Six times in a row, I've cut the power to reset the player and it's failed to start, getting stuck again and again on a black screen. As far as I can tell, the firmware update has made a 50% okay series into completely unplayable. :(

This is the only blu-ray series I own and I'm paranoid about buying any more blu-ray. I'm really looking forward to Philips sorting this one out, but considering how long the series has been out and the time since the last firmware update, I'll believe it when I see it. :(

izogi
12-02-2012, 10:34 AM
Today I had a bright idea, and successfully updated the player's firmware from 1006.1 to 1142.1, thinking it couldn't hurt to try. Now, however, disc 1 doesn't seem to start at all.

Immediately after posting this, I went back to try something else, and I think I've narrowed this issue to a problem the auto-start functionality. If I disable auto-start, Game of Thrones S1 disc 1 starts fine. As far as I'm aware there's no nice way to disable autostart, but the following sequence works for me and with firmware 1142.1:

* Insert disc, or power on machine with disc inserted. (Given time, the machine will attempt to proceed with its auto-start sequence upon detecting a disc in the drive.)
* Repeatedly press STOP on the remote until it's clear that the disc won't auto-start.
* Once the DVD player has halted at the HOME screen, select PLAY DISC.
* [for me] The disc starts successfully.

When I do this, the disc plays successfully. I've repeated this sequence four times now, and it's worked every time. Between these successes, I've allowed to the auto-start sequence to play the disc four times, and it's failed four times, requiring me to yank the power cord to force a reset.

I'd be interested to know if other people who've experienced this black screen issue can replicate the workaround, and if it's reproducible then maybe it can help with a proper firmware fix or something.

kabuki
12-10-2012, 01:52 PM
I have the latest firmware, and maybe since i upgraded it i received some faults in reading discs (Unknown disc" reading BR-R with avi and jpg files).