View Full Version : Bug: Time-shift recording crashes on "rewind&watch"

11-13-2011, 08:53 PM
Not sure how to reproduce this, but this is how it happened:

1) I switched to a few channels with Ch+ and started watching NDR (a free digital DVB-C channel).

2) After about 30 minutes, I wanted to start time-shift recording and noticed, it already was started,
because when I pressed "Pause", I actually could go back 30min to the beginning without having to press "Pause"

(I don't know if this an intended feature, but this is really cool, because it allows to replay missed scenes without having to actually start time-shifting! Please keep this, this is great!!)

3) I rewind back about 15 min to repeat the last 15minutes.

4) This worked for about 10(or 15?) minutes perfectly, then suddenly the screen faded to black and came back, but it looks as if it skipped a number of minutes (maybe 10-15min?) then I could continue watching from there.
However, from this point on, the time-shift recording crashed:
- Pressing pause/play/rewind displayed the icons, but nothing happened, so I couldn't replay the part that was skipped.
- Changing the channel didn't work ("First press stop to return to live TV..."), but pressing "Stop" didn't actually stop it.
- I had to switch off the TV and turn it back on (Standby and Back was enough) to be able to switch to a different channel.

Didn't try to reproduce this, but this happened to me twice, so maybe Philips can reproduce it it as well.

The "normal" (manually started) time shifting directly pressing "pause" & "play" after switching to a channel _did_ work. No crashes here.


(32PFL7606K FW Q5551-

Philips - Thomas
11-21-2011, 01:39 PM
Hi matthias

we will look into this and Update you as soon as possible.


11-21-2011, 01:45 PM

I tried to find a way to reproduce it a few times, but unfortunately couldn't find a reliable way to do this.

A guess is that the player _sometimes breaks at the point where the automatically prerecorded part ends and the point where I pressed "pause" begins. Maybe the MPEG-stream has a corrupt frame at that point?

Is there a way to replay the time-shift recording after a reset? Then I could test the next time, if it is the recording.


Philips - Thomas
01-09-2012, 03:26 PM
Hi Matthias,

can you just give me a short notice if you have seen this Issue in the last weeks?


01-09-2012, 03:51 PM
Hi Thomas,

thanks for getting back. I'm sorry I was away the last two weeks and too busy before to try out 14.93, so I'm still running 14.84.

I haven't used Time shifting extensively over the last weeks (maybe 4 or 5 times) and didn't have problems, but this probably not statistically relevant ;-)

I'll let you know of any time-shift issues when I get around testing 14.93.

Best regards,

01-17-2012, 11:48 AM
I updated to 14.93 and played around with time shifting a little more, but I'm not sure what to say exactly.

In general, it works, but from time to time, when using timeshift, I still have problems that I cannot stop it anymore and have to go to standby to be able to change the channel (I had to do this maybe 3 times out of 15 times playing with timeshift).

First, the problems were occurring when I did the following:
1) watch a channel, pause, play, rewind, play, stop -> everything worked

2) again, (not change the channel), press pause, press play (here, it started playing for a few seconds, then it stopped automatically) -> press pause (nothing happened, still not playing), press play -> continues playing without problems, press stop->ok.
This feels like a work around to catch potential problems, because I didn't have this issue previously. It's annoying from a usability point of view, but maybe it helps?

3) again, (again no channel change), press pause -> at this point, it broke. It didn't pause and afterwards didn't react to play/pause/stop. Channel change didn't work ("Stop timeshift first") and needed to go to standby.

This is quite difficult to track. Sometimes, I have to repeat each step 1) or 2) several time before it crashes. It seems to take longer (i.e. more tries) to crash after a cold start.

It still does crash from time to time, but still only occasionally. There is not SW error log entry. Is there something else I can log to help debugging?

In general, it seems, there are less crashes, when I give the TV enough time to react between each key press (i.e. at least 15 seconds between each key press). It seems to be more unstable if I leave only 1-3 seconds between each press.

Also, I'm not sure if this was coincidence, but I experienced more crashes on BR-alpha than on Arte for example. Not sure what to make of this though. Maybe just coincidence.

Compared to the 14.84 FW version, it doesn't seem to be better now. After leaving enough time on 14.84, I think I found a way to keep it working more reliable.
I don't know if 14.93 is better or worse (well, maybe with that occasional automatic pause, which requires press pause, press play, actually UI is a little worse)

But I'll keep an eye on it and keep you updated!

If you have any other suggestions what to look for that may help debugging this, just let me know.


01-31-2012, 04:53 PM
My TV just crashed again during Time-Shift Recording:

Here's what I did:
- Watching zdf'neo for ~40min
- rewind for 5 min
- watching again 10min
- pausing for 10 min
- another few rewind,watching&pausing
Until here, it worked.
- then I tried to rewind to the beginning (the lightgrey band showed ~60min of possible rewinding)
- after rewinding finished, it didn't play, but crashed: I got a black picture. Pressing stop didn't give any error, but no picture appeared. Switching channels always showed a black picture.

I had to power-cycle the TV to get a picture again.

Best regards,