PDA

View Full Version : BDP3000 - cant read any disc or update firmware



Windrider
11-26-2011, 11:16 AM
My blu-ray player can't read any disc at all. It just said "unknown disc" everytime. I have tried with DVD's and Blu-ray disc and it just says the same. Tried to reset all settings to factory settings but it doesn't help at all. This has been a problem for a long time now and today I tried to update the firmware on it by using a usb device but it didnt work either, it just said "Can't upgrade" then it just re-boot itself. So anyone got any solution to this problem?

Pretorian
11-27-2011, 03:20 PM
I have the BDP3000/12 player and it suddenly stopped reading any disks and it does not recognise the software update on USB.

Advice please.

smp
11-27-2011, 05:09 PM
It is obviously a problem with the optical drive. Time to buy a new player.

kwinnie
11-28-2011, 08:30 AM
agree, it s to me a loader issue if you say it cant play any disc of yours...

Kiro
11-29-2011, 10:35 AM
Hello Windrider,

before to give up, try this: during the upgrade process, when a message pop up asking if you want to confirm or reject the modification done, click on "reject" instead. I read on a forum that there was an exchange in the buttons' functions, just for BDP3000.

Let me know if it worked ;)

RobertThomas
03-14-2012, 08:36 PM
We are having the same problem with the firmware upgrade software not being recognised on the USB stick.

We can watch some discs but some ( Game of Thrones ) wont play. We cant upgrade as the software isnt recognised on USB and the network download option seems to just stop without progressing at the point of the progress bar.