PDA

View Full Version : MyRemote and Samsung GT5570



Silvia
12-04-2011, 09:13 AM
When i try downloading MyRemote from Android apps store i get a message i is not compatible with my device (samsung GT 5570). it is just an Android phone with android version 2.3.5. Why is it not compatible?