PDA

View Full Version : FLAC playback issue



kwetal
01-04-2012, 01:04 PM
Using NP3500/12 with Mediatomb upnp-server on Synology NAS.
When playing FLAC files, often the last 3-7 seconds of the file are skipped/cut off.
The problem is persistent: it occurs again when the file is played again.
Playing the same file with another upnp-client does not show this problem.
Any hints?

gs27
01-07-2012, 10:58 AM
Did you try turning off transcoding options on the NAS ?

I have a synology NAS as well, and using DS Audio as DLNA server, and had the same issues (sometimes only), while streaming FLAC files: it turns out disabling transcoding options (as the NP3500 can handle FLAC files) solved the problem.

NB: I'm still having issues with s24le and s32le encoded FLAC files though, but I'm not sure this comes from the streamium renderer, as the NAS doesn't seem to be able to transcode them either. It just seems there are limitations with Little-Endian float encoded FLAC files).

kwetal
01-08-2012, 11:48 AM
Did you try turning off transcoding options on the NAS ?

I have a synology NAS as well, and using DS Audio as DLNA server, and had the same issues (sometimes only), while streaming FLAC files: it turns out disabling transcoding options (as the NP3500 can handle FLAC files) solved the problem
Thanks for your hint, but it will not work:
1) transcoding is not switched on: <transcoding enabled="no"> in /opt/etc/mediatomb/config.xml
2) the FLAC files decode OK when I use another upnp-client (and the same server)
I also discarded the use of the native Synology upnp-server and use Mediatomb now, but the Streamium shows the cut-off effect with both servers.

However, I might try to switch transcoding ON and see how well that works.

gs27
01-08-2012, 06:00 PM
Does that happen only on shuffled playlists ? Cause I remember some issues with Mediatomb (prior use) which had to do with the way Mediatomb actually streams the files when shuffled.

That's a possible hint, though I've never known a fix for that: you might actually search for Mediatomb related issues if that's the case.

kwetal
01-10-2012, 12:43 PM
Does that happen only on shuffled playlists ? Cause I remember some issues with Mediatomb (prior use) which had to do with the way Mediatomb actually streams the files when shuffled.
Unfortunately not. I didn't use the shuffle option on the Streamium until you made this hint. The cut-off effect happens to the same flac files all the time, no matter along which path I access them with the Streamium. (The "directory structure" that is offered by Mediatomb makes it possible to arrive at the same media file via different ways, e.g., via the "Audio/Album" route, or "Audio/Artist", or "PC Directory". No matter which route is followed, the cut-off effect happens to the same files all the time.
I even tried re-coding the offending FLAC files from the original cd's, but to no avail.
Moreover, as stated earlier, the problem does not occur when I use another upnp-client (foobar2000 on a windows pc and djmount on a Linux pc) so I am pretty sure the problem lies in the Streamium, not in Mediatomb.

llesniew
04-20-2012, 12:54 PM
I can't get my NP3500 to play FLAC files at all using Media Browser Powered by Twonky Media Specially Developed for Philips v 1.1.1.12 - any ideas what I might doing wrong?