View Full Version : Problem reading some 3D Blu ray

01-09-2012, 04:24 PM

I just bought a the TV 47PFL7606 with the blu ray player BDP7600/12, I installed this weekend the latest firmware for both devices. I received also for Xmas the blu-ray disk Rio, I tried to show it to my grand son but viewing in 3 D is impossible. I have the impression that the same problem exists with the film "Gulliver's travel" and Ice Age 3!!
It seems also that I am not the only one encountering this problem. Is somebody aware of what is the source of the problem and is there something tpo do?


01-09-2012, 05:06 PM

well - you should describe what exactly is "impossible". With your describtion we cannot help you.


01-09-2012, 06:11 PM
Thanks for you quick reply... see below a trial of description of the problem: (and it's not coming from the disc as I changed already)
First, it takes quite a lot of time before the blu ray is starting. (blu ray player dispay 00000). Then, when it starts reading, all static images are OK but as soon as there is a movement, the image is not sharp, it's blur, giving headdeck after 5 minutes. In fact as soon as there is a move it seelms that the images are split into two

Philips - Thomas
01-10-2012, 09:43 AM
[Topic has been moved to BDP Subsection]

01-19-2012, 12:00 PM
Hi did you try to test on other tv/bdp? Did you already changed the cable and try a new one. Is it on all 3D movies or are there any not giving problems...


01-19-2012, 04:35 PM
1, All other 3d movies are running OK
2, I have not tried it on another TV/BDP but I exchanged the blu ray , my first though was indeed a bad blu-ray
Is someone else having the movie and having test it on a BDP7600?

01-27-2012, 09:48 AM
1, All other 3d movies are running OK
2, I have not tried it on another TV/BDP but I exchanged the blu ray , my first though was indeed a bad blu-ray
Is someone else having the movie and having test it on a BDP7600?

Hi eti126,

I have exactly the same two devices (BDP7600/12 and TV 47PFL7606K/02) and I also have the same problems! All our previous 3d blu rays work perfectly, but the new ones (RIO 3d and Ice Age 3) work like yours. It seems as if you have two pictures which come a bit later to one eye than to the other. Yes, as if it was split in two. The picture is blurred and if I look to the TV some minutes my eyes ache...

So it seems to be a problem with the devices and not with the blu rays!

01-27-2012, 09:56 AM

please try the new firmware 1.42 for BDP7600...


01-27-2012, 10:51 AM
Hi Toengel,

thank you for your quick reply!
I just updated my blu ray player (1.42) and there is still the same problem. :-(
(but only "ice age 3" and "rio", other films like harry potter, Tangled, Coraline, Cars2... run perfectly in 3d)

And now?

Thanks for your help!

01-27-2012, 10:53 AM
Which are the EAN codes, think some testing is needed

01-27-2012, 11:00 AM
EAN ICE AGE 3 : 4 010232 055330
EAN RIO : 4 010232 054326

Thanks for your help!

01-27-2012, 03:37 PM
Probably this two devices cannot read the "20th century fox" 3d blu rays, because the problems occure only there (dreamworks, sony, and other work perfectly)

01-27-2012, 07:27 PM
And for me code EAN for Rio =8 712626 094067

Thanks also for searching.... because this problem is quite annoying, I don't dare to buy any new 3D blu-ray

01-29-2012, 03:34 PM
I have a problem with the conan 3d bluray. After starting, the movie stutters extremly and is completly unwatchable. Is there a new fw on the horizon that fixes that problem?

01-30-2012, 11:02 AM
Did one of you guys by any chance have the possibility to test the BDP on another TV and did you see the problems there also?????????


01-31-2012, 07:40 PM
I am also experiencing Blu-ray playback issues with my Philips BDP7600/12 Blu-ray player. The 3D RIO Blu-ray is not rendered well - showing stuttering and basically 'lacking framerate' all through the film. I also noticed an *incredibly* long loading/startup time. I am using the BDP7600/12 with my Philips 42PFL7656H/12 3D Easy TV. It is interesting that RIO is my first 20th Century Fox 3D Blu-ray (all of my other 3D Blu-rays work great). Hopefully Philips can solve these playback issues, because I am *really* looking forward to obtain a working Avatar 3D and Prometheus 3D Blu-ray in the future...

I have installed the latest v1.42 firmware update, but the playback issue remains.

The UK Fringe Blu-rays are also causing issues, but only in the menu screen. When navigating 'up' to select subtitles/language/extras, the menu often just freezes completely, and the only option left is to stop playback and restart loading the Blu-ray.

Can Philips look into these issues?

02-01-2012, 06:16 PM
Hi pacman,

yes, we tested the rio and the ice age 3 films on an LG TV with LG bluray player and both films worked properly in 3d.

So it seems to be a problem only with philips devices.


02-06-2012, 07:42 PM
Since the moment I attempted to play my RIO 3D Blu-ray (see 2 posts above for my earlier report and used hardware) I noticed that my *other* 3D Blu-rays gained 'framerate issues' as well. For instance, my How To Train Your Dragon 3D Blu-ray (which *always* used to play well indeed) started to have the same annoying symptoms that the RIO 3D BR gave my player.

My first thought was that the 1.35 and 1.42 firmware were responsible for messing up the playback of 3D titles in general. However, after attempting a 'reset to factory settings' in my BR player's menu, at least I am back to where I started: being able to play all of my 3D Blu-rays *except* for RIO 3D.

So for other people who are having troubles with their 3D collection after having tried RIO 3D, consider resetting your BR player to factory settings. It helped with my player.

I noticed the RIO 3D Blu-ray might be some kind of 'hybrid' disc. It both plays 2D (it looks well when the TV is in 2D mode, and plays without any issues), and 3D (causing horrible issues with my player, unfortunately - like the player 'cannot keep up'). Perhaps the Philips BR player has difficulty with that hybrid-like format?

If Philips could shed some light on this, or fix it, I would be interested in hearing about it. Philips, please do get involved in this thread...

02-07-2012, 10:04 AM
Hi NickNightingale,

the same happend to my player after installing both firmwares (1.35 and 1.42)! And I did the same, resetting to factory settings. Now all our 3d blurays work perfectly (again) except rio and ice age3.

So I'm still waiting for help from Philips as well. Hopefully they will fix it soon, because I don't dare buying any new 3d films until I know they work.

02-09-2012, 06:25 PM
Thnaks NickNightingale for your advise. As I went to v 1,42, I will also make a reset to factory settings . Now I find Philips very quiet with our problem, I will try to call them directly and see what I get as reply.

02-14-2012, 10:39 AM

Just wanted to let you know i have the exact same problem with the 3000 series BDP3280/12 .

Seems like a problem with encoding on some 3D Blurays


Hope this gets fixed soon!

06-15-2012, 06:58 AM
Hi Griz, Eti, NickNightingale and so on,

did one of you already solve our problem? Or did anyone get an answer from philips, that the viewing problem will be (or probably even already is) solved?

Thanks for your feedbackl!


06-15-2012, 08:34 AM
hi there,

suggest you to upgrade to the latest firmware and test again.
also, it sounds like disc issue, suggest to checkc with the disc manufacturer, indeed for philips, better they can test this out

Philips - QK
06-15-2012, 08:42 AM
Dear Birdy,

I have sent you a PM. Please check.

Kind regards,
Philips Moderation Team

07-13-2012, 04:57 PM

A problem I found is with the blu ray disc of the Fantastic Four: Rise of the Silver Surfer, EAN 8712626036623 a Dutch/France release (20th Century Fox). Most of the supplements are not visible or selectable. I can only see/select from the extras the two audio commentaries. But none of the others like The Making of 'Fantastic Four etc. etc is visible. This problem is present under firmware V1.42 and 1.55.