PDA

View Full Version : 42PFL3603D/27 Audio Drop



damselfly2
01-10-2012, 02:51 PM
Hello,
I'm hoping someone can help me as the Philips Support has been an epic fail on multiple occasions.
I have a 42PFL3603D/27 that randomly drops the audio signal when connected to my laptop via HDMI. I'll be watching a movie (not even streaming) or listening to iTunes or Pandora and the audio will just drop out and go all scratchy. the only way to 'fix' the problem is to disconnect HDMI cable and plug back in. Then audio comes back. Picture is never lost and I have not had any issues when connected to Blue Ray player - so it's quite the conundrum. Software is up to date (well, the last update version available is from 2008!)
Another piece of info: I just purchased a small Philips 19PFL4505D/F7 for my bedroom - did a quick test watching the same exact movie I tried on the 42 and it was flawless! Never dropped sound! I've also tried a different HDMI cable (as recommended by Philips) and of course, that did not solve the problem.
So the problem is definitely with the 42PFL3603D/27 which renders the TV useless as far as Netflix/music/streaming etc. which is why i bought the TV back in 2009 in the first place! :mad:
Any help appreciated - I've been dealing with this for over a year with Philips and have gotten nowhere. It would seem they are aware that this is known firmware issue, and yet, they do not rectify the problem. Also, what would happen if I installed the firmware from the 19PFL4505D? Just curious... at this point - I've got a useless TV and I'm willing to try anything before going out and buying a SONY! :rolleyes:

Philips - Thomas
01-18-2012, 12:03 PM
Hi

Pls get in contact with your local Call Center to have this addressed.
http://www.support.philips.com/support/catalog_selector.jsp?COOKIE=off

Regards
Thomas

damselfly2
01-18-2012, 11:17 PM
Hi

Pls get in contact with your local Call Center to have this addressed.
http://www.support.philips.com/support/catalog_selector.jsp?COOKIE=off

Regards
Thomas

Thank you but I have already devoted almost a year to Philips support. I got 6 months of blaming my laptop and 4 of telling me to buy a new HDMI cable and keep hot-starting when watching movies - which leads me to believe that there just is no fix. I was hoping someone here had a some way to make it work - because it is clear that Philips has no intention of remedying the issue on this model TV.

Philips - Thomas
01-19-2012, 06:26 AM
Hi

I'm sorry about your experiences but this Forum is for European TV's only so i guess you will not find help in here.

Regards
Thomas