PDA

View Full Version : SA3MUS16S/37 USB functionality totally gone



jimwi97007
01-13-2012, 06:54 AM
I've had my GoGear SA3MUS16S/37 for about 6 months. It played fine. Recently, I saw that there was new firmware available from a message from Songbird. I had version Songbird 2.5.6. The player's firmware was 1.34. Evidently a bad combination...as the player bricked! Luckily I found the support forum and found out you had to use 2.5.4. After several attempts, I got it to update to 1.46 but then had the menu problem of nothing but ?????. I did a repair again, and this time it seemed to work OK. I did not have time to download some music into the player (it was 3AM by the time I got the player restored) so I turned it off.

Now, it's a week later. I plugged in the USB cable into the player, and the usual Win7 USB connected message did not appear. I also did not get a message on the player screen if you wanted to just charge or wanted to transfer and charge. I tried selecting MSC and MTP modes manually, made no difference. No connection whatsoever. So, time to do yet another repair session. Unfortunately, the repair session did not start. I held down the volume up button for 5 minutes and the little message window on the PC screen never went away. The cables are fine. I used two different cables on two different USB ports (front and rear of PC), no difference. I did notice after about 10 minutes of being connected to the PC, the battery charging indicator pop up over the battery symbol, which is good news. However, still no data transfer capability. At least the FM radio works OK...

I have a modern AMD Athlon II triple core processor PC running Windows 7 Home Premium. I am quite experienced in electronics (electronics engineer) and audio/video equipment. I'm not a noob on this stuff.

Now what? How do you "repair" a device whose USB funtionality is now toast?

This experience has soured me on any Philips products that contain bits.

Philips - Andrea
01-13-2012, 08:31 AM
Dear jimiwi97007,

Sorry to hear about the problems you have experienced. It would seem that the issue may be down to a USB functionality failure as you say. However, as you have experienced the problem after attempting to upgrade your firmware using Songbird I would suggest the following in an attempt to rectify the issue:

Uninstall Songbird from your PC
Delete all Songbird drivers
Connect your GoGear and use Windows Media Player to open the files
This will check to see if it is the USB connections only that have failed or if the issue is related to Songbird. If this does work, please let me know so I can look into the issue with Songbird.

However, if you are still unable to use your player I would in this instance suggest contacting your American customer care team to discuss the next steps: http://www.support.philips.com/support/contact/contact_page.jsp;jsessionid=488A340CFC575324EECEAB 8135EB6E73.app106-drp1?userLanguage=en&userCountry=us&_requestid=3495081

Kind regards,

Andrea

jimwi97007
01-13-2012, 08:59 AM
Andrea:

Thanks for the quick reply. I uninstalled Songbird 2.5.4. Now, which Songbird drivers do I uninstall? I still see rk28usb.sys in the C:\Windows\System32\drivers directory, and there is the C:\Windows\System32\DriverStore\FileRepository\rk2 8usb.inf_x86_neutral_bc1f1ad834ae8f27 directory that contains rk28usb.cat, rk28usb.inf, rk28usb.PNF (with today's date) and rk28usb.sys. Are there any other drivers or files that I need to blast away? Do you folks have a utility that also cleans all registry settings so if you wanted to do a fresh clean install, you could do so?

As a point of interest, when I first had problems with Songbird 2.5.6 trying to update the firmware, I used the chat facility on the main support page. I was told to uninstall 2.5.6 and use the open market Songbird from getsongbird.com. I asked the support agent if that program did firmware updates. He said yes. Turns out he was totally incorrect. If you ant, I can PM the chat conversation to you if remedial instruction of your support agent(s) is required.

jimwi97007

scubaboyc
01-13-2012, 04:10 PM
How did you get songbird to not update to 2.5.6?
When I installed it, it automatically did it and did not give me the option to by-pass it. I downloaded 2.5.4 from the support site. The update happened so quick, I didn't even get proper access to Songbird until after the fact.

Can it be assumed that if you have a SA3MUS16S/37 then you should never let Songbird updated?
Thanks.

jimwi97007
01-14-2012, 01:01 AM
Scubaboyc: When I installed Songbird 2.5.4, after about a minute or so, a pop-up window came up on upgrading to 1.9.6. That was the cue to 2.5.6, so I canceled the update. Evidently, you were not as lucky. I noticed in the pop-up that if you "upgraded", whole buckets of functions were disabled, including the ability to upgrade player firmware.

Note to Andrea:

After I had uninstalled Songbird, I rebooted the computer and looked in the Windows driver directories. The RK28usb.sys file was still there, and so were the repository files. I re-named the RK28usb.sys to RK28usb.orig to force a driver re-install when the device was plugged in. I never got a notification. I did some Win 7 device troubleshooting, and it found an unknown device. I had it try to ID it, but no luck. It appears that the USB signalling from the player is not happening. When you plug in the player, there is zero PC activity (no
USB connect sound or pop-up notification) and the only clue is the player's screen brightness changes. That is most likely due to the player's sensing it has now been hooked up to +5V USB power.

Conclusion: My SA3MUS16S/37 player's USB data connectivity has failed. The only way that can be restored is to take the player apart, find the JTAG connector, and do a direct flash memory firmware restore. That task is something an end user CANNOT perform. I will contact the USA support center for a warranty return.

scubaboyc
01-14-2012, 03:00 AM
I tried deleting the C:\Windows\System32\DriverStore\FileRepository\rk2 8usb.inf_x86_neutral_bc1f1ad834ae8f27 folder and it wouldn't let me.
Should I assume the same for you?

I'm going to assume there is no way to get rid of it since it says you need permission from SYSTEM to do anything to it.
I think it's one of the 47 files/ folders I can't get rid off when I do a registry cleaning.
Thanks.

This may help in getting rid of the files, I'm going to try tomorrow (you may have already tried, but just in case):
http://www.howtogeek.com/howto/windows-vista/how-to-delete-a-system-file-in-windows-vista/

scubaboyc
01-19-2012, 03:06 AM
jimwi97007,
Did you have any success removing the drivers? If so, can you please share? I tried the method in the link posted above and it didn't work. I'd like to re-install Songbird, but it keeps failing.

Thanks,
scubaboy

jimwi97007
01-20-2012, 04:49 AM
scubaboyc:

I did not attempt to remove the drivers in the DriverRepository directory. As I mentioned what I was going to do, I contacted the USA support center for a warranty return. I should be getting my new (hopefully not a refurb) player in about a week or so from today. And, no matter what firmware is in the player, I'll NEVER attempt to upgrade it again, as the Philips updater is a dangerous tool and kills players. I just don't have any confidence in Philips' ability to write stable, robust code for their products. Just check out the HDTV forums for owners complaining about buggy and unstable SW on their TVs.

You need the RK28usb drivers to be able to use the player on your PC, Songbird or not. My suggestion is to get one of the commercial uninstaller programs to wipe out the remnants of the Songbird install. Norton Utilities or System Mechanic registry cleaner may also help you on the Songbird reinstall issue. I think what may be happening to you is NOT the USB drivers, as they are just resting in the driver directories, waiting for a RK28usb device to present itself. Most likely you have damaged registry settings or corrupted leftover files from previous Songbird installs that are hindering the reinstall process.