View Full Version : BOOK OF ELI and APOLLO 13 DON'T WORK?!

01-14-2012, 08:14 PM
Hey guys,

I wondered if you could maybe help me. I've got some troubles with my Bluray Discs "The Book of Eli" (Steelbook) and "Apollo 13" - both are from "Universal Pictures".

My Player just can't read the discs. I sure bought originals on Amazon, so where's the problem? It's so frustrating, when you've spent so much money on a good Bluray Player and even more for those Bluray Discs and it just doesn't start or even find the disc. It always says "Unknown Disc" in the main menue.

I had the same problem with the normal version of "The Book of Eli" - in fact that was why I've bought that damn even more expensive Steelbook-Edition of that movie. Result: it does not work either. Today I've got my brandnew Apollo 13 (normal version) Bluray and it does not start aswell.

The player tries to load them for about a minute until it stops and says Unknown Disc.

Here's what my Bluray Player version infos say:

Model: BDP7500MkII/12
System SW: 1.53
I'm from Germany by the way.

When I updated the player, it only installed 1.53 - allthough I've seen there is a v1.60 out that time. I can't update to a higher version, but I'm sure that would not fix THIS PROBLEM at all.

Is there anything known about these two movies (German Editions)? Any Firmware-Updates?

Thanks and greets!

01-15-2012, 10:13 AM

you need to update your player via USB - not all updates are delivered via the integrated update mechanism. Format your USB stick with FAT and be sure that NO disc is in the try during updating...

After updating, please test again.


01-15-2012, 07:04 PM
Thank you so far with that firmware-issue, it worked. My player is now on v1.60 :)

As I thought, it didn't solve that problem with the movies. Apollo 13 and Book of Eli still don't work on my Philips BDP7500. I've just tried another new Bluray from Universal Pictures, "The Adjustment Bureau" (Matt Damon)... my player had severall problems to get the disc running, but finally it worked here. But I don't know what to do with the other movies. I've tried it a dozen times... They worked perfectly well on my buddy's Playstation 3 so it hasn't anything to do with the Bluray discs themselves. It must be a problem with the player, maybe that can be fixed with another firmware update?


Kind regards ;)

Philips - Remko
01-16-2012, 06:48 AM
Hi iLegend,

I have send you a personal message.