PDA

View Full Version : Video Stutter pixel precise HD engine



bart8
01-21-2012, 09:36 PM
Dear Philips,

I have a 50pfl7956 (Philips cinema gold) TV, with the latest software version installed (000.014.093.000, 2011-12-21). The TV uses the pixel precise HD engine.
95% of the time I have this TV connected to my pc for playing movies.
When I play a 1080p movie and in the movie, the complete picture moves at a constant speed, then the video on the TV stutters. With moving at a constant speed, I mean the camera slowly turns round to give a panoramic view or for example when playing the closing credits of a movie, where there is not only text but also some background (for example in the movie “Shrek forever after”). I find this stuttering extremely annoying. When I play the movie both on the laptop screen and on the TV screen at the same time (clone the display) the stuttering only happens on the TV, so the problem is with the TV and not with the pc.

The stuttering only occurs if the complete picture moves, when for example a fast car moves across the screen, no stuttering occurs.
An employee at the Philips MyShop (Philips personnel only store in Eindhoven, Netherlands) told me the problem was with the pixel precise HD engine, which was not powerful enough. And that I should try to set the Perfect Natural Motion to minimal. However, I use the TV in the "PC mode" and I can't change the Perfect Natural Motion setting when the TV is in the PC mode.

A software update should be able to make the tv recognize when the picture is moving at a constant rate so that the pixel precise HD engine does not need to calculate the movement of every individual pixel

I find video stuttering when playing simple closing credits on a 2000 euro TV unacceptable, especially if the TV is provided with 60 Hz 1080p pixel information over HDMI, the TV only needs to display the pixels! no fancy internet media streaming or whatever needed.
Philips, can you please offer a solution?

anyone else experience this problem?

petasis
01-23-2012, 05:41 PM
Can you provide any details on the software you are using to play the movie on the PC, the refresh rate of the desktop when the movie plays, and the settings on the TV regarding motion?

What the employee at the shop told you, cannot be true. I think it is a problem with your pc...
(Else you would have problems when watching TV or a satellite receiver...)

bart8
01-23-2012, 07:27 PM
Thanks for your reaction, petasis.

I use XBMC and VLC media player to play the movies on my pc. (both recent stable versions)
the problem occurs using both XBMC and VLC.
the laptop is a HP compaq 8510w running windows 7 enterprise 32 bit version
processor: Intel core duo CPU T9300 2.50 GHz
4,00 GB RAM (3,00 GB usable)
GPU: Nvidia quadro FX 570M

I am not sure if the problem occurs when watching tv, I rarely watch regular tv and if I watch tv the source is old fashioned analog kable tv, so I do not have acces to HD TV over the cable.

When I connect my laptop to my tv the laptop puts out 1920x1080p at 60 Hz.

I assumed the problem could not be my laptop, since when I select "clone the display" in the control panel the laptop screen and the tv receive exactly the same information (wright?) and in this case the tv does show stuttering while the laptop screen does not.

The tv is set to "Pc mode"
and the "smart picture" setting is usually set to Vivid, but the problem allso occurs when setting the tv to another smart picture mode, like: isf day, isf night, cinema etc.

is this information useful?

petasis
01-28-2012, 07:15 AM
When you set the TV to PC mode (which is for using it as a monitor actually), the TV sets a gamma at 1 (wrong for watching movies), and disables all motion processing - showing exactly what your PC card sends.

So, when you observe stuttering, this comes from your PC.

The problem with your setup, is that the movies come at 23.976 Hz. Since you are not able to output this frequency from your laptop (so as the TV to handle it correctly), you output 60 Hz. This means that your video player, must convert the 23.976 Hz to 60 Hz, a conversion that cannot be made exactly, which means that a frame must be dropped at a specific interval.

Depending on what the movies shows at that time, you may observe or you may not observe the dropped frame. I suspect that this stuttering happens all the time on your setup, but you observe it only during pannings.

So, what to do from here?

First of all, do not use the PC mode. Use cinema, with PC mode disabled. PC mode, is only for using the TV as a monitor.

Then try to not use your TV in clone mode. Clone means both screens show the same, and you are limited by your laptop screen, which typically is locked at 60 Hz. Check if setting your TV in other mode (extended, or what other mode your card allows), allows you to also set a different framerate (we are targeting for 23 Hz if it is offered by your card or 24 Hz).

Enable the motion interpolation handling of the TV. Enable perfect natural motion to minimum )not to off).

Try a better player. I suggest media player classick home cinema. This uses its internal codecs, and has a useful function of changing the screen refresh rate when in fullscreen, and also a mode that displays the timings with graphs on screen (selecting control-J). There, you can see the video frame rate, the audio frame rate, how they deviate, and when the dropped frame occurs in the player, to correct these offsets. It will help you find out what is the best setting for your setup.

Finally, if you cannot use a different frequency at the TV and you are locked to 60 Hz due to the laptop monitor, and you want perfection, you should by a media player, that is able to export 23.976 the movies have...

bart8
01-28-2012, 11:00 AM
Many thanks for your input petasis,

I am currently in the middle of an exam period (I’m a student at a technical university in the Netherlands), so I don't have time to play around with my TV at the moment. But after my exams (in about a week time) I will try out your suggestions and post my findings here.
I remember XBMC has a setting to sync the monitor refresh rate to the video refresh rate, this might be useful. but I will also try classic home cinema as you suggested.

Your information on the PC mode is surprising, in the manual Philips does not make this distinction. Philips simply advises to use the PC mode when the TV is connected to the pc. I used the pc mode because it fixed the overscan issues I was having when the TV was not set to pc mode.
I could also solve this overscan issue by reducing the resolution outputted to the TV, but this seems like a bad solution to me, since the pc compresses a 1080p video to say 1060p and the TV scales that up again to 1080p.
anyone know a way around this problem?

petasis
02-02-2012, 05:41 PM
My experience with XBMC is that it was not working correctly. It has an amazing interface, but I never managed to get smooth motion from it. Perhaps it depends on the codecs of the system....

Regarding overscan, things are really easy. You just switch to the input that shows the TV desktop, and set the "screen edges" to 0 (it may be at 5 - the default), and from the picture format the last setting (unscaled).
You have to switch to HDMI and have signal (i.e. you see the HDMI signal) for the "unscaled" option to appear.

Phil82
04-27-2012, 09:13 AM
Sorry for digging this up.

Found this thread after googling this issue, which I experience as well since I bought my Philips LED TV yesterday.
Model = 52PFL8605H/12


Unfortunately I really find that problem is in the pixel precise engine as this weird stutter also occurs during HD TV opposed to streaming media (which I do as well, and NEVER had any problems with on my Samsung TV). I find that the stutter goes away when I either put the TV in PC mode or select Normal smart mode. It looks like both modes disable all the pixel precise options, explaining why the stutters goes away.

However, I do not agree that this should be my solution, as I can really see the more vivid and alive motion when 200hz and perfect motion is enabled, disabling it makes no sense, as these are features I paid for.

What's the deal with this? Little bit annoyed that I constantly need to fiddle with settings and never have the 'satisfied' feeling I should have when buying a rather expensive new TV.

Regards,
Phil

Michelvw
07-30-2012, 09:18 PM
And I'm digging this topic up also.

I currently own a brand new top-of-the-line 42PFL7606 H12 600Hz tv.
I am also experiencing this stutter on all kinds of inputs, including normal digital TV.
I am really satisfied with my, albeit expensive purchase.
The image quality, black levels, etc are great.

This stutter is that annoying needle that keeps digging deeper into my skin.
As said by Phil82, I'm also a firm believer that disabeling option A and B, the constant fiddling, should not be there.
If anything, an expensive purchase like this should work perfectly out of the box (Spent a week fiddling with drivers for my laptop to get sound to my tv - was plug and play with every other tv I have ever connected to it...but ok it's solved now). Hell, a 300 euro samsung tv works flawlessly out of the box.
What gives, Philips?

Thanks in advane for any help.






Sorry for digging this up.

Found this thread after googling this issue, which I experience as well since I bought my Philips LED TV yesterday.
Model = 52PFL8605H/12


Unfortunately I really find that problem is in the pixel precise engine as this weird stutter also occurs during HD TV opposed to streaming media (which I do as well, and NEVER had any problems with on my Samsung TV). I find that the stutter goes away when I either put the TV in PC mode or select Normal smart mode. It looks like both modes disable all the pixel precise options, explaining why the stutters goes away.

However, I do not agree that this should be my solution, as I can really see the more vivid and alive motion when 200hz and perfect motion is enabled, disabling it makes no sense, as these are features I paid for.

What's the deal with this? Little bit annoyed that I constantly need to fiddle with settings and never have the 'satisfied' feeling I should have when buying a rather expensive new TV.

Regards,
Phil