PDA

View Full Version : HDMI ARC only working sporadic with 40pfl6606t



Bastrup
02-20-2012, 07:05 AM
Hi,
I try to get the HDMI ARC functionality to work on the following setup: 40pfl6606t TV with onkyo tx-nr509 receiver. I have had only limited success, where it has only been working a couple of times. Getting it to work is quite cumbersome and involves reconfiguring and power cycling the devices a couple of times. Then it works as intended, until I put the TV and Receiver to standby (TV powers off the Receiver), the failure scenarios is then the following:
Scenario A: (Easylink: on, Easylink Remote: on, TV Speakers: Easylink)

1. I turn on the TV from standby.
2. TV turns on and after a while reports that "external amplifier is active". This is also reported on the Onkyo display
3. From the Adjust menu I then ask to switch to amplifier
4. TV reports: "Connecting to amplifier failed - activating TV speakers"
5. TV speakers active is also reported on the Onkyo

I can do a Scenario B, with TV speakers set to Easylink Autostart:
1. I turn on the TV from standby.
2. TV turns on and after a while reports that "external amplifier is active". This is also reported on the Onkyo display
3. TV reports: "Connecting to amplifier failed - activating TV speakers"
4. TV speakers active is also reported on the Onkyo

So result is the same, it only happens automatically.

I have tried different HDMI cables, results are the same.

Any ideas on where thing goes wrong?

Kind Regards, René

Lassy
02-20-2012, 07:31 AM
I've got a similar problem: http://www.supportforum.philips.com/en/showthread.php?4626-Can-t-ARC-get-to-work-on-AV-Receiver&p=26398

No messages appear on my receiver though. Using a HDMI 1.4 cable did not work either. There is no interactivity noticeable between my TV en AV receiver at all.

Bastrup
02-20-2012, 02:57 PM
OK it seems like the HDMI ARC problem is now reported with the following receivers: Yamaha RX-V671, DENON AVR-2312 and Onkyo TX-NR509.

With regard to cables, I do not see any specific cable requirements for the ARC to work (looking at hdmi.org specs. for ARC, the following is mentioned: "All HDMI cables will support Audio Return Channel functionality when connected to Audio Return Channel-enabled devices. You can use your existing HDMI cables or choose a different cable type"

Lassy
02-20-2012, 03:47 PM
You are right. Although the info regarding ARC in the FAQ on hdmi.org is somewhat misleading and reads as ARC was introduced with HDMI 1.4


What’s new in the HDMI 1.4 specification?

•Audio Return Channel
The new specification adds an audio channel that will reduce the number of cables required to deliver audio “upstream” from a TV to an A/V receiver for processing and playback. In cases where a TV features an internal content source, such as a built-in tuner or DVD player, the Audio Return Channel allows the TV to send audio data upstream to the A/V receiver via the HDMI cable, eliminating the need for an extra cable.

Lassy
02-21-2012, 10:09 AM
OK it seems like the HDMI ARC problem is now reported with the following receivers: Yamaha RX-V671, DENON AVR-2312 and Onkyo TX-NR509.


Where and to whom has it been reported to? Where can we get any updates on this?

Bastrup
02-22-2012, 12:24 PM
The reporting part was merely the result of my own search through this support forum, revealing the following threads with similar problem.

http://www.supportforum.philips.com/en/showthread.php?4626-Can-t-ARC-get-to-work-on-AV-Receiver&p=26398
http://www.supportforum.philips.com/en/showthread.php?4051-40PFL6626H-fails-to-connect-on-ARC

I actually managed to get the ARC functionality to work in a quite consistent manner. The following sequence did the trick (actually part of the solution is also decribed in the Onkyo manual as a note, which I completely missed).

1. Disabled all HDMI ARC functionality on both TV and reciever.
2. Power cycled both units (disconnect from mains and power on again)
3. Enabled Easylink + HDMI ARC on TV
4. Enabled HDMI ARC on receiver
5. Power cycle both units (disconnect from mains and power on)

Thereafter the HDMI ARC function works, and seems to be quite stable. At least for my case it seems like the power cycle is required in order for the units to do a proper synchronization.

Lassy
02-22-2012, 12:28 PM
OK, thanks. I believe I did all this but I wil try this again tonight.

Edit:

No luck so far. I need to get this fixed as my current SPDIF connection gives audio drop outs :(