PDA

View Full Version : Stucked before firmware update finishes



etitor
02-21-2012, 04:34 PM
Hi friends. I just came home with my new MCI900/12. I read the manual. I followed the manual.

Ten minutes later I was listening to music on the USB HDD. Bingo!

Five minutes later I entered settings, gave the wifi Internet password to the MCI900/12, and as soon as it connected to the net it offered to update firmware wirelessly. I accepted.

After some minutes of downloading and installing, the guy restarted itself. Since that reboot, it seems to keep trying to complete the upgrade procedure, but complains about finding no Internet connection. And it simply gets stuck there. No more music.

I took it near the router and plugged in an RJ45 cable. First the MCI900 tried to get a fixed IP (it shows bad settings, all zeroes), then it tried DHCP. It never gets to the Internet. I know DHCP is active since my computers and smartphones have no problem connecting thru wifi and thru cables and all of them get DHCP addresses correctly. "Turn it off and then on" the screen advices. I did it several times, to no avail. Wired or wifi.

Can you help me? I would be grateful if I could just go back some minutes and have my MCI900 with an old but working firmware. As it is now, it is of no use.

Thanks in advance.

lucas1970
02-22-2012, 07:54 AM
Did you reset the device to factory settings

etitor
02-22-2012, 08:17 AM
Did you reset the device to factory settings

Thank you Lucas, sounds good idea! How do I do that?

lucas1970
02-22-2012, 08:22 AM
Go to settings and then scroll down till reset factory settings

etitor
02-22-2012, 09:13 AM
Go to settings and then scroll down till reset factory settings
Thank you! In order to do that, though, I should get first to the menu.

Unfortunately, as soon as the MCI900 starts, it only tries to resume the failed FM upgrade procedure. No access to menu!

etitor
02-22-2012, 09:34 AM
Go to settings and then scroll down till reset factory settings
Thank you! In order to do that, though, I should get first to the menu.

Unfortunately, as soon as the MCI900 starts, it only tries to resume the failed FM upgrade procesure. No access to menu!

lucas1970
02-22-2012, 10:46 AM
That is difficult then. Did you try to unplugg it for some while and plugg it back in?

Whatever button you press on the RC does not help, as the back button, stop, menu?

etitor
02-22-2012, 11:15 AM
That is difficult then. Did you try to unplugg it for some while and plugg it back in?

Whatever button you press on the RC does not help, as the back button, stop, menu?
Yes my friend Lucas, I unplugged it for a whole night.

I plugged it in again. RC buttons have no effect whatsoever.

I have taken pictures of the process that unfolds after start. Pale blue screen, uppercase black letters, in this order, screen after screen:

RECOVERING...

---

STATIC IP

---

STATIC IP setting
IP: 0.0.0.0
NM: 0.0.0.0
DNS1: 0.0.0.0
DNS2: 0.0.0.0
GW: 0.0.0.0

---

INTERNET UNAVAILABLE

---

TRYING DHCP

---

DHCP IP SETTINGS
IP: 0.0.0.0
NM: 0.0.0.0
DNS1: 0.0.0.0
DNS2: 0.0.0.0
GW: 0.0.0.0

---

CHECKING INTERNET

---

INTERNET UNAVAILABLE

---

RETRYING

---

CHECKING INTERNET

---

INTERNET UNAVAILABLE

---

RETRYING

---

CHECKING INTERNET

---

INTERNET UNAVAILABLE

---

RETRYING

(the rest is an endless loop). By the way, Internet IS available both under wired connection and under wifi connection.

lucas1970
03-05-2012, 10:04 AM
Better let your device be checked then....