View Full Version : BDP5200 - Won't switch on using remote control

02-26-2012, 10:20 AM

I just bought a BDP5200. It doesn't appear to switch on when pressing the standby button on the remote. It does start fine when pressing the button on the device and it will switch off using the standby button on the remote.

Any ideas?


02-27-2012, 07:03 AM
in my device, though not 5200, but 5100/3200/2700, this should work...

03-05-2012, 07:21 AM
Did you get it to work, did you try other batteries already?

03-08-2012, 05:21 AM
I noticed that the on/off button on my remote is a bit tough : I not always press enough to make it happened.
Also, if I am not pointing it really to the player, it doesn't work.

I also deactivated easylink feature wich was, by default, activated.

Hope this helps.

03-08-2012, 01:50 PM

That looks like problems with the RC since I have played various times with it and it responds really good....from various distances

04-30-2012, 11:16 PM
This is a firmware bug.
Been there at least since 1.35.
1.16 worked fine.

If you choose enable quick standby the remote will work again.
But this method consumes energy and does NOT shut down power for the USB port.
So unplugging a device even if the device seems shut down might corrupt your USB device.

I have reported this to Philips and waiting for an answer and or solution.

05-03-2012, 01:01 AM
Got an answer today.

They wont send me the working 1.16 firmware.

"the problems you described are sent forward"

Had also several other problems i told them.

So maybe it will be fixed someday, or not.

05-04-2012, 08:53 AM
Got the problem, too, with my BDP5200/12, Firmware 1.52

Philips - QK
05-08-2012, 05:54 AM
Dear Luth & other users,

We understand that you may want to use your player still whilst we are looking into your issue. My colleague helped uploading the v1.16 firmware here: http://wtrns.fr/VQ3MQweE1HJXc5o

Please see if the download works. Thanks.

Kind regards,
Philips moderation team

05-08-2012, 04:52 PM
Thank you very much.
The device is working fine again (it now can be turned on with the remote) with the 1.16 FW.

For the upcoming fix for the new FW can we also have support for variable framerates:

And easy of use function: The arrow buttons (around the OK button) Now dont do anything while video playback.
Would be great to have
right arrow: fastforward
left arror: rewind
up arrow: slomo

All previous Philips dvd players had those but not with this bdp5200, unfortunately.

Thank you.

05-10-2012, 09:18 PM
After going thru firmwares 1.16 to 1.52 i noticed if you after FW upgrade reset the device back to default settings, the remote can be used to turn on the device even if you don't have "enable quick standby" set to yes.

At least worked for me with fw 1.52

05-15-2012, 07:29 AM
When I upgraded my device to newer firmware I had the same issue, couldn't switch on the device with my remote. I "solved" it by unplugging the device from power completely for a few minutes.

Be advised, I read somewhere that unplugging the player for a long time may clear the Wifi settings. It didn't in my case.