View Full Version : DS9800 becomes unavailable for airplay time after time

02-29-2012, 12:45 AM
I have a problem with DS9800 airplay speakers.
The speakers randomly become unavailable for airplay streaming, although it remains on and available in airplay menu of iPad. If I try to send the streaming signal to the speakers the playback just stops.
All other functions continue to operate: device is visible on the wi-fi network, I can play music through aux connection, indicator shows that the unit is on.

Usually this happens after a few hours of being idle, but there's no rule. Sometimes it happens overnight, sometimes it does not.

The wifi network is fine, my B&W zeppelin air doesn't have such problem.

03-03-2012, 07:12 AM
I just want to say that I have the exact same problem. Everything works fine except for the AirPlay streaming from iTunes or iOS.

Using a third party utility built for AirPlay (AirFoil) which provides an actual error message instead of Apple iTunes' odd error-numbers I managed to see that the AirPlay streaming server (which lives inside of the speaker) simply crashed and returned a 500 Internal Server Error.

I have two sets of speakers, and they both have the same problem. The one which is also connected through a mini-jack wire to my TV does it more often than the one which stands single - but they both have the problem if they are allowed to stand idle for about 24-48 hours.

I am waiting for a firmware fix from Philips. Without any access to logs on the unit it is impossible to diagnose this further.

Philips, feel free to contact me for details. I tried contacting you through the customer chat but was dismissed.

Model: DS9800W/10 (two sets, both have same problem)

Both are connected to a Apple Airport Extreme Base station (I have tried to connect to my other wireless router supplied by my ISP and the problem persists)

03-16-2012, 09:19 AM
I wanted to update this thread as yesterday Philips released a new firmware ( for DS9800W.

The firmware does indeed address the problem of this thread. It seems that the firmware operates as some sort of patch. If the internal software that lives inside of the speaker is made aware that the AirPlay server has crashed it is restarted in a few seconds.

Therefore, when trying to establish contact through for instance iTunes it will still produce an error - but if one retries immediately afterwards it works as intended.

All in all a good temporary fix. Hoping though that the next version of the firmware will address the acutal problem so that retrying will not be needed.

03-18-2012, 06:36 PM
Hi there - I've got the same problem. Firmware is, which according to the Philips UK site is the latest version. I found changing the IP address from the standard has improved things somewhat but I can still crash the speakers if I skip through too many songs in a row.
Where do I get firmware from? Its not available on the UK site. Thanks, Dave

03-19-2012, 04:18 AM
Check out here:

I just updated the software, will post the result in a few days.

03-19-2012, 11:01 AM
Ahh...this looks promising. I wonder why it's not the same across all the Philips sites.

03-20-2012, 07:06 PM
I am from GREECE and i have the same problem, even after the upload of the latest version V3.8.88.3700 .I have this problem with ipad2, iPhone4, iphone4s, and my latest i mac. It starts playing music with airplay for some seconds or minutes and then stops.:mad:

Philips - QK
03-21-2012, 07:31 AM
Dear users,

Please be noted that the firmware version V3.8.88.3700 is catered for US consumers only as they have different router settings with that of Europe consumers. Please avoid using this US version firmware. We are now looking into firmware solution for Europe versions. Please bear with us some time for this. Meanwhile, please try upgrade your iphones & iPads to iOS5.1 for further testing. We have been testing the compatability of iOS5.1 and the testing report shows that DS9800 works well on iOS5.1.

Kind regards,
Philips Moderation Team

03-21-2012, 01:23 PM
I'm running iOS 5.1 and I will admit that it's better but it's not fixed. It still looses connection and AirPlay just stops broadcasting. It's interesting that it doesn't appear as a connected device when looking at the advanced settings on the router. I use WI-FI / AirPlay on the following devices without problem:
Apple iMac
Apple TV
Apple iPad (1st and 3rd Generation)
Apple iPhone 4
Panasonic Blu-Ray
HP Photosmart Plus Printer

None of these devices have had problems and all show-up as listed devices on the BT Home Hub3 router. For some reason the Philips DS9800W/10 speakers really struggle.

03-21-2012, 05:10 PM

Philips - QK
03-22-2012, 12:27 AM
Dear users,

We have reported your issue here to our development team. Please bear with us for some time to look into this. We will update you as soon as we have more information from the team.

Kind regards,
Philips Moderation Team

Philips - QK
03-23-2012, 12:18 AM
Dear users,

Software engineer advised that this may be router compatability issue if all your iOS devices have problem with DS9800W. Could you please provide more info on your router so that we can continue with our investigation?

Kind rgeards,
Philips Moderation Team

03-23-2012, 12:13 PM
I'm using a BT Home Hub 3. All other devices work (most not as expensive) work perfectly well.

Philips - QK
04-02-2012, 02:10 AM
Dear users,

Thanks for giving the router info to us. However, we would like to understand more on the setup of your router. Appreciate if you can give us a bit more information.

Also, I would like to inform you that firmware v3.8.88.1000 has been released for DS9800W. Please find and download the firmware at http://www.p4c.philips.com/cgi-bin/dcbint/cpindex.pl?scy=GB&slg=ENG&ctn=DS9800W/10&mid=Link_Software .

With thanks & regards,
Phillips Moderation Team

04-02-2012, 08:50 PM
Now I don't seem to be able to update my firmware. I click on Update Firmware from the landing page but it just times out and the light on the back of speaker goes red.

I've watched the Philips demo video on updating the firmware but despite trying to do the update on both Win7 machine and a Mac, I don't seem to be able to apply the update.

04-02-2012, 09:41 PM

It fails to go any further than this stage. Flashing red light on back of speaker.

Philips - QK
04-03-2012, 03:02 AM
Dear DavePriceRoberts,

We are currently looking into this with our backend support team. Will update you as soon as I heard back from them.

Thanks & regards,
Philips Moderation Team

04-05-2012, 02:00 AM
I'm a US user, my routers are D-Link DIR-655 (now) and basic Netgear (used before D-Link).
All the same problems. Whenever speakers are idle for a while they become unavailable although green light indicator remains on. This definitely not a general router problem because my other devices (Zeppelin and printer) never drop the connection.

I wonder if UK firmware is any better.

And btw, this problem is a real stone in the shoe. The speakers have such great sound and look but fail in quite basic (from a consumer perspective) element of connectivity.

04-10-2012, 04:59 PM
@davepricerobert: i had exactly the same problem. Despite the instructions coming with the firmware you have to go to the tab "Firmware Update" and push the Button "ok". The first 3-4 times the speakers rebooted (assumed) and the page wasn't able to reload. After a day waiting i tried it again and it worked. Speakers rebooted and page reloaded fine. I was able to upload the file and update the firmware. That's not actually a fix but give it some tries.

For the new Firmware the stability of the connection is still not sufficient and the speakers lose their name from time to time (Bridge XXX) or lose the connection to iTunes, very disappointing. Restarting iTunes does help but i guess that's not what Apple meant.
I recommend to assign a fixed IP to the speakers in any case, DHCP proofed to be even worse.

@Philips Support: Please do a deep dive into this. You brought such a high-end product to market and i appreciate the craftsmanship and astonishing sound every day but Airplay connectivity really su... well you know.


04-10-2012, 10:25 PM
Thanks for this Zoyss - how long did you give it before restarting speakers once the red light appeared after clicking the update firmware button? Thanks, Dave

04-11-2012, 05:47 AM
@davepricerobert: you do not need to reset the speakers manually, the process is accomplished by itself. Push "ok" you will hear a white noise from the speakers and after 5-10 seconds the bonjour page will reload and allow you to upload the file.

Just fyi: I did the update from a Macbook.

04-11-2012, 07:23 PM
@zoyss: thanks for your help but I'm afraid even after repeating the process 10 times in row it still won't work.

@Philips Support: what can I do to fix this situation? I'm stuck with this version of the firmware, which is not acceptable. No matter what I do the process fails. I click on ok on the firmware update page, it comes up and tells me the device is preparing to update the firmware. After about 10 seconds the page trys to refresh and then times out. The speakers have a flashing red light and no longer is discoverable.

I do work in IT so I feel fairly competent in my approach to this problem. I've tried applying firmware using both windows 7 pc and also using bonjour via an iMac. I've tried doing it connected via the home router and also doing it using the Philips air play network. Nothing works! What else can I try?

04-14-2012, 04:42 PM
******PROBLEM FIXED*******

You need to ensure that before you do the firmware upgrade that the light on the back of the speaker is a solid green. If it's flashing green, then hold the off button on the back of the speaker for 5 seconds before running through the set-up process again. Once the light is a solid green, go to the webpage and run the firmware update again.

I have tried so many different things before discovering this! Sounds simple and it is but if you're not looking for it then I guess it's not that obvious. I hope it helps others who might be suffering similar issues.


04-14-2012, 05:49 PM
Okay - so I managed to get the firmware update to apply but like everyone else the update has not fixed the root cause problem of AirPlay dropping out.

Come on Philips there must be a way to get this fixed!

05-16-2012, 12:37 PM
Some additional information for people experiencing problems with the firmware upgrade:
I tried in vain for may hours to update the firmware of my DS9800 speakers and even entering the IP address mentioned in the “Firmware Upgrade DS9800W” page did not help. The speakers kept on blinking in red and entering the IP address led to a time out because the IP address could not be found.
Finally I found the solution for the update by comparing the IP adress of the Fidelio speaker with the one shown on my WIFI router listing. The IP adress which was shown on the Fidelio update page did not correspond to the one of the router listing. After entering the IP Address shown in the router listing I could finish the firmware update process without any problems. The new firmware now allows a quicker connect to the WIFI router when powering up the speakers. Before it used to take up to 2 minutes and now the connection is established almost immediately after the quickly blinking LED switches to the slower blinking.
I hope this will help other users who had problems updating the firmware. I also should mention here that the German Philips support I contacted over the phone did not have a clue as to the solution of this problem.

05-21-2012, 09:05 PM
Like others my airplay is unreliable yet a have a full strength airport express two feet from the speaker! sometimes it runs for an hour then stops, then might even come back on. When it goes off sometimes the fidelio option on my iPhone - or iPod is missing, sometimes it is there in all its glory but no sound, then sometimes it just comes back on as if by magic. Similar problems from my iMac. I have latest 5.1 sw. This is a very expensive piece of kit. It should not be this difficult to get it to work.

I saw the mention of the new firmware. My speakers are only a month old and accessing the fidelio internal firmware page shows the firmware as (the latest?) BUT with a firmware date of 2011-10-17. Not a March 2012 date as implied in earlier posts from Philips.

Should I still update the firmware? are folks that had the problems earlier still having them?


05-30-2012, 12:40 PM
Dear Philips Support, i'm from Switzerland and have exactly the same Problem! - It's not possible to listen Music for hours, the Speakers stop playing and often i had to shutdown and reboot them. Since i was trying to install the newest firmware, i can't connect any more to my Speakers. The LED is fast blinking green then it blinks red and then it power off?! :( :(

It's so sad and frustrating, when one buy a high-end product and then have so much trouble !!
Have you got any suggestion to fix my problems?

05-30-2012, 06:47 PM
I saw the mention of the new firmware. My speakers are only a month old and accessing the fidelio internal firmware page shows the firmware as (the latest?)

Should I still update the firmware? are folks that had the problems earlier still having them?

yes is the latest firmware

The problems were even worse with the earlier firmware

05-31-2012, 07:06 PM
Good point. I'm just happy that something has been done on this issue. As long as there's a progress, I'm pretty happy with it. https://imagicon.info/cat/12-19/vbbiggrin.png

08-04-2012, 04:26 AM
I've had no Airplay dropout issues with continuous play for several hours. They're only a week old so maybe the latest firmware has resolved some of the issues. I must say I was a trifle concerned after reading all the above hassles but I can't fault them and the sound quality is superlative

Philips - Remko
08-09-2012, 11:02 AM
Dear users,

We understand the frustration this issue is generating. To improve the quality of our product, we will appreciated a lot if you can provide us with more information for our investigation:

1. Under what conditions did you detect the problem of blinking red? Was it during playback of music via airplay, or via the MP3 link?

2. How long did you use the unit before the problem happened? Any special user pattern?

3. Did you find the failure when you were working on a FW upgrade?

4. Any other thing that you may tell?

5. Would you be able to give the serial number also?

Thanks a lot for your help in advance.

Kind regards,
Philips Moderation Team

08-09-2012, 11:21 AM
Excellent that this is being dealt with. I have so far had three seperate pairs of DS9800W - all of which has died. One (the first one) turned itself off and refused to turn back on. No lights, no nothing - just as dead as if no power was connected. The two other ones died with the red flash as the others' in this thread.

With regard to the questions I will focus only on the latter two, as I suspect the former one was a switch-issue rather than this one with the red flash:

Both units were connected to my Samsung TV set through the headphone jack. At the same time I regularly used an iPhone 3GS, an iPad 1 and iTunes on my Mac to send music to the device through AirPlay. The units were both updated with the latest firmware There was no issues with connectivity or reception prior to the incident. I was not there, and the speakers must have been completely idle when it happened.

One of the speakers broke down like this: I returned from work where the speakers had been on standby. When entering the room I heard a weird "whuuuush"-ing noise from the speakers. It sounded just the same as the sound that comes right in the middle of a firmware update - but they had already been firmware updated a long time ago and I or any other had not initiated a firmware update (I live alone and the wireless network is secured). After trying to reach the speakers setup-page to see what was going on (but it was unreachable) and waiting for about an hour I pulled the power from the speakers, waited and put it back. By then they showed began to quickly flash green and then flash red slowly - with no option of reset.

The other speaker broke down while I was not there. It had begun flashing red by itself (I was not in the room when it happened, so I do not know if the "whuuush"-ing sound had been there prior to my arrival. Pulling power and reinserting produced the same quick green flash followed by the slow red flash.

My theory is this: The units somehow put themselves into a firmware upgrade mode OR some kind of safe-mode from which they cannot themselves recover. I have no idea what causes this, as I was not in the room when the incident began. I can only say that no "humans" interacted with the devices when they broke. It might have been a NAS-server on the network calling out some broadcast message - but I doubt it. The best fix for now must be to isolate the situations in which the speakers turn into this "safe" mode - and then make additional checks to make sure it does not happen when its not supposed to! But then again, if any components are broken inside the unit - the issue might be a different one than can be fixed by firmware.

2) About 4-8 months for all of them. See above for usage pattern.

3) No. Incidents happened many weeks after updating to latest FW. But please note that in one occation the speakers sounded like they were in some kind of update or safe mode.

4) The speakers were working brilliantly up until the point I left them idle and went back to find them broken.

5) I will be happy to give serial numbers for all the above mentioned units. But not in this thread as I already had trouble with the Danish philips department giving me mixed messages about the SN of one of the units. Please send a PM to me - whomever needs the numbers.

Best RBY

Dear users,

We understand the frustration this issue is generating. To improve the quality of our product, we will appreciated a lot if you can provide us with more information for our investigation:

1. Under what conditions did you detect the problem of blinking red? Was it during playback of music via airplay, or via the MP3 link?

2. How long did you use the unit before the problem happened? Any special user pattern?

3. Did you find the failure when you were working on a FW upgrade?

4. Any other thing that you may tell?

5. Would you be able to give the serial number also?

Thanks a lot for your help in advance.

Kind regards,
Philips Moderation Team

Philips - QK
08-10-2012, 10:33 AM
Dear rby,

Thanks a lot for getting us all these comprehensive information.
I have just forward these information to our product team for further study. We can assure you that we are working on this issue and we shall let you know if there are some updates on this.

With thanks & regards,
Philips Moderation Team

08-18-2012, 01:40 AM
OMG!!!!!!!! This is so frustrating... I've never been so angry in my life.... I actually fell asleep while trying to get more than 5 seconds of a song out of these speakers via Airplay!!!! Who did the Q&A on these????Hundreds and Hundreds of dollars and complete audio silence!!!!!!!!!!!!!!You have got to be kidding me!!!! I tried to update to the latest software and surprise surprise my DS800W's already came with the latest version...
EPIC FAIL!!!! EPIC FAIL!!!!!! The only thing that works is the charger and the remote control!!!!!! I've got some fancy artsy pods sitting on top of my floorstanders now... PLEASE FIX THIS NOW!!!!!!!!!! NOW!!!! AHORRA MISMO!!!!!

08-21-2012, 02:01 AM
This is a follow up to my first post above

Philips you are so lucky I have an Ipad2 - I updated the software on both my iphone4 and ipad2 to IOS 5.1.1 and the iphone is still a no go even with the DockStudio app!!!!(In fact when trying to connect it says Device not supported!!) The ipad however plays - I got about 2 straight hours without interruption the other night!!! Whew!!!!!!! I was seriously thinking about gutting my DS9800W's and stuffing some flowers in them ;) These things were DOA as far as my iphone4 was concerned. I started out with both devices on IOS 5.0.1 - I surely hope when the iphone5 is released with IOS 6 this issue will be resolved - I keep most of my music on my phone and now I have to clear space on my ipad for the same music.... YUKK!!!!

P.S. I brought these as an alternative to powering up my 5.1 Airplay AV receiver and I cannot complain the SOUND is AWESOME!!!!!!

10-14-2012, 11:27 PM

Okay Guys...

After reading this thread and spent a couple of hours trying to get the update applied i finally figured it out.
It could be that some of you are making the same stupid mistake as i did.

I was just simply trying to update the firmware using the setup button on the back of the speaker. I Connected to the Philips_fidelio created network, and tried to update the firmware through
This led to the led flashing red after pressing the update button in the firmware update section .(corresponds fairly to some of the problems some of you have described)

The proper way to do it is of course to access the speakers from the browser being on the same network as the speakers. My speakers was using found the IP by accessing my router and checking my connections ) , typed the speakers IP in to safari, and accessed the speakers and updated the firmware.

No going on the new - Fingers crossed for some improvements ! ( really disappointed in the lack of user friendlyness, and stability from such a high end product!)


- Setup the speakers to your home network

- Log on to your homenetwork

- Check the speakers IP adress by accessing you router and checking its connections

- Type in the speakers IP adress in safari , and you should acces the speakers interface

- Update the speakers !

Hope it helps some of you :)

10-16-2012, 12:07 PM
Thats a nice one Helper!!! Great one :)

12-05-2012, 08:53 PM
One more guy asking for a solution !

Up to the moment I can't say I had too much delight on my DS 9800W speakers :

First to the positive aspects:

- If they work, the sound is (relative to their size) fantastic

- The classical look of "loudspeakers" in our living room has gone

And now about the flaws :

- in the 7 months of owning them there were not too many ours of listening to them properly

- different indications for malfunctioning displayed, sometimes only after a week of (randomly) operating them, sometimes after less than 1 hour of standby (as this evening)

- sometimes restarting the loudspeakers does work, sometimes not
(errors may vary between "unknown error -15000" / "loudspeakers not found" & others )

- the "beep" for confirming the connection between Mac and Loudspeakers yesterday came 5 seconds after booting them or several times later, when the connection was already built up...

The DS9800W loudspeakers already got sent in for inspection but it was claimed that nothing had been found.
Funny enough, the loudspeakers sent back still have the original serial number on the chassis, but new ID on the Bonjour setup menu (!?!)

I have 2 different Mac generations with 2 different OS generations (10.6.8 & 10.5.8), both showing the same effects, so we can exclude those as cause.

I checked on help on the internet, but either the advices shown so far didn't work in my case or proved as utter nonsense (...even if someone claimed it solved its problems...).

Does anyone know any final solution before I will return my DW9800W to my dealer and look for an other brand ?

Thank you for your help

12-27-2012, 06:18 PM
And now about the flaws :

- in the 7 months of owning them there were not too many ours of listening to them properly

Same here, is there any solution yet? I even "upgraded" to a Airport Extreme and put a Airport Express next to the speakers for maximum coverage ... but still audio drop outs. (Previous routers; WD N900 central and Linksys E2000)

12-28-2012, 07:50 PM
Same here, is there any solution yet? I even "upgraded" to a Airport Extreme and put a Airport Express next to the speakers for maximum coverage ... but still audio drop outs. (Previous routers; WD N900 central and Linksys E2000)

Did anyone try to download the studio app and disable the "Livesound" and "DBB"? I just disabled them both and they have been playing for a whole 2 hours. Can someone try?

07-19-2013, 09:31 AM
Any improvements in the Airplay issue? I recently got my speakers back from repair (the red blinking light issue) and now I get the airplay dropping out from both my iPhone and Macbook. I can sometime listen to music for 15-30 minutes or more before a dropout occurs. Sometimes rebooting the speakers seems to help for a while, . . . but if I haven't listened for a while an airplay drop out is generally inevitable. I've been wanting to play music for firends to hear the good sound, but I can't risk having the speakers dropout in front of other people.

Please tell me there is a solution to the reliability of using airplay with these speakers. I'm hoping I don't have to send them back before my warranty expires and look for a new set.

07-19-2013, 09:47 AM
hi djangoman, have you tried to play your music through DockStudio or Fidelio App? That may avoid the sound dropping out hopefully....

Philips - Katerina
08-24-2015, 08:13 AM
Hello participants of the thread and forum members in general!

Hopefully your issue was dealt with and you are no longer facing it. Since the thread has been silent for some time now, I will proceed by closing it. If you still have the same question about the same issue or any similar issues arise feel free to start a new thread or contact one of us moderators to open this thread again.

Kind regards
Philips Katerina