View Full Version : Remote control doesn't work anymore on Net TV

04-20-2012, 12:58 PM
Hello I have a 32PFL7605H/12 tv set that accesses Net TV via a WIFI USB.
This used to work for a while. But recently I noticed that the arrow keys on
the remote control do not have any effect when on the Net TV application.
The remote control does work OK in all other contexts ( TV , USB, Remote PC
etc... ).
In order to try to solve this problem , I have installed the latest firmware
Q5551_0.140.47.0. But that did not help. Still the same problem .
Net TV welcome panel was shown, but I can't select any off the apps.
Then I tried to clear the Net TV memory, and now it is even worse .
When Net TV starts, it shows me the 'terms and condition' page,
and I am unable to go beyond this screen by selecting OK on the RC
or any of the arrow keys.
So now I am completely lost.

Any help on getting this solved ?

04-20-2012, 01:07 PM

see: http://www.supportforum.philips.com/en/showthread.php?4737-problem-with-regard-registration-at-Net-TV-service&p=27042#post27042


04-20-2012, 04:11 PM
downgrading to 140.34 as in above post did the trick. Remote control did function again after tat was done. And it kept on working fafter I upgraded to latest version 140.47 afterwards.
Many thanks to Mr Toengel for pointing me to this post.