PDA

View Full Version : Files >4 GB via USB Flash Drive



stoyan89
04-25-2012, 10:11 PM
Hi,

Is it possible to play files (videos) that are larger than 4 GB from a USB flash drive on BDP5200. Currently the only way (that i'm aware of) to put a large file on a USB drive is to format it in the exFAT file system which is proprietary to Microsoft and thus not supported by Philips devices (my TV - 32PFL5405H, doesn't support it either). Is there an alternative file system (which allows >4 GB files) that is supported by my BD player and how to format my USB in it under Windows 7.

Thanks,
Stoyan

Toengel
04-26-2012, 06:30 AM
Hi,

try NTFS file system. It should be working, but might not be supported officially.

Toengle@Alex

wolverine83
05-12-2012, 05:31 PM
My 5200/12 doesn't see my NTFS usb drive, It only seems to recognize FAT32. Is this some bug in the firmware and/or something that is going to be fixed? I bought a usb drive specifically to put larger files on than I could fit on a single layer dvd. But its absolutely useless as FAT32 because of the 4gb limit

wolverine83
05-12-2012, 05:48 PM
I'm using the new 1.55 firmware by the way

Philips - QK
05-15-2012, 05:56 AM
Dear wolverine83,

Could you advise 1) what brand and model of NTFS HDD you are using and 2) if your HDD connected to it’s own power supply?

Thanks & regards,
Philips Moderation Team

wolverine83
05-15-2012, 06:00 PM
I've tried with a 16 GB Silicon Power USB 3 Stick (no external power since it's a stick)

and the other is an Icy Box Sata Enclosure with a 200gb SATA disk inside, USB 2 (with external power)

I've only tried the Icy Box once, since it would be a hassle to use it since it has a huge power cord and is overall very uncomfortable to move around. I was hoping to use a stick because it's much simpler. The 16 GB USB 3 stick works when formatted to FAT32 but not NTFS, it works in any exFAT and NTFS between my pcs.

Perpetual Beta
05-15-2012, 07:24 PM
The USB 3.0 specifications are defining 5V 0.9 ampere max. for bus powered devices.

The USB 2.0 specs are demanding 0.5 ampere max. bus power. So many USB 3.0 mass storage devices are incompatible with (poorly designed) USB 2.0 ports without external USB Hub + power supply. Tested here on a Philips TV with Sharkoon Flexi-Drive Accelerate Duo 64GB (USB 3.0 Stick). No reliable function without USB Hub + power supply.

exFAT is a proprietary filesystem from Microsoft. Most embedded systems in TVs, multimedia players etc.. are running a Linux OS which doesn't support exFAT so far. NTFS is a proprietary filesystem, too. But it is supported in most linux distributions since years.

wolverine83
05-16-2012, 10:58 PM
Ok I get that, but why does my USB 3 Stick work like a charm when formatted with FAT32 but not in NTFS? that shouldn't have anything to do with the ampere need right?

Perpetual Beta
05-17-2012, 11:06 PM
A not recognized NTFS filesystem is very probably a firmware problem.

"USB 3.0 specifications require 0.9 A bus power" was an answer to "no external power since it's a (USB 3.0) stick".

Philips - QK
05-21-2012, 03:33 AM
Dear all,

If you haven't performed a downgrade yet, we have found out a workaround for the NTFS formatted HDD playability issue:

Equipment Needed: USB Flash Drive formatted as NTFS (example: Sandisk 16GB Flash Drive)
Pre-condition: USB Flash Drive formatted as NTFS using Windows, copy some media files into the flash drive.

Steps:

1. Power on BDP.
2. Plug in USB Flash Drive (Thumb Drive), BDP will detect flash drive.
3. Go into the USB browser and playback any file.
4. Stop playback, remove the USB flash drive.
5. Plug in the USB HDD with NTFS formatting.
6. BDP will be able to detect USB HDD, playback files.

So far it works for us with these steps. Kindly try this out and use this as a workaround while we solve the issue.

With thanks & regards,
Philips Moderation Team

backhandguga
05-21-2012, 03:30 PM
Tried it here on my end it it worked. Would be nice to know if this is being considered for a fix in the next firmware release. https://imagicon.info/cat/12-19/vbbiggrin.png

Philips - QK
05-22-2012, 03:11 AM
Hi Backhandguga,

We are currently working on resolving this. Will update you when we have more concrete infomation.

Kind regards,
Philips Moderation Team

Philips - QK
05-23-2012, 09:26 AM
Dear users,

I need your help and input for the NTFS issue.

We tried the issue again today and we could not reproduce it anymore. I’ve tried different scenarios (see below). It seems that this problem is not 100% reproducible. Do you know if there are specific steps or the BDP has to be in a certain configuration to reproduce the issue?

Steps we have tried:

1. BD playback first then plug in USB – OK, can playback from NTFS HDD.
2. NetTV playback first then plug in USB – OK.
3. Factory restore then plug in USB – OK.

Your input will indeed help us sorting this out sooner. Thanks a lot in advance.

Kind regards,
Philips Moderation Team