View Full Version : BDP3406/F7 - cannot update firmware

04-26-2012, 03:44 AM
Just got the player and great, new firmware only released the other day. Filename is "bdp3406_f7_fus_eng.zip" and it's located here. (http://www.p4c.philips.com/cgi-bin/dcbint/cpindex.pl?scy=US&slg=AEN&sct=BLURAY_DISC_PLAYERS_SU&cat=BLURAY_AND_DVD_CA&grp=SOUND_AND_VISION_GR&session=20120426041651_71.64.105.82&ctn=BDP3406/F7&mid=Link_Software&hlt=Link_Software)

Network updating causes the download progress bar to simply hang. Had to cancel and the machine restarts.

USB is even worse. First the confusing site instructions tell you to simply extract the folder to the root of a USB drive. Of course if you do that, it finds nothing because many unzip programs name the folder as the original filename. The player doesn't recognize that.

So research indicated I should simply extract the "UPG" folder to the root of the USB. Did that, and it hangs at "Now searching for upgrade software," requiring a forcible power cord pull.

Then the included manual says it needs to be named "UPG_ALL". Tried that, and same thing.

Getting frustrated here. Two curious things I notice is that there are TWO files in the folder (might that be confusing it?) and for some reason after I remove the USB and look at it again there's a new, blank folder created called "BUDA."

You can't seriously tell me that this thing needs several hours to do this update. It's just not working. What needs to happen to make this update work?

Philips - Remko
04-26-2012, 02:05 PM
Hi Nagual,

First of all welcome to the forum! As this product is not activly being monitored in this forum please use below link.


Kind regards,

Philips Moderation Team

06-10-2012, 11:49 PM
We're having the exact same issue with ours. This is very frustrating; we may just toss this thing and buy a Sony since no help is forthcoming.

06-12-2012, 01:42 AM
We're having the exact same issue with ours. This is very frustrating; we may just toss this thing and buy a Sony since no help is forthcoming.

If you want to bother with it, try calling Philips support and ask for an exchange. To their credit, even though I had to be a bit insistent on the phone (as they tried to stall me with a "we're working on this issue" canned response), they did this and it was delivered today about 10 business days later. (Prepaid label by UPS for the return too.)

I set it up and was surprised to see that despite an earlier 2011 manufacture date it was also the newer "M2" variant. Almost the first thing I did of course was choose Network to update the software, expecting disappointment but...it actually worked, no hang after the download, just about a minute's pause. (My jaw almost dropped.) It took me from v2.16 (the version my faulty player also had, and was stuck on) to v2.27 with the update.

I'm putting it through its paces but so far Netflix does appear more responsive. Unfortunately I expect the aspect ratio problem with MKV files (which was supposedly fixed in a newer release that only the 3406 original has currently) to still be present (ETA: yes it is). And I wonder if any of the quirks handling more complex blu-rays with Live features, etc. are any better (ETA: perhaps, but can't be sure without a lot more testing. GAME OF THRONES does appear a bit faster-loading). But at least I'm much confident now that any future updates will install. Good luck with your situation benkenon!

Also, for anyone reading, here are a few tips for this player which make quite a bit of difference in my experience:

1) I highly recommend you do not put this player on an extension cord plug or perhaps not even on a power strip. Doing the former caused weird lockups especially when using Netflix, the latter was mostly OK but I'm just being cautious. I guess the power supply is very finicky.

2) To avoid the "resolution downgrade" issue where playing anything which ends up 720p, like a normal DVD, causes the menus and everything else you play after to go to 720 and look much worse, choose "Auto" in the HDMI settings and not "Native" (I don't know if "Native" has any advantages over the other). I believe this solved the issue for me, as I tested it going back and forth through different sources. Maybe this will be solved in a future update as well.

3) Something verrrrrry interesting about the replacement remote. It takes two AAA batteries, where the original player only took one. Will this mean better performance with one item which has generated so many complaints about this player? I'm hopeful. (ETA: yes, this makes a noticeable difference. Hope many more people have this type of remote than just me!)

Philips - QK
06-13-2012, 05:01 AM
Dear users,

Since this player is not one of the supported model in this forum, we do not have much information for this model. Please kindly refer to your country support for more information: http://www.support.philips.com/support/contact/contact_page.jsp?userLanguage=en&userCountry=us.

Kind regards,
Philips Moderation team