View Full Version : .ts Issues via USB

05-07-2012, 10:20 AM

According to the product documentation, my 46PFL8606 should be able to play Transport Stream files, however it is having issues to achieve this although the all codecs used are supported according the Philips documentation...

I did test two different .ts files both being DVB recording that I copy into an USB stick and try to play using the TV :

- 1st file : 1920x1080 H.264 Level 4 video with AC3 Audio
- 2nd file : 768x576 Mpeg2 video and Audio

When I choose the first file the TV tries to start playing and keeps displaying a black screen until I press the "back" button on my remote. When I try the second file, the TV goes full black screen for a second then returns back to the USB browsing menu.

Edit: My TV is running the latest Philips firmware and the files are played correctly using VLC or MPC on my computer.


05-07-2012, 06:40 PM
Hi Attached the Mediainfo informations about the two .ts files...

Philips - Thomas
05-08-2012, 10:56 AM

can you please share a part of the 2nd Video?
1st one is out of specs as we do not support H264 on TS Files, only MPEG2.


05-08-2012, 11:05 AM
Thanks Thomas,

I'll share it this afternoon after getting home.

Why is the first file out of specs? It is clearly mentioned in the User Guide that TS MPEG container is supported and that H.264 is also supported. In limitations, it is mentioned nowhere that TS container combined with H.264 codec are not supported. I based my purchase on the User Guide.

Philips - Thomas
05-08-2012, 11:11 AM

Reading through the manual you should read all of it...

MPEG-4 AVC (H264)

So TS in combination with H264 > no.


05-08-2012, 11:32 AM
Hi Thomas,

Excuse me but can you elaborate what do you mean? I don't see how your quote means no TS combination with H264.

Quote from the english manual

Playback formats
• Containers : MPEG Program Stream, MPEG Transport Stream,
AVI, MPEG-4, Matroska, Windows Media, ASF
• Video Codecs : MPEG-1, MPEG-2, MPEG-4 Part 2, MPEG-4
AVC (H264), WMV9
• Audio Codecs : MP3, AAC, HE-AAC V1, HE-AAC V2, WMA,
• Image Codecs : JPEG
• Limitations : WMA (V2 up to V9.2), MPEG-4 AVC (up to level

You can see that containers are listed separately to codecs and that TS is part of the containers and MPEG-4 AVC (H264) is part of the codecs. There's no mapping between the containers and the codecs specifying what codecs are supported with what containers.

I think you mean by your quote that H264 is supported only with MPEG-4 container, but I'm sorry to highlight that it's not what is written in the documentation as MPEG-4 AVC (H264) is the codec and is listed under codecs. So what it means, is that this codec is supported if in use with any of the containers listed above. For instance MPEG-4 AVC (H264) with TS, or PS, or matroska...

I'm not saying you are wrong and H264/TS is supported, I'm only saying that the manual says so in its current form!

Philips - Thomas
05-08-2012, 11:37 AM

Containers : , MPEG Transport Stream,
, MPEG-4,
Video Codecs : MPEG-2, MPEG-4 Part 2, MPEG-4
AVC (H264)

Yes we seperate the Codecs and the containers, yes we Support MPEG-4 Containers but only with "MPEG-4" Part 2 and AVC Codecs as you can clearly see in the List.


05-08-2012, 11:46 AM
I'm sorry Thomas, this is misleading... When I read Video Codecs, what I understand (and what every user will), is Video Codec, Not Video Codec combination with Container! If I should understand what you said, then it means that matroska for instance is not supported with any of those codecs?

Again "MPEG-4 AVC (H264)" is the name of the codec, it can be used in several containers AVI, MKV or TS. The way it is written does not suggest by any way the limitation you are talking about.

05-08-2012, 10:48 PM
Dear Thomas,

Attached is the file sample you asked for.

Back to TS/H264 subject, you can see from this table (http://www.supportforum.philips.com/en/attachment.php?attachmentid=926&d=1331632341http://) provided by Philips a clear mapping between containers and codecs. For instance it is easy to understand which containers do support H.264 on 2011 Blueray players. It is also clearly stating MP4 container with MPEG-4 AVC (H.264) codec... Not like you said that we should understand from this statement
AVC (H264) that H264 is only supported with MP4 container!

Unfortunately the table doesn't include 2011 TVs, and the TV manual is suggesting that all supported codecs are available on all supported containers without highlighting any limitations.

mike tv
05-09-2012, 01:51 PM
When I choose the first file the TV tries to start playing and keeps displaying a black screen until I press the "back" button on my remote.

Hi soussef24,
I have a somewhat similar issue when playing some .ts [standard def., mpeg2, DVB] files via DLNA to the TV.
A workaround I stumbled upon was when the screen goes black after pressing play simply leave the TV alone and just wait. After waiting any thing up to 4 mins or so the file starts playing! Usually it only takes 2 mins.

I know this is far from ideal but for my DLNA setup its better than nothing.

The non playback of .ts files for me only happens for a small few files I have. And usually for those problem files I have to wait around 2 mins for them to play.

05-09-2012, 02:01 PM
Hi Mike,

Thanks, actually I saw your trick somewhere in the forum and tried it after posting this, but it doesn't work for me!

What happens with the SD file is that after black screen for 1s or so the TV returns automatically to USB browsing menu. For the HD file, it takes significantly more (few minutes), and the TV also automatically returns to the same menu!

mike tv
05-09-2012, 05:16 PM
Pity about that.

Some other [long shot] ideas:
*Are there incompatible characters in the file name? try renaming it
*Try formatting the USB drive. Not sure if this is possible but perhaps try exFAT [or EXT 3?]instead of FAT32
*Try a different USB drive altogether. I've a satellite box that is very picky about the USB drives it will use.
*Are the files locked?

Philips - Thomas
05-10-2012, 06:42 AM

i have checked the File, the container is corrupt. I reinitialised the container and now everything works fine. you can check for yourself, opening the File with AVI Demux, you will see an error Message showing that there is no index.

I have attached the reinitialzed file.


mike tv
05-10-2012, 01:06 PM
I reinitialised the container and now everything works fine.

For future references could you explain how you reinitialised the ts file.

Philips - Thomas
05-10-2012, 01:09 PM

open the File with AVI Demux, you will get a message that the Index is missing, click yes, save the file.

Thats all.


mike tv
05-10-2012, 01:17 PM
Oh, right. Thanks

Any time I do that AVI Demux saves the index as a separate file [.idx]. It must do something else to the ts file as well?

Do you choose "copy" in both the video and audio menus?

Philips - Thomas
05-10-2012, 01:24 PM

idx is created for AVI Demux only.
Please do not change any setting, leave all at default, just go to file > save > video

and save it as... "test.ts" or something similar. Note: I had problems to overwrite the original File so you may need to be aware of that.


mike tv
05-10-2012, 01:48 PM
Thanks for clarifying that

Two points:
[1] I don't think the fact that AVI Demux asks to create an index file means the .ts is corrupt. AVI Demux asks to create an index for any MPEG2 file [that it hasn't already opened and thus had a.idx file available]. The index file is purely for AVI Demux and doesn't alter the file's content itself.

[2] Your procedure creates an AVI file. By naming it test.ts haven't you miss-named the file? Wouldn't it have been better to call the file test.avi ?

Philips - Thomas
05-10-2012, 01:53 PM

AVI Demux is not able to recognize the File, thats why an index is created. Why does AVI Demux which can handle MPEG Codec very well, show up a Message saying so?

I told you to not change any settings in AVI Demux, if you do so you will not create anything new.
Of course if you change settings, which you can, you can also create new Files...


mike tv
05-10-2012, 02:12 PM
AVI Demux is not able to recognize the File, thats why an index is created.
I'm no expert on AVI Demux but for almost every MPEG2 file I've ever loaded in to it [both Transport Stream and Program Stream] it has always asked to index it. I wouldn't take the request by AVI Demux to index the file as proof that the file is some how corrupt.

I told you to not change any settings in AVI Demux, if you do so you will not create anything new.

I understood what you said, I'm just clarifying that the procedure you outlined does not create a .ts file. It creates an .avi file.
I don't understand why you would incorrectly name the file .ts when it should be .avi, that's all.

mike tv
05-10-2012, 02:16 PM
I was just looking at your test.ts file, and there is no audio track in it.

Philips - Thomas
05-10-2012, 02:52 PM

true, because in your File attached to this Thread there is no Audiotrack...


mike tv
05-10-2012, 03:09 PM
This isn't my thread [nor my file]

Actually the original .ts file [from post #9], according to MediaInfo has 3 Audio tracks in it in French, English and German - but your conversion has none.

05-22-2012, 03:27 PM
Hi Thomas,

Basically what you did is removing the audio track and changing the container to AVI. Even if you used the .ts extention, it is an AVI file as stated by the Mediainfo tool. And the original file was TS format and had audio track.

Complete name : D:\userdata\mrabet\Desktop\test.ts
Format : AVI
Format/Info : Audio Video Interleave
File size : 558 KiB
Duration : 1s 640ms
Overall bit rate : 2 785 Kbps

ID : 0
Format : MPEG Video
Format version : Version 2
Format profile : Main@Main
Format settings, BVOP : Yes
Format settings, Matrix : Custom
Format settings, GOP : M=3, N=24
Codec ID : MPEG
Codec ID/Info : Chromatic MPEG 1 Video I Frame
Duration : 1s 640ms
Bit rate : 2 758 Kbps
Maximum bit rate : 15.0 Mbps
Width : 720 pixels
Height : 576 pixels
Display aspect ratio : 16:9
Active Format Description : Letterbox 16:9 image
Frame rate : 25.000 fps
Standard : PAL
Color space : YUV
Chroma subsampling : 4:2:0
Bit depth : 8 bits
Scan type : Interlaced
Scan order : Top Field First
Compression mode : Lossy
Bits/(Pixel*Frame) : 0.266
Stream size : 552 KiB (99%)

05-24-2012, 09:21 PM
Hi Thomas, any feedback on this? The file you attached is an AVI file as stated by Mediainfo!

Philips - Thomas
05-31-2012, 10:57 AM
hi soussef24,

i have send you a PN.


06-05-2012, 06:01 AM
Unless you are an advanced user, you can choose to change the settings from default. I only tried it ones though and when I encountered a problem, I wasn't able to fix it so I switch back to default mode. Just a simple lesson for me to share. http://imagicon.info/cat/12-19/icon_e_smile.gif