View Full Version : Usb key empty

05-20-2012, 04:03 PM
Hi everybody,

When I try to use a usb key on my Philips 37pfl7605h, I get a message "EMPTY".
However, I already succeeded in viewing jpg photos and avi films with the same key on this TV.
Furthermore, when I connect this key on a PC or on a Mac, I can see the files ...

Any idea ?

05-20-2012, 04:32 PM

can you please check how the stick is formated?


05-20-2012, 09:54 PM
Thank you for quick reply.
Current format is "Mac OS extended" ; but I also tried with MS-Dos FAT.
In both cases I can see the files with PC or Mac, but not on the TV ...

05-21-2012, 05:50 PM
hey marcdt; to bad, all the TV's i know to only support FAT/32, mac os extended (journaled) will not be accessable.
can you please reformat this key ona windows pc (or windows os on your mac) and then copy the files again to the stick?
tv should now be able to handle this stick, formating it to fat32 will also make you able to use this stick on osx

05-22-2012, 05:01 PM
hi Tom,
Same bad result with Fat32 ...
But I tried with another usk key, also formatted fat32, and it works ...
So, let's stop loosing time on that !
Thanks for your help.

05-22-2012, 05:42 PM
hehe okay great, can you just share the modell and typ of they that does not work, maybe some others can learn from that...

05-22-2012, 09:17 PM
the one which does not work (anymore) is a Corsair Padlock

05-23-2012, 05:11 PM
hey marcdt; seeing that this key comes with hardware encyption, i guess it is something with this encryption, stopping you from using this key, but thats only a guess