View Full Version : BDP3310/12 no internet connectivity

05-29-2012, 09:28 PM
Today I bought a Philips BDP3310/12.
It had system software version 2.45 installed.
I want to connect it to the internet using an ethernet cable.
For one way or the other I cannot seem to succeed.
When I set it up automatically it says it cannot optain an ip-address.
When I set it up manually it says it's connected to the internet but it doesn't receive any data from the internet.
Settings when trying it manually for the first time:
Subnet mask:
Gateway: (which is the ip-address of my modem)
DNS server 1: (cause DNS server is applied by my modem)
DNS server 2: (cause DNS server is applied by my modem)

Settings applied when trying it manually for the second time:
Subnet mask: 255.255.255
Gateway: (which is the gateway my modem uses)
DNS server 1: (which is Planet Internet NL)
DNS server 2: (which is Planet Internet NL)

All other devices in my network get their ip-addres from my modem using DHCP.
The DHCP ip-addresses range from to (leaving - for static ip-addresses). The modem used is a KPN Experia box (Siemens Gigaset SX552).

Could you help me find a solution for my problem?

05-30-2012, 06:25 AM

please try the following. Try to connect a notebook to the cable (where you try to connect your BDP to) and use DHCP. If that doesn't work, something is wrong with your cable connection. If this works, your BDP has a problem...


05-30-2012, 09:55 PM
My colleague provided me with a working solution.
Since my modem is in charge of the routing to my ISP (and thus also taking care of the DNS lookups) he suggested to use the modem's IP-address for both DNS Server 1 and DNS server 2. And indeed it works! :D

So my manual configuration that is working is:
Subnet mask:
DNS server 1:
DNS server 2:

@moderator: You can close this topic.