PDA

View Full Version : Why the BDP5200/98 can't be upgraded to v1.55?



doumeki
06-02-2012, 07:08 AM
I felt very disappointed.:(

Toengel
06-02-2012, 07:41 AM
Hi,

as you can read here (http://www.supportforum.philips.com/en/showthread.php?5828-BDP5200-Latest-Firmware-upgrade-(V1-55)-has-been-released), Firmware 1.55 isn't released for your stroke version /98.

Toengel@Alex

christopher
06-06-2012, 09:47 AM
strange you have almost all devices no? you must love philips