View Full Version : HTS7140 hangs after starting device

06-02-2012, 03:19 PM

I have my 7140 over one year and had no problems with it.
Yesterday i tried to start the device and it only displays starting on display and nothing happens (I'm able to turn on and turn off the device).
I've pugged out the device for whole night and it started to work but after turning it off again the problem appears again. Plugging out doesn't help. I have latest upgrade from Dec last year.
Am I alble to do something by myself or only service?

06-03-2012, 05:53 PM
Hi borysbw,

I have exactly the same problem. I bought my 7140 about nine months ago and once I loaded new firmware settings everything has worked fine; until today!! It only responds to Power ON/OFF and won't go beyond "Starting". I have plugged everything out and started again but to no avail.

Can anyone help please?

06-04-2012, 12:16 PM
Okay this is weird... Powered on my Hts7140 this afternoon and it starts and hangs with Starting displayed on the screen, same as described above. Nothing seems to get to out of this mode.. Possible firmware date bug ??

please help I have a Blu-ray stuck inside now..



06-04-2012, 12:17 PM

did you make a firmware update and leave a disc inside during the update process?


06-04-2012, 12:21 PM
Nope, just turned on the unit to watch something, no USB attached at the time. Firmware version can't recall, but have not updated it for months at least.

06-04-2012, 12:23 PM

try to cut power for 5 minutes and restart device again.


06-04-2012, 12:32 PM
Just tried that, disconnected fully for at least 5mins and repowered, same symptoms.

Only the power button works when in this state, other buttons have no effect.

Using the remote I can get changes like AUTO VOL using sound options button, which then stops the display of "starting" phase and goes into "OPTI IN" but no volume and you can't change the volume either via the remote or the unit itself.. Can cycle thru the sources then but still no output, the unit still seems to be in a locked state...


06-04-2012, 05:20 PM
Dear All,

I spoke today with Philips via help line diagnose= service.
Nothing can be done 'home made'.
They told me that diagnose will be tomorrow. I will let you know
what was the issue.


06-04-2012, 05:23 PM
And check of both coolers on the back are working. In my
case I think the left cooler was not working.

06-05-2012, 12:03 PM
I have a service rep. coming tomorrow will post results also... My left cooling fan does not seem to be working either.

06-05-2012, 01:05 PM
Hi guys,

Having left it turned off overnight it is now working again!!! I was able to get the DVD out that was trapped and all seems to be back to normal. Maybe by being off for so long it reset itself because it was definitely "stuck in a moment" that it couldn't get out of.

Would be interested to know if there is a fix becasue I have a feeling I haven't seen the last of this.

06-06-2012, 06:36 AM
Service rep. Picked up unit today, indicated it's a board issue, requires board replacement currently on order. Should be able to retrieve DVD after part replacement.

06-17-2012, 12:52 PM
Dear all,

As it was mentioned earlier: mainboard failure after overheating (both fan's replaced). I asked philips if this issue will re appear they told me that they cannot guarantee that so if next year same issue will occur. If yes it can be putted in trash the repair will cost almost the price of a new one.