View Full Version : Problem after upgrading to latest firmaware

06-03-2012, 07:57 AM
Hello, I am a long time Wacs user, first wacs7000 then 7500. Always using wachandler and was a member of old streamium cafe.

I have used my wars 7500 long time (4-5 years) and no problems, saw the new firmware 1.31 and upgraded.

First it started to loose connection to satelite station, then the buttons started to behave strange, when I increase or decrease the volume by a press it contious to increase or decrease until maximum or minimum. Then the buttons stopped working and finally it was only working with the remote.

I have to pull the cord out and try to start the wacs7500 and it now only starts 1 of 50 starts.

Could it be the firmware? I have tried to download it once more & upgrade firmware but ended up with same result, could i revert to old firmware (have deleted it so I do not have it on my computer).

Could it be the hard disk? But wouldn't the buttons work and it would boot normally? Or is it the end for my wacs....

Any inputs are helpful.


06-03-2012, 09:29 AM
I searched this forum an found http://www.supportforum.philips.com/en/showthread.php?3179-WACS-7500-trouble-with-starting-up-HArd-Disk

I opened my wac and one capacitor in the power supply has leaked and are "round". So I will replace and see if it will help.

Philips - Katerina
08-21-2015, 08:43 AM
Hello participants of the thread and forum members in general!

Hopefully your issue was dealt with and you are no longer facing it. Since the thread has been silent for some time now, I will proceed by closing it. If you still have the same question about the same issue or any similar issues arise feel free to start a new thread or contact one of us moderators to open this thread again.

Kind regards
Philips Katerina