View Full Version : 47PFL8404H NETTV Issue

Karl Ranseier
07-15-2012, 12:14 AM
Latest Firmware for 47PFL8404H dates back to 2010-08-25.

Aside from a heapload of issues in the used libs (and reported in the last 2 years), the firmware's NETTV function is borked. As soon as a DLNA Media Server is present, NETTV becomes unavailable.

Reproducability: Always
Firmware Version:

When NETTV is activated, the TV set resolves some Philips server via DNS and starts a HTTP Connection. In case a DLNA Server is present, the TV communicates with the DLNA Server, but shows no NETTV activity at all on the network side, while the TV set itself displays a 'starting connection' message.

NETTV: DHCP->[NETTV invocation]->DNS lookup->HTTP
NETTV+DLNA: DHCP->[NETTV invocation]->SSDP->DLNA / (No DNS/HTTP Activity)

The same behavior that occurs when a media server is present in the network at TV boot time is exhibited, when the TV operated a longer period in DVB reception. After watching TV for a while starting NETTV does nothing. No DNS lookups, no HTTP connection gets built up.

The issue seems to be more general.

Further Problems:

Seeking is not possible at all. When a NETTV stream is paused, after resuming the stream, the TV stops playback frequently. There was no sign of a network congestion, funny enough, the data packages kept flowing in, while the playback stopped. Seems to be a player issue.

07-26-2012, 03:56 AM
I haven't tried Net TV yet, but will do and see if I get the same problem. http://imagicon.info/cat/12-19/icon_smile1.gif

02-05-2013, 05:26 PM
I have the same problem with my 47PFL8404, see http://www.supportforum.philips.com/en/showthread.php?10707-47PFL8404H-12-NetTV-can-t-make-connection

Karl, did you manage to get a fix or response from Philips?

02-07-2013, 05:51 PM
Hi Karl,
I have the same TV, firmware and issue, however it seems that disabling all DLNA/UPnP/Bonjour computers on the network still doesn't allow the TV to connect to NetTV. Did you get a reply from Philips on a fix/update?