PDA

View Full Version : HTS9140/98 Subwoofer no sound



Ed Canaya
07-26-2012, 02:43 AM
I recently purchased the sound bar but after 10 days the sub woofer is not working(no sound). Firmware is updated to the latest version. I've been sending emails to Philips but i haven't gotten any replies from them. Any other cases like this?

kwinnie
07-27-2012, 02:34 AM
I recently purchased the sound bar but after 10 days the sub woofer is not working(no sound). Firmware is updated to the latest version. I've been sending emails to Philips but i haven't gotten any replies from them. Any other cases like this?

better go to service for a check. potentially there are several reasons and they are not that firmware related.
1) use it for too long (i dont know how long = too long) that it is burnt
2) the current is too significant while you turn it on, so it's burnt
3) there s no audio output passthrough to the subwoofer

these have to be checked and prescribed by service centre i think

Ed Canaya
07-27-2012, 02:46 AM
Hi Kwinnie! thanks for the reply. by the way, the sound-bar wasn't used that long cause i can only turn it on after i come back home from work so total usage is very little. maybe point 2 & 3 are possible cause.

Ed Canaya
08-01-2012, 06:38 AM
Just to update, Philips technician confirmed that i have a dead subwoofer. Im still awaiting for the replacement part. Will update you all guys soon.

Ed Canaya
08-04-2012, 04:27 AM
The subwoofer replacement still didn't solved my issue. Support here is very hard to get. How can i get Philips attention to help me solved this matter???? Been calling them again and again, saying will escalate blah blah blah.. A 10 day product that failed..still remains unresolved..Common Philips...

kwinnie
08-13-2012, 06:23 AM
how can it be? i mean why replacing subwoofer still doesnt solve your issue? ?_?
it's another dead set?

how s your case now with SGP consumer care?

Ed Canaya
08-13-2012, 08:04 AM
how can it be? i mean why replacing subwoofer still doesnt solve your issue? ?_?
it's another dead set?

how s your case now with SGP consumer care?

Hi Kwinnie,

According to Philips, there's some board issue with my head unit, so in the end they sent me a new set .

xiaohe
12-17-2012, 03:03 AM
Hi Ed, how is your new set?

The unit I bought also went to no sound after about one month with very light uses. I'm contacting Phillips for a replacement as well.

I'm wondering whether the problem is just unit-specific or general to all units of this hts9140 model? This would affect our decision on whether we shall ask for return & refund or just exchange it.

Thanks!