View Full Version : [MCI730] Internet radio doesn't work anymore

09-09-2012, 10:13 AM

Since few weeks, I couldn't listen to internet radios. Previously it worked perfectly but now, whatever the radio I try, I've it for exactly 60 seconds and after it stops. I must go back and select another radio to have again 60 seconds of sound.

During this time I always have the message of buffering (the menu are in French so I don't now the exact translation).

Does someone have and idea?

09-13-2012, 07:55 PM
I had exactly the same problem, except I had it for about two months.

I found your post a few hours when I searched for solutions (I found no solutions).

Close to unplugging the unit and send it for recycling, I decided to try some kind of reset and to my joy it seems to have done the trick.

Here is what I did:
- I pressed little power button on unit for a few seconds (until the screen wrote "good bye").
- I pressed litte power button again until the unit woke up, and then waited a few minutes more
- I entered 'Settings' / 'Internet Settings' / 'WiFi' / ... and reconnected to my wireless network
- I started listening to my Internet Radio channels

It still takes some 5-30 seconds of "buffering" before a radio channel becomes listenable, but after that it seems to function as I would expect.

Hope this is helpful for you too.

09-15-2012, 07:46 AM

Thanks a lot, I didn't think at all, to do a reset (fully stop the radio using the power button as you described).

So cool.

10-21-2012, 10:46 AM
So cool.

But only for a few time. After few days of normal performance, fully inoperative: no radio, no possibility to access to my DNLA music.

I reset it and now It works 1 minute!!!!

I'm starting to hate this product!

Philips - Katerina
08-27-2015, 01:09 PM
Hello participants of the thread and forum members in general!

Hopefully your issue was dealt with and you are no longer facing it. Since the thread has been silent for some time now, I will proceed by closing it. If you still have the same question about the same issue or any similar issues arise feel free to start a new thread or contact one of us moderators to open this thread again.

Kind regards
Philips Katerina