View Full Version : Problem with repairing SA3ARA

09-23-2012, 09:54 PM
I want to repair my device, but if I connect it to the PC (according to the instructions), I get the textbox asking to not disconnect the device from computer while repairing and nothing more happens for hours except CPU usage rises to 100%. By win task manager the songbird is running but if I try to cancel the operation or close that message box, it's not possible - I have to end the SB with task manager.
I tried to update the songbird but no help.
Any advise how can I get my player work again?

10-10-2012, 10:58 AM
Did you try with the little hole at the site to reset?

10-10-2012, 06:49 PM
Repairing process formatted the player's memory to raw. I got my player work again by StUpdaterApp (Prog. files\Philips\Philips Songbird Resourses\Firmware\SA3ARA\SA3ARA) but only with old firmware.
SB still crashing. Haven't tried it on other comp yet.

10-18-2012, 05:34 PM
Repairing process formatted the player's memory to raw. I got my player work again by StUpdaterApp (Prog. files\Philips\Philips Songbird Resourses\Firmware\SA3ARA\SA3ARA) but only with old firmware.
SB still crashing. Haven't tried it on other comp yet.

I dont know if you are still checking this website
if you still do, i have exactly the same problem you had.
I would like to use the method you used to reflash the old firmware into the gogear.
It would be very appreciated. Songbird bricked my device and im very upset right now.

I'd like, if you can, a guide of the steps you did and a download link to StUpdaterApp because i cant find it anywhere.

Thanks in advance

Maybe PHILIPS SUPPORT can actually help me?

10-18-2012, 09:31 PM
Hi, Sebastian! You'll find that app in the philips folder on your comp. Full way is described above but instead of SA3ARA you have to open folder with your devices name.
Where is the Prog files folder depends of the configuration of your comp but usually it locates on the drive C

10-19-2012, 04:11 AM
Thanks for your reply. I'll tell you more details describing whats happening now.

I wasnt looking hard enough. updaterapp was indeed where you pointed me but it didnt worked.
Since im using Windows 8 i went to an older laptop i have with Windows 7. Installed Songbird, found the updaterapp, the app finds my Gogear Ariaz model SA3ARA(the same you have and repaired) and started flashing the firmware...tought everything was gonna be allright but then, Disaster. The flashing fails, a black screen with a white circle and white characters appears on my devices and the SA3ARA doesnt even turn on. After i freak out a little, i do the reset+power on trick.
To my surprise, my device turns on again and im back in step one. It only shows me the Philips Screen, UI Error (or something like that) and then turns off.

The thing is, updaterapp doesnt find the device anymore and always ask me to plug the device in.

Then, to verify Songbird ACTUALLY works, my next step was plugging in an older MP4 player i have (an SA2ARA) and then proceeded to update its firmware...after a while, and a little freak out after the device turned off (turned on later) it actually upgraded the firmware.

After upgrading my already working SA2ARA, then proceeded to use the recovery app on Songbird to fix my bricked(?) SA3ARA since the updaterapp was not working anymore. To my surprise(again), it actually detects my bricked device and proceedes to flash my device to factory settings and the actual "Upgrading Firmware" screen appears on the GoGear but since then i just dont know whats happening because the screens turns off after a while (just like in my SA2ARA when i was updating it) and it dissappears from windows as if it was disconnected. The thing is it doesnt turn on again and its just like it was disconnected from windows meanwhile Songbird is still "working" on getting my device to factory settings. (one hour after it turns off, its still "working")

Whats going on? is the recovery method really supposed to be THAT long?


Now that i read your first post carefully, the exact same thing is whats happening to me...CPU usage is really high and the taskmanager shows the updater and songbird being active


I just dont know anymore. I'll just report what happened so others can know what to do or what to expect.

I just tried over and over with the recovery app on Songbird. Went to Secure mode on Windows 7 (to use less ram)...tried like three times. Was (literally) posting here when i look over my other laptop, songbird's recovery app shutted down, my SA3ARA was turned off...i was trying to not get angry and try again when i glance over the laptop's screen (it installed some MTP drivers and i was repeating myself "no way") plugged out my device, turn it on for the lulz and MAGICALLY turns on again on FW 2.06

I honestly dont know what happened. Just kept trying and it flashed back

Will try to update again and see if it works...if it bricks, i know exactly what to do...complain to philips and try until it reflashes again

Philips - Katerina
08-27-2015, 01:58 PM
Hello participants of the thread and forum members in general!

Hopefully your issue was dealt with and you are no longer facing it. Since the thread has been silent for some time now, I will proceed by closing it. If you still have the same question about the same issue or any similar issues arise feel free to start a new thread or contact one of us moderators to open this thread again.

Kind regards
Philips Katerina