PDA

View Full Version : BDP9600 Issue on LFE downmixing



Philips - Remko
10-17-2012, 08:13 AM
Dear users,

We would like to assure you that we are still working on this issue. The issue is now under sanity testing stage. If everything is OK, we expect that the new FW can be released in Oct.

Thanks a lot for your patience on this.

Kind regards,
Philips Moderation Team

sopon
10-17-2012, 02:22 PM
We are crossing our fingers!!!
And we hope that it will be an 100% fix, without compromises or side effects!

sileem
10-18-2012, 05:07 PM
How about "multichannel analog audio output and video synchronization", will it also be fixed?

Stormen
10-19-2012, 01:05 PM
Awsome work !!! tnx for the feedback about the evolution process :-)

kvic
10-21-2012, 04:24 PM
Why does it take months to fix a defect like this?

Philips - Remko
11-09-2012, 05:37 AM
Dear users,

During the testings of the new firmware we found some bugs. We will let you know the revisted planning as soon as possible.

Kind regards,
Philips Moderation Team

Stormen
11-09-2012, 08:05 AM
ok, sad news, but tnx for the continued feedback. Thats one of the most important things on these kind of forums. Let us now as often as you can. lets say: every month, even if there is no news.

sopon
11-09-2012, 01:48 PM
We are checking the forum every day!
Please consider that 3 things are important;
1) That you are working on the solution
2) That there is a stable solution
3) That you are informing us on the progress.

Please keep in mind that our patience is measured in years now!

Toengel
11-09-2012, 01:49 PM
Hi,

so - the magic number is 2 (years)... 2 is a small number :D

Toengel@Alex

sopon
11-12-2012, 01:52 PM
Although i believe that the team is working on the solution of the LFE problem, i would not recommend anyone to exceed the 2 years warranty of his product.
In this case, one should demand Philips to give his money back or replace his product at least with the new model (provided that it works ok!).
Don't forget that the result of waiting for so much time, is that we have an old model now and still not working properly!

Desperate Dan
11-14-2012, 12:11 PM
I'm also looking for reassurance that the analogue audio sync issue is going to be fixed in this release.

I've upgraded from a 720p projector to the Panasonic PT-AT5000E HD 3D projector but now Lip sync is a mess, even SD DVD is off.

My HD satellite box is connected the same way with no sync problem.

The projector has no audio outs.

If this release doesn't fix this, then if you have a non-HDMI amplifier and your display is one that does enough picture processing to need audio sync then:
The 7.1 Audio outputs are useless
The TI Burr-Brown DACs which were a selling point are useless
The Digital Optical output is useless
The Digital Coaxial output is useless

Can we expect a fix?

Philips - Remko
11-16-2012, 11:05 AM
Dear users,

As said in my post on the 9th there were some bugs found during the testing of the new firmware. We are currently still working on the new one but I cannot give you any exact date on the release.

Kind regards,
Philips Moderation Team

sileem
11-30-2012, 03:54 PM
Hello Phillips

Can you inform us, will the analog audio Lip sync problem also fixed with this new firmware???

Philips - Remko
01-18-2013, 08:35 AM
Hi Sopon,

I have send you a personal message. Please check your inbox.

Kind regards,

Stormen
02-28-2013, 08:17 PM
Any progress since november ?

9600epicfail
03-18-2013, 07:22 PM
I agree with sopon,
my 2 years warranty of this product is coming to an end, I haven't seen the promised new firmware.
I still got a product that's not working properly (analogue audio sync issue), do you want us to wait for another 2 years Philips?

BTT
03-29-2013, 12:59 PM
Well,

now we're one year after the previous firmware update, leaving me with a BDP which still doesn't work as expected in my stereo setup. I've been happy with my Philips TV and thought adding a matching BDP was a good idea. However, this bug with missing LFE when playing blu-rays (again, in Stereo) prevents me from enjoying the movies as the missing part of the sound content is quite noticeable (I have full output to below 30Hz in my setup).

So, thus far you've lost €4000 that I'd have spent on upgrading to a new Philips tv (ambilight is fantastically addictive) by leaving this bug unfixed.

If you'd like me to consider a Philips product again, this must be fixed. And it really shouldn't be months between updates in this thread.

sopon
07-04-2013, 03:39 PM
Sad day for me! Honestly.
After 2+ years, dozens of calls and mails, Philips Hellas accepted ONLY to give me back my 328 Euros for my 9600 because of the LFE problem.
They were not able even to replace it LIKE ALL THE OTHERS with the 9700, difficult to send one here in Greece!!!
Never mind Philps, you do not have aftersales but you produce excellent electric shavers
(your only bug free product)!
Thank you very much!

sileem
07-04-2013, 06:24 PM
ONLY to give me back my 328 Euros for my 9600 because of the LFE problem.

Was the full price really so low?

Stormen
07-04-2013, 08:08 PM
They where sold out here in sweden at the very end for 303 Euros. ( its a good price) But I paid around 480 for mine.

kvic
07-14-2013, 04:11 AM
The past week in Hong Kong, there was a clearance sales of "refurbished units" in Philips showroom. ~220 euro. All units were quickly sold out as I heard from a local forum.

The way I see it is that 9700 is a really good beast but just that the firmware is not on par with its hardware design. A bit sad and hopefully Philips will continue to improve on the firmware.