View Full Version : HTB7530D/12 software update?

11-11-2012, 08:42 PM
Hello all,

I've recently purchased this Philips HTB7530D/12 home cinema system and I've run into an issue while trying to upgrade the software. According the information given by the HCS itself there is a software upgrade available however each time I try to execute the upgrade via network it fails. It starts out right by saying that the system is downloading the software from the server which could take a few minutes and to have patience. After a while, sometimes quick and sometimes quite long, I get a message that the system is unable to connect to the network (Philips server or my home network? because the latter is connected according the network information) and that I should retry at another time. So far I've tried at least 25 times with no result. Anybody here who could shed some light because I am in the dark on this one!?

Current version information:

System software: 1.00.01
Subsystem software: 12-00-01-05

Is there really a software upgrade for this system? If so, what is the latest version? And more importantly, how can I get my system's software upgraded to this latest version?

Thank you in advance for your time and replies. Kind regards,


11-12-2012, 12:49 PM
Did you download it via USB already? Version on the net is 3.0

11-12-2012, 01:54 PM
Oscar thanks for your reply.
The answer to your question is 'no' as I am not sure whether or not there is a new version for the system software. The way I understand the information given in the PDF file which goes with the upgrade to 3.0 zip file tells me that this is an upgrade of the electronic manual. Also, it states that the version number (3.0 for this upgrade) corresponds with the last two digits of the subsystem's version number which in my case is 05 and therefor seems newer ...

Or wait a minute ... does 05 mean 0.5 and therefor 3.0 is a newer version? I'll have to check that out.

Still, I think that it's silly to have an HCS capable to connect with the internet, with build in version check/upgrade module and then being forced to perform an upgrade by use of USB. Just my 2 cents.

Anyway, I'll give it a try and will report back ...

11-12-2012, 02:12 PM
Yes you are right...it looks indeed more as an upgrade for the manual.........strange

11-12-2012, 03:08 PM
Quick update ...

Just tried again to upgrade via the network option and this time it followed all the way through. However, at the end a message was displayed stating that the upgrade software did not pass control and to place the correct software. What gives???

I am still reluctant to try and upgrade via USB as I am not sure whether or not this would disable my HCS. Until now, the HCS has been working more or less correctly. The 'more or less' bit is still 'under investigation' as I am not sure whether it's just my ignorance or indeed flaws in the HCS.

01-20-2013, 11:04 AM
Hello again,

Since my last post I haven't been able to perform any software upgrade but what is worse is that I cannot get the HTB7530D/12 to start up anymore. Whether I try to start it up via HDMI-ARC or just via the power button, the system says it is starting up but that is all it does. The display reads: "starting" but nothing happens.

So far I can't say that I am very happy with this Philips home cinema set. Guess I will have to contact Philips and get the unit exchanged or my money back.

If there is anybody out there who has had the same experience and found a solution ... please speak up and let me know how I can fix this.

Thank you in advance,


01-20-2013, 11:05 AM

pull power cord for 5 minutes and start again. If it still does not work, call service.


01-20-2013, 11:11 AM
Hi Toengel, thanks for your reply.

Unfortunately without success I've done that already at least twenty times.
Tried to start up just the system without it being hooked up to my TV to rule out an HDMI cable problem with the same results as described earlier. Nothing!

I'll contact Philips tomorrow to see what they have to say and to find out what they will do to solve this for me.

01-31-2013, 10:12 AM
Got he same system, htb7590d/12
ARC doesn't work (yes connected it al properly), the system crashes some times and doesn't respond.
Also when i'm playing music, the back speakers whisper at high volume...
And the app. escpecially surroundme is not worling

03-03-2013, 08:28 PM
Hello all,

Again, a little update about the issues with my HTB7530D/12. After contacting Philips customer support I was asked to pack my unit securely in a box and drop it off at a local DHL pick up point. After receiving conformation that they had received my unit in 'good' shape it took their technical department 'only' 22 days to exchange the 'Pr audio rec', whatever that may be, and on top of that they've managed to perform an upgrade to the latest software version.
Ok, although it is my opinion that 22 days is rather long for any repair I could have lived with it if everything was now working properly. Unfortunately this is not the case!

Yes, the unit starts up again and everything seems to work. The only feature that I can't get to work is the HDMI-ARC function. This function was working properly before I've sent in the unit and now it's not. My TV (Philips 8000 series 2012) is giving the signal to the HTB and the HTB does start up. The TV speakers are being disabled and then there is ... nothing. The HTB7530D/12 remains in the 'HOME' modes and does not switch to 'HDMI-ARC', therefor no sound is being transferred to the HTB speakers. I've checked all the settings of both units and, to me, they are all good.

I will contact Philips customer support again but this time I won't settle for repair. They can change out the complete unit or my money back. I am open to an upgrade to let's say the HTB9550D/12 with some extra money from my side but they would have to settle to some discount. Let's see what their opinion is.

Meanwhile, if there is anybody here who might know a trick to get my current unit to work properly ... speak up please!



03-05-2013, 03:15 PM
Hello again,

Another update ...

After updating my TV to the latest software, resetting it to factory settings and resetting my Home Cinema Set to factory settings I then went ahead and started from scratch. Reconnected the whole lot and after start up everything is now working properly. I keep my fingers crossed but so far so good.

My tip for anybody with similar equipment and issues:

* Update the software to the latest edition on all components
* Reset all components to factory settings
* Start up all components and then adjust the settings to your personal liking

I am pretty happy that in the end all worked out fine because after contact with Philips Consumer Care it was clear to me that they were willing to see what they could do for me in terms of changing out the unit for another one but that was not going to happen overnight. For now, everything seems OK.